LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   4MLinux (https://www.linuxquestions.org/questions/4mlinux-115/)
-   -   PulseAudio (https://www.linuxquestions.org/questions/4mlinux-115/pulseaudio-4175609325/)

Edward4m 07-06-2017 02:00 PM

PulseAudio
 
Hello ZK!
Firefox told me to install PulseAudio in order to play audio. (Youtube)
I downloaded the PulseAudio-10.0.tar.xz file, turned it into an addon and managed to install the addon. It is there in the var/4mlinux/ file.
I am proud of myself getting this far.:-)
However, Firefox still asks me this question.
I was not surprised, though, I suppose there is more to it then just
installing this addon.
Perhaps the solution to this is in front of me and I fail to see it..

A little help, please..

Kind regards, Edward

PS, bought a HP 6730b laptop, ancient but in mint condition, 4mlinux runs like...!!

BW-userx 07-06-2017 02:04 PM

Quote:

Originally Posted by Edward4m (Post 5731551)
Hello ZK!
Firefox told me to install PulseAudio in order to play audio. (Youtube)
I downloaded the PulseAudio-10.0.tar.xz file, turned it into an addon and managed to install the addon. It is there in the var/4mlinux/ file.
I am proud of myself getting this far.:-)
However, Firefox still asks me this question.
I was not surprised, though, I suppose there is more to it then just
installing this addon.
Perhaps the solution to this is in front of me and I fail to see it..

A little help, please..

Kind regards, Edward

PS, bought a HP 6730b laptop, ancient but in mint condition, 4mlinux runs like...!!

did you try installing it into your system instead?

zk1234 07-06-2017 02:51 PM

Hi Edward,

Strange. Which 4MLinux version ?

Regards,
zk1234

BW-userx 07-06-2017 03:09 PM

Firefox Goes PulseAudio Only, Leaves ALSA Users With No Sound

ALSA support is dropped from Firefox 52 onward

zk1234 07-07-2017 04:40 PM

Quote:

Originally Posted by BW-userx (Post 5731587)
Firefox Goes PulseAudio Only, Leaves ALSA Users With No Sound

ALSA support is dropped from Firefox 52 onward

Yes, I know. 4MLinux uses Apulse to have sound in Firefox:
http://4mlinux-releases.blogspot.com...-released.html

.

zk1234 07-07-2017 04:54 PM

@Edward4m

There are the following two possibilities:
1) You are running 4MLinux older than 21.1. If so, please update it.
2) You are trying to run Firefox directly (and not via the 4MLinux JWM menu). If so, you should add /usr/lib/apulse to the /etc/ld.so.conf file:

Code:

/lib
/usr/lib
/usr/lib/apulse

Execute the ldconfig command afterwards.

PS.
Your new/old HP is not bad :-)

.

Edward4m 07-08-2017 05:07 AM

Quote:

Originally Posted by zk1234 (Post 5732161)
@Edward4m

There are the following two possibilities:
1) You are running 4MLinux older than 21.1. If so, please update it.
2) You are trying to run Firefox directly (and not via the 4MLinux JWM menu). If so, you should add /usr/lib/apulse to the /etc/ld.so.conf file:

Code:

/lib
/usr/lib
/usr/lib/apulse

Execute the ldconfig command afterwards.

PS.
Your new/old HP is not bad :-)

.

This did the trick! (/usr/lib/apulse wasn't there as you mentioned.)
I do use JWM (WBar) to start Firefox, and allways use the latest 4m version. (and nothing more.:))
I tried to install pulseaudio-10.0.tar.bz, but got on error.
Anyway, I can trash this download and addon.
Many thanks!!:thumbsup:


Off topic: Got this error. (Compiler)
Perhaps you like to know or not, it's up to you.

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... build-aux/install-sh -c -d
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets $(MAKE)... no
checking whether make supports nested variables... no
checking whether UID '0' is supported by ustar format... yes
checking whether GID '0' is supported by ustar format... yes
checking how to create a ustar tar archive... gnutar
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for stow... no
checking whether make supports nested variables... (cached) no
checking whether ln -s works... yes
checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: in `/root/Downloads/pulseaudio-10.0':
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details
root@4MLinux:~/Downloads/pulseaudio-10.0$

zk1234 07-08-2017 08:04 AM

Hi,

Good to know that your Firefox works :-)

PS.
The output posted by you indicates that development packages are not installed.
You can find them on the 4MLinux Live CD and online.

.

BW-userx 07-08-2017 08:06 AM

Quote:

Originally Posted by zk1234 (Post 5732154)
Yes, I know. 4MLinux uses Apulse to have sound in Firefox:
http://4mlinux-releases.blogspot.com...-released.html

.

not to side track too much - but whats so nice about 4MLinux? what is it a derivative of? their page doesn't really say a lot. what maintenance and app install system do they use?

only 1GB to install? no extra packages ?
is there repo sparse or not?

says you got slack and 4Mlinx on your side bar -- dual boot working okey Dokey then?

- I got a tri boot as it is on my lap top, what about a quad boot? does it play nice with other Linux Distros in that respect?

can it be ran off USB Stick as it states something about using it with a DVD?

it has its own little space in here for posting to - so it got a be a at the least a little special -- so whats so special about it? :D

zk1234 07-08-2017 08:15 AM

Quote:

Originally Posted by BW-userx (Post 5732402)
not to side track too much - but whats so nice about 4MLinux? what is it a derivative of? their page doesn't really say a lot. what maintenance and app install system do they use?

only 1GB to install? no extra packages ?
is there repo sparse or not?

says you got slack and 4Mlinx on your side bar -- dual boot working okey Dokey then?

- I got a tri boot as it is on my lap top, what about a quad boot? does it play nice with other Linux Distros in that respect?

can it be ran off USB Stick as it states something about using it with a DVD?

it has its own little space in here for posting to - so it got a be a at the least a little special -- so whats so special about it? :D

What do your questions have to do with Pulse Audio ?
Start a new topic if you wish so.

.

BW-userx 07-08-2017 08:16 AM

Quote:

Originally Posted by zk1234 (Post 5732409)
What do your questions have to do with Pulse Audio ?
Start a new topic if needed.

.

oh and I just seen on your side bar says,
zk1234
4MLinux Maintainer

interesting. have a nice day :D


All times are GMT -5. The time now is 10:50 AM.