LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > 4MLinux
User Name
Password
4MLinux This forum is for the discussion of 4MLinux.

Notices


Reply
  Search this Thread
Old 07-22-2020, 02:51 PM   #1
heistein369
LQ Newbie
 
Registered: May 2020
Posts: 15

Rep: Reputation: Disabled
4MLinux ~ Do I have to set locale time after each system power off?


I am running 4Mlinux 33.0
I have to go to MENU > Settings > Locale > Locale time
after each system shut down to set time correctly.

Is there any like "autostart" setting for the system time like is in slacko-puppy linux please?
 
Old 07-22-2020, 03:23 PM   #2
zk1234
4MLinux Maintainer
 
Registered: Oct 2010
Location: Poland
Distribution: 4MLinux, Slackware
Posts: 1,036

Rep: Reputation: 192Reputation: 192
4MLinux remembers these settings, of course. I have no idea what is wrong with your setup.

.
 
Old 07-23-2020, 02:44 AM   #3
heistein369
LQ Newbie
 
Registered: May 2020
Posts: 15

Original Poster
Rep: Reputation: Disabled
Unhappy I am sorry.

I wanted to make the 4Mlinux my everyday use OS. I really like 4Mlinux. Setting the time each time I start the system so that I can browse the Internet is quite uncomfortable. I will be forced to give up because of that.
This is not for everyday use.
 
Old 07-23-2020, 05:07 AM   #4
zk1234
4MLinux Maintainer
 
Registered: Oct 2010
Location: Poland
Distribution: 4MLinux, Slackware
Posts: 1,036

Rep: Reputation: 192Reputation: 192
How do you connect to the Internet. Is that WiFi ?

.
 
Old 07-23-2020, 06:31 AM   #5
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware
Posts: 4,472
Blog Entries: 11

Rep: Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551
Most distros have a file called /etc/localtime which is either a link to the locale timezone in /usr/share/zoneinfo or an actual copy of that file. You could look for that.
 
Old 07-23-2020, 09:15 AM   #6
zk1234
4MLinux Maintainer
 
Registered: Oct 2010
Location: Poland
Distribution: 4MLinux, Slackware
Posts: 1,036

Rep: Reputation: 192Reputation: 192
Quote:
Originally Posted by hazel View Post
Most distros have a file called /etc/localtime which is either a link to the locale timezone in /usr/share/zoneinfo or an actual copy of that file. You could look for that.
Actual copy in 4MLinux. Therefore this may be a problem with a battery and/or a hardware clock.

.

Last edited by zk1234; 07-23-2020 at 09:21 AM.
 
Old 07-23-2020, 09:23 AM   #7
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, fedora,Xubuntu, others
Posts: 4,494

Rep: Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800
The op is multi-booting with puppy linux and windows. I think 4mlinux runs ntpd at startup, maybe a network connection and/or timing problem between when ntpd is ran versus when network is up
 
Old 07-23-2020, 09:36 AM   #8
heistein369
LQ Newbie
 
Registered: May 2020
Posts: 15

Original Poster
Rep: Reputation: Disabled
Question I am connect to inthernet via ethernet cable

I found the two files ( /etc/localtime and /usr/share/zoneinfo ) but File type = unknown
I am not able to open them yet.
 
Old 07-23-2020, 09:42 AM   #9
zk1234
4MLinux Maintainer
 
Registered: Oct 2010
Location: Poland
Distribution: 4MLinux, Slackware
Posts: 1,036

Rep: Reputation: 192Reputation: 192
Hi again,

1) Download this updated package:
https://sourceforge.net/projects/lin...d-8.1.4.tar.xz

2) Install it:
zk addon_dhcpcd-8.1.4.tar.xz

3) Reboot

I do hope that this solve your problem.

.
 
Old 07-23-2020, 09:44 AM   #10
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware
Posts: 4,472
Blog Entries: 11

Rep: Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551
/usr/share/zoneinfo should be a directory, the root of a tree that ultimately contains data files for time zones. /etc/localtime should be a file of type data according to post no.6. Something seems weird to me. How did you determine the file type? the simplest way is to run the file command.
 
Old 07-26-2020, 04:24 AM   #11
heistein369
LQ Newbie
 
Registered: May 2020
Posts: 15

Original Poster
Rep: Reputation: Disabled
I made that >
Quote:
zk addon_dhcpcd-8.1.4.tar.xz
>
but local time still isn't working.
 
Old 07-26-2020, 04:24 AM   #12
heistein369
LQ Newbie
 
Registered: May 2020
Posts: 15

Original Poster
Rep: Reputation: Disabled
local time still isn't working

I made that >
Quote:
zk addon_dhcpcd-8.1.4.tar.xz
>
but local time still isn't working.
 
Old 07-26-2020, 07:02 AM   #13
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, fedora,Xubuntu, others
Posts: 4,494

Rep: Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800
open a terminal and run
Code:
ntpd
does the time change to the correct time?
 
Old 07-26-2020, 07:33 AM   #14
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, fedora,Xubuntu, others
Posts: 4,494

Rep: Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800
do something like this
Code:
date +%T%p -s "12:10:30"
To make the time incorrect then
run
Code:
ntpd
to see if the time changes to the correct time, it will take a couple of seconds before it changes, maybe longer it you have slow internet.

Last edited by colorpurple21859; 07-26-2020 at 07:47 AM.
 
Old 07-27-2020, 07:15 AM   #15
heistein369
LQ Newbie
 
Registered: May 2020
Posts: 15

Original Poster
Rep: Reputation: Disabled
the command ntpd is not working

the command ntpd is not working
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
locale: Cannot Set LC_ALL to default locale: No such file or directory. asym Linux - General 11 10-24-2018 05:54 PM
cannot lock locale archive "/usr/lib64/locale/locale-archive": Permission denied when building Multilib Cross Linux from Scratch Gunnersky2002 Linux - Software 2 06-13-2018 09:28 AM
"locale not supported by Xlib, locale set to C" Irad Linux - Software 3 06-25-2006 03:59 PM
locale: Cannot set LC_ALL to default locale: Invalid argument GadgetWiz Mandriva 1 03-31-2006 11:38 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > 4MLinux

All times are GMT -5. The time now is 07:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration