LinuxQuestions.org
Help answer threads with 0 replies.
Home Forums Tutorials Articles Register
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices


Reply
  Search this Thread
Old 01-07-2005, 12:50 PM   #1
provkitir
Member
 
Registered: Jul 2004
Location: Mass
Distribution: Freebsd 5.3, Debian sid 2.6.7
Posts: 101

Rep: Reputation: 15
upgrade to freebsd 6.0 current clarifications


Hi

i use freebsd 5.3, but i'd like to have the binary packages available in freebsd 6.0 current, but i hate the old binaries for 5 and compiling firefox just produced one big bug and i'm sick of "rm firefox-bin.core" (although i'm not sayin that i expect less bugs with the 6.0 binaries)

I have read up on the whole thing, and i'd like some clarification, for someoen in my situation, who doesn't care to upgrading the system, but would like new *binaries* like firefox 1.0.7, do i still have to do cvsup using *-supfile? and buildworld and all that?

if i don't, great, please tell me how
if i do, is this the process:

use cvsup to get new src for the 6.0 system
make world and kerenl and install them with new src
(done?)

please help
thanks in advance
 
Old 01-07-2005, 01:53 PM   #2
sigsegv
Senior Member
 
Registered: Nov 2004
Location: Third rock from the Sun
Distribution: NetBSD-2, FreeBSD-5.4, OpenBSD-3.[67], RHEL[34], OSX 10.4.1
Posts: 1,197

Rep: Reputation: 47
If you're supping the ports with tag '.' you're getting the latest ports available.

If you're expecting RELENG_6 to be more stable than the system you have now, you're wasting your time. There's a reason that RELENG_(4|5) are marked -STABLE and RELENG_6 isn't...
 
Old 01-07-2005, 02:52 PM   #3
provkitir
Member
 
Registered: Jul 2004
Location: Mass
Distribution: Freebsd 5.3, Debian sid 2.6.7
Posts: 101

Original Poster
Rep: Reputation: 15
i don't expect 6.0 to be any less buggy, just easier to get the newest binaries (for testing/using/etc).

right now
if i get a binary say for firefox, i'll get the firefox 0.9.3 tbz when i do "pkg_add -r firefox". which i don't want.

now on freebsd.org/ports, there is a 1.0.7 tbz under the 6.0 current packages. i want my computer to automatically fetch that binary. and I wasn't clear on your "." comment, sorry. do i add that to a file?

thanks in advance
 
Old 01-07-2005, 03:07 PM   #4
frob23
Senior Member
 
Registered: Jan 2004
Location: Roughly 29.467N / 81.206W
Distribution: OpenBSD, Debian, FreeBSD
Posts: 1,450

Rep: Reputation: 48
NO... do NOT run 6.0 current for that reason.

Upgrade your ports tree instead. They are separate.

Put the following in a file (I keep it as /root/portsup)
Code:
*default tag=.
*default prefix=/usr
*default base=/usr/local/etc/cvsup
*default host=cvsup17.freebsd.org
*default release=cvs delete use-rel-suffix compress

ports-all
[replace cvsup17.freebsd.org with your closest cvs repository.]

Then run `cvsup /root/portsup` and it will upgrade the ports tree. I am running Firefox 1.0_7,1 right now and I am using 5.3 not 6.0.

Save yourself the headache... the ports are "relatively" separate from the src of the system itself. I say relatively because games/tank will build on 4.x but not 5.x for some reason. :P

Anyway... if you just want the latest programs... upgrade the ports tree not the src tree.

Last edited by frob23; 01-07-2005 at 03:09 PM.
 
Old 01-07-2005, 03:11 PM   #5
frob23
Senior Member
 
Registered: Jan 2004
Location: Roughly 29.467N / 81.206W
Distribution: OpenBSD, Debian, FreeBSD
Posts: 1,450

Rep: Reputation: 48
I stand corrected about games/tank... whatever the problem was has been resolved and it does build now. But that is an example of how it sometimes matters to the ports tree which version of the system you are running. But usually it doesn't.
 
Old 01-07-2005, 03:19 PM   #6
sigsegv
Senior Member
 
Registered: Nov 2004
Location: Third rock from the Sun
Distribution: NetBSD-2, FreeBSD-5.4, OpenBSD-3.[67], RHEL[34], OSX 10.4.1
Posts: 1,197

Rep: Reputation: 47
Edit: Nevermind. Posts while I was on another desktop have delt with the question.

Last edited by sigsegv; 01-07-2005 at 03:21 PM.
 
Old 01-07-2005, 03:48 PM   #7
provkitir
Member
 
Registered: Jul 2004
Location: Mass
Distribution: Freebsd 5.3, Debian sid 2.6.7
Posts: 101

Original Poster
Rep: Reputation: 15
hmm, before, i just installed the freebsd 5.3 without ports, and then manually got ports.tar.gz to install to compile the firefox 1.0.7 i have now. i guess one has to cvsup the tree to get the pre-compiled binaries. thanks
 
Old 01-07-2005, 04:51 PM   #8
frob23
Senior Member
 
Registered: Jan 2004
Location: Roughly 29.467N / 81.206W
Distribution: OpenBSD, Debian, FreeBSD
Posts: 1,450

Rep: Reputation: 48
Code:
cd /usr/ports
make index
The pkg_add program is going to try and get the version you have listed in INDEX-5 (or INDEX.db ... one or the other... they both contain the same data). If you upgraded your ports tree but see this problem you need to rebuild the INDEX file.
 
Old 01-07-2005, 08:29 PM   #9
provkitir
Member
 
Registered: Jul 2004
Location: Mass
Distribution: Freebsd 5.3, Debian sid 2.6.7
Posts: 101

Original Poster
Rep: Reputation: 15
hmm, i'm not sure we've been solving the right problem.

i do have the current port already, i need not update it.
i want the *binaries*. in short, the line "pkg_add -r firefox" still look for the package in:
ftp://ftp.freebsd.org/pub/FreeBSD/po...elease/Latest/
and i want to fetch from
ftp://ftp.freebsd.org/pub/FreeBSD/po...urrent/Latest/

i can't find the config file to change this, and making PACKAGEROOT='ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-current/Latest/" does not help, the pkg_add will look inside "ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-current/Latest/pub/FreeBSD/ports/i386/packages-5.3-release/Latest/"

please help
thanks in advance
 
Old 01-07-2005, 11:40 PM   #10
frob23
Senior Member
 
Registered: Jan 2004
Location: Roughly 29.467N / 81.206W
Distribution: OpenBSD, Debian, FreeBSD
Posts: 1,450

Rep: Reputation: 48
Quote:
The environment variable PACKAGEROOT specifies an alternate location for
pkg_add to fetch from. The fetch URL is built using this environment
variable and the automatic directory logic that pkg_add uses when the -r
option is invoked. An example setting would be "ftp://ftp3.FreeBSD.org".

The environment variable PACKAGESITE specifies an alternate location for
pkg_add to fetch from. This variable subverts the automatic directory
logic that pkg_add uses when the -r option is invoked. Thus it should be
a complete URL to the remote package file(s).
From the manpage. set PACKAGESITE to "ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/i386/packages-current/Latest/"
 
Old 01-07-2005, 11:43 PM   #11
frob23
Senior Member
 
Registered: Jan 2004
Location: Roughly 29.467N / 81.206W
Distribution: OpenBSD, Debian, FreeBSD
Posts: 1,450

Rep: Reputation: 48
If you read the manpage carefully you would see that PACKAGEROOT just changes the site itself "The fetch URL is built using this environment variable and the automatic directory logic that pkg_add uses..."

Confusingly enough... the PACKAGESITE variable "subverts the automatic directory
logic that pkg_add uses"
. Which is where your problem is coming into play.
 
  


Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Keeping FreeBSD 4.10-stable (current) vaworx *BSD 20 05-02-2005 10:38 PM
FreeBSD 5.3 current for AMD64 Mouse Config for X EnderWiggin1337 Linux - Newbie 1 01-24-2005 04:19 PM
What first upgrade kernel or upgrade slack 10.0 to current Kelean Slackware 7 01-16-2005 06:54 PM
FreeBSD 4.10-STABLE vs. 5.2.1-CURRENT entob *BSD 3 09-01-2004 03:30 PM
Is there a way to upgrade to current? trey85stang Debian 9 04-10-2004 10:43 PM

LinuxQuestions.org > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 09:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration