-   *BSD (
-   -   The Multiple Booting Nightmare After Christmas. (

menorux 12-27-2012 09:00 PM

The Multiple Booting Nightmare After Christmas.
I use Mint Maya as my daily driver, and was successfully dual booting it with CNC Linux. I then installed Ghost BSD, knowing that I would have to write it into the GRUB boot file.
Before i attempted to figure out how to get it to show up at boot, I installed Open Suse on my last partition.
That's when the nightmare began. Suse's boot file took over everything, and its the only choice I have now. I am on a live disk at the moment, and need to get it fixed pronto because I run my business off of the Mint partition.

I have a 1Gig space allotted for /boot. How do I clean this mess up, and make it so I have ONE boot file, seeing BSD and Linux distros?

malekmustaq 12-27-2012 11:25 PM


Hi welcome to your nightmare... ooops nah sorry, I mean WELCOME TO LQ!

If your suse uses Grub 2 there should be no problem, you can fix everything up to the previous Mint and the other (I don't know what is a CNC linux). With respect to the BSD you can easily chainload its own bootloader from the Grub.

Try run as root under suse:


~# update-grub
If your distro does not have an 'update-grub' command you can create one for you. Here is the code:


set -e
exec grub-mkconfig -o /boot/grub/grub.cfg "$@"

Hightlight complete code above, copy and paste to editor and save as "update-grub" at the folder /usr/sbin, and make it executable

~# chmod +x /usr/sbin/update-grub
then issue the command above as root

~# update-grub
wait until the system has completed its configuration.

You may try to reboot after completed. Also if Mint did not resurrect post here what you have there with these queries:


~# cat /boot/grub/grub.cfg
~# fdisk -l

Post them here so that our comrades are able to help diagnose your problem and provide fitting helper in pronto.


Another way is to boot from Mint LiveCD and activate your previous Mint boot up. Let us do this one by one. While running as live, you can do these:


~$ sudo -i
~# cd /mnt
~# mkdir mymint/
~# mount /dev/sd(your_mint_partition) /mnt/mymint
~# mount /dev /mymint/dev
~# mount /sys /mymint/sys
~# chroot /mnt/mymint
~# grub-mkconfig -o /boot/grub/grub.cfg
~# grub-install /dev/sda <NOTE: this if your hard drive is named as /dev/sda; examine first using "fdisk -l" Note also that in issuing command "grub-install" there is no 1,2,3.. partition, only "sda" since you are trying to print it into the MBR to boot again into Mint.>
~# telinit 6
<Remove the liveCD press Enter; watch if Mint reappears>

Check first what is your hard drive and partitions, which is Mint which is BSD which is CNC and don't mistake, be careful, always use pen and paper to note down partition identities in order to avoid delay.

Hope that helps... in pronto.

Good luck.

menorux 12-30-2012 04:08 PM

Thank you very much for your reply, I am now up and running. To tell you the truth, I didn't expect to get such a thorough answer.
...I should have registered for an account on here long before I did.
Thanks again,

malekmustaq 12-30-2012 07:20 PM


Rest assured your joy is shared by everyone in the LQ; it is our satisfaction that some one gnu/linux user has solved another system problem and has learned something new the way we do. Congratulations!

You may now mark (or click above) this thread as 'Solved' so that others experiencing similar problems shall easily benefit from your thread post.

Good luck.


All times are GMT -5. The time now is 11:16 PM.