-   *BSD (
-   -   Strange problem when trying to install (5.2.1) (

Eluzion 02-24-2004 09:01 AM

Strange problem when trying to install (5.2.1)
I have searched everywhere and simply can't seem to find a solution to this problem. =/

I'm trying to install FreeBSD 5.2.1. For some reason my computer never boots from the CD and I always have to use boot disks (can't change the boot order, only which devices are bootable from and I have my CD drive selected but it still doesn't work.). How I usually install my OS is use a windows 98 boot disk and start with cd drivers, then access the cd and run whatever I need to, to start the installation. On linux it was autorun.bat and windows it was winnt.exe. I couldn't find a way to do this on FreeBSD so I went ahead and got the FreeBSD boot disks (kern.fip and mtsroop.flp). I made the boot discs using fdimage.exe.

Now, I start the computer with the kern.flp boot disk in, and it begins the installation process. I get to the part where it says "Insert mtsroot.flp disc" and press enter. It does it's thing then gets to the "press enter to load kernel", or something along those lines. I press enter and it starts loading something (looks like it's detecting my devices) but half way through it or so it starts scrolling VERY fast with white text. I can't read what it's saying but it looks like it is the same message over and over. I can only read the very right side and it says 0x04837000. I tried resetting my BIOS settings to default like some people suggested when "hanging" at install, no go. I thought maybe it was because I had so many USB things plugged up so I unplugged all them and tried, still no go. One thing I did notice though, was after the mtsroot.flp was done loading I guess (before the, press enter to load kernel), I saw a message saying 'zf_read unexpected EOF'. I wonder if that has anything to do with it?

Hopefully someone knows the answer to this problem. Thanks!

shahriar 02-25-2004 09:33 AM

to start with, it might very well be a bad floppy situation. Therefore, it is highly recommended that you try booting from your CD-ROM.

to do so, try getting into the bios and then change the BOOT ORDER (currently it is "floppy-first", which should be changed to "cd-first", and then try.

if you still fail, try posting the make and model of your system, so someone with a similar system can post a step by step instruction.

All times are GMT -5. The time now is 12:41 PM.