-   *BSD (
-   -   PC-BSD OSS installation problem (

ReaperX7 07-05-2012 05:09 PM

PC-BSD OSS installation problem
I've tried using the ports release of OpenSound to get my CMI8788 (C-Media OxygenHD) sound card working but during boot the system has a panic and reboots endlessly, or attempting to manually start the oss daemon causes the system to freeze solid.

I tried the binary release from 4Front for FreeBSD 9 but the driver load but there is no sound regardless of what I do.

Any suggestions or should I just wait and see if submitting an inquiry to can get the CMI8788 driver added to the native BSD sound server in a future release?

hitest 07-06-2012 09:55 AM

FreeBSD 9.0 won't identify your hardware? I've had good luck with 9.0.

FreeBSD sound set-up

Maybe try this command?


# kldload snd_driver

ReaperX7 07-06-2012 03:50 PM

It won't identify it through the native BSD sound drivers because it's not yet included for support so I have had to fall back to the OSSv4 driver.

Here in lies the first problem. OSSv4 Open Source driver will compile fine and build correctly without errors. It's however when I attempt to load the module and start the sound daemon that the system freezes up requiring a hard reset and if I attempt to autoload the module at startup the system gets a failure panic and auto-reboots.

I have attempted the binary distributed driver and it will more or less do the same thing.

The card I have is a C-Media 8788 Oxygen HD based/rebranded ASUS Xonar DX.

To be honest I have never had luck getting a driver from OpenSound working at all on any system I have ever used when I have used Linux or BSD based systems.

I followed these EXACT instructions from 4Front to get the binary driver working but it would not produce any sound.
  1. Login as root or superuser
  2. cd /usr/src/sys/i386/conf (for 32bit CPUS) or /usr/src/sys/amd64/conf (for 64bit CPUs)
  3. Edit the file GENERIC
  4. Comment out all the lines under Sound Support as follows:


    # Sound Support
    #device sound                # Generic sound driver (required)
    #device        snd_es137x        # Ensoniq AUdioPCI ES137x
    #device        snd_hda                # Intel High Definition Audio
    #device        snd_ich                # Intel, Nvidia and other ICH AC'97 audio
    #device        snd_uaudio        # USB Audio
    #device        snd_via8233        # VIA VT823x Audio

  5. type: config GENERIC
  6. type: cd ../compile/GENERIC
  7. type: make cleandepend && make depend
  8. type: make; make install
  9. type: reboot to reboot your new kernel

I even attempted this for the Free driver from ports:
  1. Some of the sound cards driver module are not available in the kernel, it will need to use the OSS (Open Sound System driver) ports in /usr/ports/audio/oss. Install it by :

    cd /usr/ports/audio/oss
    make install clean

  2. Insert the line :

    into /etc/rc.conf
  3. Start the OSS service by :

    /usr/local/etc/rc.d/oss start
  4. To check whether the device driver for the sound card works or not, use

    cat /dev/sndstat
  5. Cross your finger and hope that the sound card driver module from OSS works.

The problem with Method 2 is when I get to Step 4, the system locks up and has to be manually reset and powered down to reboot, and if I add the rc.conf line, the system goes into an infinite reboot loop unless I select the Windows OS I use on the system as well.

I don't know what I'm doing wrong on my end but this is getting very frustrating.

hitest 07-07-2012 11:10 AM

Bummer. I'm guessing that other BSDs also fail to enable sound on your box? I've had good luck with OpenBSD.

ReaperX7 07-07-2012 07:46 PM

I think I'll wait. I emailed the PCBSD support for a support request so hopefully they'll answer.

I'll leave the topic open for now as unsolved until I can find a solution that works.

hitest 07-07-2012 10:57 PM

Best wishes, man! :)

ReaperX7 08-29-2012 09:20 PM

Update... I've started an upgrade to Free/PC-BSD 9.1 RC1 to test the system and see if support has been added yet. I've been using the mailing list for help and assistance "freebsd-support" so I'm hoping the problem is getting worked on.

I also was finally able to generate this sound card detection log output:

none3@pci0:5:4:0: class=0x040100 card=0x82751043 chip=0x878813f6 rev=0x00 hdr=0x00 vendor = 'C-Media Electronics Inc' device = 'CMI8788 [Oxygen HD Audio]' class = multimedia subclass = audio

igadoter 09-08-2012 08:28 AM

Look at the forum I've got much help recently from the moderators.

All times are GMT -5. The time now is 06:42 AM.