LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices

Reply
 
LinkBack Search this Thread
Old 10-20-2010, 08:59 AM   #1
Alexvader
Member
 
Registered: Oct 2009
Location: Japan
Distribution: Arch, Debian, Slackware
Posts: 994

Rep: Reputation: 91
PC BSD 8.1.... wireless support for Broadcom


Hi

How do I enable wireless upport for a Broadcom BCM 4312 wifi card in PC BSD 8.1...?

When I installed it I couldn't help noticing that there were new kernel modules for wireless support being loaded.... but wireless does not work "out of the box"... what do I have to do to enable it...?

BRGDS

Alex

Edit: The interesting modules are wpi.ko, iwi.ko and ipw.ko... is there anything else that should be built/installed for my wifi to work...?

The light in my lappy remains red, despite that ifconfig shows the interfaces... should be blue... but this is in Linux... bsd is different...

Last edited by Alexvader; 10-20-2010 at 03:12 PM.
 
Old 10-21-2010, 09:25 PM   #2
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,277

Rep: Reputation: 166Reputation: 166
Hi Alexvader, Welcome to LQ. It appears the driver you need is bwi.

http://www.freebsd.org/releases/8.1R/hardware.html#WLAN

http://www.freebsd.org/cgi/man.cgi?q...SD+8.1-RELEASE

Good luck. ;-)
 
1 members found this post helpful.
Old 10-22-2010, 07:56 AM   #3
multios
Member
 
Registered: Mar 2006
Location: home
Distribution: OpenBSD, FreeBSD, Slackware, Debian
Posts: 228

Rep: Reputation: 39
Alexvader, if bwi doesn't work for you, then try the newer bwn.
I had to use it for my 4318.
http://www.freebsd.org/cgi/man.cgi?query=bwn&sektion=4
Note: this is available for FreeBSD 8.1
 
1 members found this post helpful.
Old 10-22-2010, 05:13 PM   #4
Alexvader
Member
 
Registered: Oct 2009
Location: Japan
Distribution: Arch, Debian, Slackware
Posts: 994

Original Poster
Rep: Reputation: 91
Hi @PeaceDog, @MultiOS

Tkz for your replies...

I added if_bwi to my loader.conf, or better, I just set it to "YES".... but no avail :

Quote:
[alex@pcbsd-5614] /usr/home/alex#ifconfig
bwn0: flags=8803<UP,BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 2290
ether 00:21:00:9d:98:c0
media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
status: no carrier
re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=389b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_UCAST,WOL_MCAST,WOL_MAGIC>
ether 00:23:8b:5c:fa:4e
inet6 fe80::223:8bff:fe5c:fa4e%re0 prefixlen 64 scopeid 0x2
nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
media: Ethernet autoselect (none)
status: no carrier
fwe0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8<VLAN_MTU>
ether 02:24:1b:e6:51:01
ch 1 dma -1
fwip0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
lladdr 0.24.1b.0.3b.e6.51.1.a.2.ff.fe.0.0.0.0
pfsync0: flags=0<> metric 0 mtu 1460
syncpeer: 224.0.0.240 maxupd: 128
pflog0: flags=0<> metric 0 mtu 33152
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=3<RXCSUM,TXCSUM>
inet 127.0.0.1 netmask 0xff000000
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x7
nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
lo1: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=3<RXCSUM,TXCSUM>
inet 10.1.1.1 netmask 0xffffff00
[alex@pcbsd-5614] /usr/home/alex# ifconfig bwn0 inet 192.0.2.10 netmask 255.255.255.0
ifconfig: ioctl (SIOCAIFADDR): Invalid argument
[alex@pcbsd-5614] /usr/home/alex#
And I did not find any if_bwn inside /boot/kernel... i will have to download this and build it from ports... right...?

Last edited by Alexvader; 10-22-2010 at 05:15 PM.
 
Old 10-22-2010, 06:54 PM   #5
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,277

Rep: Reputation: 166Reputation: 166
From:

http://www.freebsd.org/cgi/man.cgi?q...SE&format=html

Quote:
This driver requires firmware to be loaded before it will work. The
ports/net/bwi-firmware-kmod port needs to be installed before ifconfig(8)
will work.
From:

http://www.freebsd.org/cgi/man.cgi?query=bwn&sektion=4

Quote:
This driver requires firmware to be loaded before it will work. The
ports/net/bwn-firmware-kmod port needs to be installed before ifconfig(8)
will work. Most cases you need to use bwn_v4_ucode module but if you are
a LP (low power) PHY user please uses bwn_v4_lp_ucode module.
Good luck. ;-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broadcom in PC BSD 8.x Alexvader *BSD 3 07-09-2010 07:38 AM
Fedora 11 Support for Broadcom Wireless Card BCM94309MP lmcilwain Fedora 4 07-29-2009 06:39 PM


All times are GMT -5. The time now is 12:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration