-   *BSD (
-   -   OpenBSD CUPS bugs (

dchmelik 01-20-2013 01:08 AM

OpenBSD CUPS bugs
I tried to add a HP PhotoSmart 7350 printer in CUPS web administration on OpenBSD 5.2. It always returns an error about the printer description. CUPS says the printer description must be only up to 127 characters, and contain no spaces, nor '/' or '#.' (though the example description has spaces!) I tried with underscores, a null string, and one string of letters only and am always getting this error. I have heard of other people having this problem with letter-only strings.

Ztcoracat 02-02-2013 12:12 AM


Perhaps installing hplip will help. It did in my case with my HP Envy.

Here is driver support if you deem it helpful.

Which distro is giving you this issue with your HP printer?

Hope these suggestions help

dchmelik 02-02-2013 12:16 AM

I already got to the point of entering a HPLIP printer when I get this error. I stated I am using OpenBSD 5.2.

Ztcoracat 02-02-2013 12:36 AM

Got it; your running OpenBSD 5.2.-

Other folks are having a similar problem as you.

I'm searching for the solution-

When you can; please post your error message.

dchmelik 02-02-2013 01:34 AM

I solved the problem, or a similar one. I maybe had the wrong URI, then when I added it, it said the printer name had an error, so I followed instructions and the printer added. That gmane link above is about versions at least six years old that are not in OpenBSD 5.2, but the newsgroup they are in could be helpful.

I am having some more printing problems. When I checked there were cartridges and paper and tried a test print from the server, CUPS admin said the following.


stopped "/usr/local/libexec/cups/filter/pstotiff failed"
I am also having problems connecting to the printer from Windows, but this is a Samba problem, which I have a thread on, and I will start a new thread.

Ztcoracat 02-02-2013 01:44 AM


I solved the problem, or a similar one
Glad you solved it-

I looked up your error message-

This update fixes the following regression:
A missing "\" at the end of a line in /usr/lib/cups/filter/pstotiff causes this
whole filter to fail, resulting in not being able to print on at least
Photosmart 7050. This was reported [1] by Thomas Lottmann and has now been
Found this here:

dchmelik 02-02-2013 02:03 AM

Thanks; I will try fixing that soon. Here is the thread describing my Samba problems that prevent me from accessing the printer.

Ztcoracat 02-02-2013 02:09 AM


Originally Posted by dchmelik (Post 4882820)
Thanks; I will try fixing that soon. Here is the thread describing my Samba problems that prevent me from accessing the printer.

Your Welcome!

Have a good weekend!

dchmelik 02-02-2013 02:19 AM

I opened the pstitoff file mentioned in my error message, but it does not even contain a '\' character like the thread you linked to mentions. One of the lines it mentions is blank in my version, and the other it mentions does not look like the type that should have a '\.'

dchmelik 07-16-2015 01:38 AM

I am not using a printer with BSD right now, so I will mark this solved for my original question, and maybe the later thing is solved or I will not need to try it again.

All times are GMT -5. The time now is 10:20 PM.