Welcome to the most active Linux Forum on the web.
Go Back > Forums > Other *NIX Forums > *BSD
User Name
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.


  Search this Thread
Old 07-29-2004, 12:19 AM   #1
LQ Newbie
Registered: Jul 2004
Posts: 2

Rep: Reputation: 0
OpenBSD 3.4 Initial Login Problems

Recently I installed OpenBSD 3.4 on one of my old computers by following the guide posted on Necessary changes were made but they were few. After the installation was complete I took out the cd and rebooted my computer. The computer booted up fine. It prompted me for my login/password and I was proptly rejected. I was sure I remembered the login/password I had configured when I installed OpenBSD, but after an hour of failed attempts I decided to do the install again, this time using the same password and login that I use on my other computer. Unfortunatly it didn't work and I still can't log in. I know it isn't me this time.

Has this ever happened to anyone? Any suggestions for remedies or ways around this problem? Thanks for any help in advance.
Old 07-29-2004, 03:26 AM   #2
Senior Member
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
This is a long shot, but did you type your username in caps by any chance? If so, see section 7, OpenBSD FAQ

Another question is, when did you setup the user? If you tried to add a user immediately after the install (i.e. no reboot), I'm not sure if that's actually saved, since the file systems are mounted in different places during setup. Did you try logging in as root with the root password you gave during the install? There should be no way that logging in as root wouldn't work (as long as you remember what you used for the root password, of course).

If you were trying to add a user before rebooting, then trying to login as that user after reboot, try root instead. Don't create any new users until the system has been rebooted following the install.
Old 07-29-2004, 05:20 AM   #3
Registered: Jul 2004
Distribution: OpenBSD 3.5
Posts: 89

Rep: Reputation: 15
I recently installed OpenBSD 3.5 and during the install it did not give me the option to add any users. You set up a root password and that's about it until you reboot your system and then use useradd or adduser. I'm with chort on this one. Finish the install, then login w/ username root and the password that you set up.
Old 07-29-2004, 07:29 PM   #4
LQ Newbie
Registered: Jul 2004
Posts: 2

Original Poster
Rep: Reputation: 0
Originally posted by chort
This is a long shot, but did you type your username in caps by any chance?

Don't create any new users until the system has been rebooted following the install.
I remember it reminding me the the login is case sensitive so I was very carefull about that. The first time I installed I thought that maybe I hit caps inbetween the time in which you type the domain and when you give the password, and made sure I didn't do anything of the sort on the second install

And yes, i'm trying to log in as the root, which is why i'm so baffled. I didn't notice any point of the install which allowed me to create other users, I believe you do so after you log in as the root.
Old 07-29-2004, 07:50 PM   #5
Senior Member
Registered: Jan 2004
Location: Roughly 29.467N / 81.206W
Distribution: OpenBSD, Ubuntu, FreeBSD
Posts: 1,449

Rep: Reputation: 48
Well, you probably should reset the root password and just go from there. Who knows what happened.

When the computer starts and you get the prompt "boot>" before the timeout happens...

Type "boot -s" without the "'s

When the computer boots. Remount the drives rw -- this is usually done by typing "mount -a" but if your drives are dirty or your /etc/fstab is wrong you will have to do other things first. Chances are, since you get to a prompt normally, that won't be an issue.

After the partitions are remounted... type "passwd root" -- it is important to include the username because you are not 'technically' root in single user mode... you don't really exist on the system. It is root and it isn't... and it is better safe than sorry.

Type in your new password. then do a "shutdown -r now" to reboot into multi-user mode (there is a way to just continue the boot by exiting out of single user mode -- personally, I prefer to reboot for no good reason at all).

And everything should be fine. Hope this works.

Note, if you set your console as an insecure tty (not the default setting, even in OpenBSD as far as I know) you will need to enter the root password to get to single user mode. Using the install disks you can work around this but it is slightly more complicated and you shouldn't need to.

Last edited by frob23; 07-29-2004 at 09:28 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
X resolution at initial login screen billgatos Slackware 1 08-30-2004 03:30 AM
Can't get to Desktop; Initial Boot of SuSe 8.2 won't let me past Login Page bramfoto Linux - General 2 10-10-2003 12:46 AM
Can't get to Desktop; stopped at Login Page after Initial boot after install of SuSe bramfoto Linux - Software 1 10-09-2003 09:05 PM
initial login screen Tbassett Slackware 4 10-09-2003 06:43 PM
Slackware initial login greenbob Slackware 2 03-03-2003 09:22 PM > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 01:32 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration