-   *BSD (
-   -   Locating the device my first hard drive is bound to... (

LinuxBAH 12-04-2003 08:26 PM

Locating the device my first hard drive is bound to...
I want to mount my windows stroage drive that I purposely made to transfer files between os's. It's fat32 and is the first hard disk in the computer. It's an ide drive if that matters and is the 3rd partiition on the drive. I've tried several different mount commands and finally came to an error that told me I was getting somewhere I think...

"msdos: /dev/ad0s1*: Invalid arguement"

The asterisk replaces 1,2,3,4 all the different numbers I've tried. Before this error I was getting

"mount: exec mount_vfat not found in /sbin, /usr/sbin: No such file or director"

Now the latter message is from the format I'd use in linux. - mount -t vfat /dev/**** /mnt/windows. Whereas **** was the appriopriate location within the linux filesystem. I've looked thru man page but got a bit confused. I'm not really familiar with manually mounting filesystems. Back in linux when I used red hat or mandrake they would auto mount them for me. But one time I did have to set it up in fstab. Basically if someone knows a command that will list the current partitions I have that's all I need. If you can toss me the whole mount command.. mmmm I'll be greatful.

whansard 12-05-2003 07:51 AM

i think the filesystem type should be mdos or dos.
disklabel -l list stuff, if i remember correctly. it's been a long time.

RJW 12-05-2003 09:45 AM

The command to use is:

mount -t msdos <device> <mount_point>
With what you have posted, the drive should be `ad0s3', but if not, would you mind posting your list of `ad' devices listed in `/dev'?

All times are GMT -5. The time now is 07:53 PM.