-   *BSD (
-   -   installing FreeBSD on Virtual Box error: "Cannot dump. No dump device defined" (

Valkyrie_of_valhalla 09-01-2007 10:52 AM

installing FreeBSD on Virtual Box error: "Cannot dump. No dump device defined"
I thought of trying out FreeBSD and I thought it was a good idea to see what it's like on Virtual Box, but it seems to be unable to install.

After I put in the CD and select "Boot Freebsd", the kernel begins loading and I get the error:


Cannot dump. No dump device defined.
And then it reboots in 15 seconds.

Booting with no ACPI or in safe mode doesn't solve this issue.

I uploaded a screenshot of the error here:

I tried googleing, but I couldn't find an answer.

I'd like to understand what this problem is, and what exactly causes it, as others have experienced it while installing on their main computer, not in a virtual box.

Any ideas on what caused it or what I should try to get it working?

Thanks for reading. Any ideas are welcomed.

frob23 09-01-2007 12:36 PM

The error is not "Cannot dump. No dump device defined." The error is a kernel panic before that. You're seeing that message because there is no disk location to store the memory from the panicked kernel. There isn't anything to fix with the dump device.

This is happening while trying to start init (which appears to not be found) but the panic does not seem to be related to not finding init. That would produce a "no init" message. I only mention this at all because it's rare to see it cycling through init locations like that. And that is probably a symptom of the real problem. There is something going on which causes a page fault. Exactly what it is, I couldn't tell you from what I know.

What version of FreeBSD is this?
Have you tried booting another version and seen if you still get the error?

Valkyrie_of_valhalla 09-01-2007 12:47 PM

Thanks for your fast reply.

I tried version 6.2 . I'll try downloading 5.5 and see if I get the same thing, but it might take a while with my slow connection. I'll post back after I try that.

da1 09-01-2007 01:03 PM

i had the same problem on a katmai 450Mhz cpu with 128 sd ram. the problem was one of the DIMMs. i switched the memory module to the other one and all went well.

Valkyrie_of_valhalla 09-06-2007 04:02 AM

Thanks for the suggestion, but I don't think I can do that in a virtual machine... But it's good to know if something goes wrong when I install it in my main box...

I tried with FreeBSD 5.5. It freezes while displaying "/stand/sysinstall running as init on vty0".
Here is a screenshot from running it in verbose mode:

I also tried NetBSD (3.1 I think...). It worked on my main box a few months ago... With a normal boot it freezes after displaying "warning: no /dev/console". I tried boot -v and after a few dozen segmentation faults, saying something about no free space (on the cd-rom?) it launched an install menu! Now I didn't finish with the install, as I already tried it, and wanted something new, but it's behaviour in a virtual machine seems quite weird...

Don't know if this info might help in any way to find a solution, but... If you have any other ideas or suggestions, I would be greatfull.

All times are GMT -5. The time now is 01:03 AM.