-   *BSD (
-   -   how can I mount this device: da0: <USB 2.0 Storage Device (

alkad_mzu 11-15-2003 02:21 PM

how can I mount this device: da0: <USB 2.0 Storage Device
hello--- freebsd 5.1
I used this cocktail to mount my cdrom
#mount -t 9660 /dev/acd0 /cdrom
this worked fine. it's a cdrw but ill make the appropriate changes later.
for now all I want to do is access files previously burned on xp.

heres the question:
how can I mount this device:

da0 at umass-sim0 bus 0 target 0 lun 0
da0: <USB 2.0 Storage Device 0100> Fixed Direct Access SCSI-0 device
da0: 1.000MB/s transfers
da0: 38146MB (78125000 512 byte sectors: 255H 63S/T 4863C)

its a 40 gig western digital IDE hard drive encased in a ide to usb 2.0 case
the da0 info is a cut out of info I got from the dmesg command.
I normally like to cut and paste error messeges in to the search engine.
in my opinion it's the only way to go. I learned how to mount cdrom without having to log
into any graphical interfaces as root and use kwikdisk. this became very important to me because after I loaded agp and nvidia .ko into my kernel and loaded nvidia drivers with 3d acceleration, I have never been able to get KDE or gnome to work under root. window maker and afterstep work fine for root. Gnome, KDE and everything else work fine for users.

so I type:
mount /dev/da0 /mnt/da0
and I got this message:
mount: /dev/da0 on /mnt/da0: incorrect super block
I pasted this messege into and browsed the results.
I did alittle brain work and this what I did....
#cd /boot/kernel
(located umass.ko)- every diagnostics step that I have taken has identified my usb drive as umass.
#kldload umass
I accidentally typed kldload umass instead of kldload umass.ko so I inputted it
correctly and when I did this I got a message that said:
kldload: can't load umass.ko: File exists.
This lead me to believe that it makes no difference if you include the".ko" or don't.
please correct me if I'm wrong, im interested.

I also want to access my usbdrive with out having to wipe it out.
I read in the past that freebsd doesn't like to mount preformatted filesystem.
if anyone has any experience with large size usb 2.0 drive please share the wealth
thank thanks.

Arvoreen 11-15-2003 04:48 PM

If the disk is partitioned, you should see some further messages in the log. Look for something like this:

GEOM: new disk da0
[0] f:80 type:165 s(CHS): 0/1/1 e(CHS):521/224/63 s:63 l:8385867
GEOM: Configure da0s1, start 32256, length 42393563904 end 42935391659

GEOM: Configure d0s1b, start 0 length 536870912 end 536870911

And so forth.

At any rate, you can also check out /dev. You should see entries like this

What you will eventually want to mount is /dev/da0s1e, or whichever partition actually has your data on it. Then, you also need to know what the filesystem is on the partition. Assuming it is FAT (or FAT32), you could then mount as follows:

mount -t msdosfs /dev/da0s1e /<some directory>

Where <some directory> is an empty directory. On possiblity, do the following:

mkdir /winxp
mount -t msdosfs /dev/da0s1e /winxp

If the filesystem is NTFS, then I think you want to substitue as follows:

mount -t ntfs /dev/da0s1e /winxp

But I'm not 100% sure that NTFS is supported fully.

alkad_mzu 11-15-2003 06:15 PM

thanks for the reply
i tried mount -t dosfs /dev/da0 /mnt/da0 and i got "device is busy"
ive never partitioned the disk under freebsd
the disk usually just shows up when i plug it into a linux box.
i checked in /dev and i saw da0 but nothing else
i also tried to deal with the usb drive through /stand/sysinstall (fdisk)
create slice/ choose type= 6 (for dos fat) when i try to write the changes
i get an error messege that sais (segmentation fault core dumped)
i dont want to have to wipe the drive clean and freshly introduce it to the unix file system but if it easier i'll do it.

All times are GMT -5. The time now is 04:59 PM.