-   *BSD (
-   -   FreeBSD and issues with Xorg (

bshearer 04-19-2005 02:51 PM

FreeBSD and issues with Xorg

after a few weeks of openbsd i have switched to freebsd

i am still a newbie by many standards but the curve is getting better

here is the issue

XF86config has been switched with Xorg. with openbsd the config file was executed and the parameters were selected and BAMM it worked when startkde was issued.

on freebsd, after reading that xorgconfig replaced xf86config, should be a snap. well, it isn't

after searching the world over (google that is) i cannot seem to find the correct installation guide to get this off the ground and i would appreciate any help

it appears to have a couple of issues;

xsetroot: unable to display ' '
xset: unable to display " "
xsetroot: unable to display ' '
kwin: cannot connect to X server
kpersonalizer: cannot connect to X server (keeps repeating this line)


frob23 04-19-2005 02:56 PM

Okay, is this from an xterm or the console?

Did you do X -configure or copy the file from the old xf86 system (xorg doesn't have much problem using the old files... I never bothered to change mine when I made the switch until I added a second monitor)?

I need to know exactly how far you have gotten before I can try and help.

bshearer 04-19-2005 03:12 PM

breaker breaker - is this forum working
i've tried to post a reply twice now but no go

frob23 04-19-2005 03:14 PM

I see that one. ;)

bshearer 04-19-2005 03:15 PM

this is a new install so defaults were taken

i ran Xorg -config (it ran thats all i can say)

i did find xorgconfig (this was similar to xf86config - so i used my settings here)


the button problem is this (there is a post repy button and a Submit Reply button.

frob23 04-19-2005 03:17 PM

Okay, cp ~/ /etc/X11/xorg.conf

The try startx to see if X comes up. You should add startkde to you .xinitrc and .xsession files.

bshearer 04-19-2005 03:21 PM


the resolution changed. x windows keeps showing up and the mouse pointer no workie

bshearer 04-19-2005 03:28 PM

where will .xinitrc and .xsession be located (/usr/X11R6/lib/X11/xinit ??

frob23 04-19-2005 03:43 PM

In your home directory.

You have no mouse? Check the file to make sure it is pointing to the correct device... it should be.

bshearer 04-19-2005 03:53 PM

i am root user so there is no home directory - correct me if i am wrong

nope. no mouse

this is a dell c600 - touchpad. didn't think this was an issue since openbsd was able to use it too

looking at the config does not show a mouse

frob23 04-19-2005 04:10 PM

/root is your home directory.

2) You should use something other than root for X (because of security implications)

c] I'm betting it is picked up as /dev/psm0 -- did you configure the mouse at boot? If not put

in your /etc/rc.conf

bshearer 04-19-2005 04:47 PM

did not work

i am re-installing from scratch with a mouse attached

i will try all you suggested and post back the results in the am

thanks for your help and patience ;)

bshearer 04-20-2005 08:48 AM


copying the to /etc/X11/xorg.conf worked and the mouse is now working.

i edited the .xinitrc file and commented the xterm lines and the exec line at the bottom of the file and then i added startkde. that worked too! we going great now.

.xsession cannot be found anywhere on the HD and .xinitrc only exit in /etc/X11R6/lib/X11/xinit/ (if i got that folder right)

resolution is at 640 and there are no other options how can that be improved?

KDE did start but it looks like xterm on steroids. very odd looking.


frob23 04-20-2005 12:01 PM

You need to create both .xinitrc and .xsession in your home directory. They will not be found on the hard-drive because they are specific for each user. They allow one user to use KDE all the time and nother Fluxbox -- for example.

bshearer 04-20-2005 12:37 PM


no glitches, warnings or errors :D

resolution is stuck at 640x480 i would LOVE to get better than this. what is my path to acheive that ?

btw - thanks for all the help

All times are GMT -5. The time now is 06:25 AM.