LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices


Reply
  Search this Thread
Old 12-18-2013, 09:26 AM   #1
hitest
Guru
 
Registered: Mar 2004
Location: Canada
Distribution: Void, Slackware
Posts: 7,341

Rep: Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744
BSD Howtos


I thought it might be useful to start a thread on how to do some things on different versions of BSD. Please feel free to post your own howtos.

Here is a short explanation on how to install XFCE on OpenBSD 5.4.

After you have installed OpenBSD 5.4 login as your regular user and then get a root prompt. This is the ftp server I use.
Set your package pathway.

Code:
# export PKG_PATH=ftp://ftp3.usa.openbsd.org/pub/OpenBSD/5.4/packages/i386/
Install XFCE

Code:
# pkg_add -v xfce-4.10.tgz
Install XFCE goodies.

Code:
# pkg_add -v xfce-extras-4.10p0.tgz
I would do a re-boot and then login as your regular user. From your home directory issue this command as your regular user.

Code:
echo "exec startxfce4" > .xinitrc
Then issue this command which will launch XFCE.

Code:
startx
 
Old 12-18-2013, 09:39 AM   #2
pan64
LQ Addict
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 21,687

Rep: Reputation: 7274Reputation: 7274Reputation: 7274Reputation: 7274Reputation: 7274Reputation: 7274Reputation: 7274Reputation: 7274Reputation: 7274Reputation: 7274Reputation: 7274
why do you need a reboot?
 
Old 12-18-2013, 10:40 AM   #3
hitest
Guru
 
Registered: Mar 2004
Location: Canada
Distribution: Void, Slackware
Posts: 7,341

Original Poster
Rep: Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744
Quote:
Originally Posted by pan64 View Post
why do you need a reboot?
It is possibly not needed, but, XFCE is not as light a DE as it one was what with all the Gnome dependencies, etc. It does not hurt to be safe. I just like to have all new processes starting up properly at boot-up.
The series of commands above will yield a fully functional XFCE. I am certain of that.
 
Old 12-27-2013, 06:07 PM   #4
ReaperX7
LQ Guru
 
Registered: Jul 2011
Location: California
Distribution: Slackware64-15.0 Multilib
Posts: 6,554
Blog Entries: 15

Rep: Reputation: 2097Reputation: 2097Reputation: 2097Reputation: 2097Reputation: 2097Reputation: 2097Reputation: 2097Reputation: 2097Reputation: 2097Reputation: 2097Reputation: 2097
Xfce4 is still fairly lightweight compared to Gnome3 and KDE4. However most BSDs and other UNICES still use KDE4 as their heaviest weight desktop with MATE, Gnome2, Xfce4, and several others as their lighter weight desktops. I personally use Xfce4 as it's verily the most flexible.
 
Old 12-27-2013, 07:35 PM   #5
hitest
Guru
 
Registered: Mar 2004
Location: Canada
Distribution: Void, Slackware
Posts: 7,341

Original Poster
Rep: Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744
Quote:
Originally Posted by ReaperX7 View Post
Xfce4 is still fairly lightweight compared to Gnome3 and KDE4. However most BSDs and other UNICES still use KDE4 as their heaviest weight desktop with MATE, Gnome2, Xfce4, and several others as their lighter weight desktops. I personally use Xfce4 as it's verily the most flexible.
Agreed. XFCE is definately light weight compared to Gnome 3 and KDE 4. XFCE is my favourite DE for the BSDs and Linux.
 
Old 12-28-2013, 04:04 AM   #6
kooru
Senior Member
 
Registered: Sep 2012
Posts: 1,385

Rep: Reputation: 275Reputation: 275Reputation: 275
To install openbox on NetBSD:

Code:
pkg_add -v openbox
Then configure your ${HOME}/.xinitrc
Code:
exec openbox-session
Now with

Code:
startx
you can run openbox.

Other tasks:

Copy openbox files into your .config/ (use this files to customize your openbox)
Code:
cp -R /usr/pkg/share/examples/openbox/ ${HOME}/.config/
In addition, install dbus, hal and famd
Code:
pkg_add -v dbus
pkg_add -v fam
pkg_add -v hal
Copy their file into /etc/rc.d
Code:
cp /usr/pkg/share/examples/rc.d/dbus /etc/rc.d
cp /usr/pkg/share/examples/rc.d/hal /etc/rc.d
cp /usr/pkg/share/examples/rc.d/famd /etc/rc.d
Put these strings into rc.conf to autostart them
Code:
echo famd=YES >> /etc/rc.conf
echo rpcbind=YES >> /etc/rc.conf
echo dbus=YES >> /etc/rc.conf
echo hal=YES >> /etc/rc.conf
Start them now
Code:
/etc/rc.d/famd start
/etc/rc.d/rpcbind start
/etc/rc.d/dbus start
/etc/rc.d/hal start
About X11 on NetBSD you can read the official documentation.
To customize your openbox, there are many resources online (just one as example)

Last edited by kooru; 12-28-2013 at 04:35 AM.
 
1 members found this post helpful.
Old 01-04-2014, 01:07 PM   #7
angryfirelord
Member
 
Registered: Dec 2005
Distribution: Fedora, CentOS
Posts: 515

Rep: Reputation: 66
Two notes on your OpenBSD section.

I'd advise picking a mirror close to you. HTTP or FTP will work fine. There's plenty of mirrors to choose from: http://www.openbsd.org/ftp.html

The other thing is that pkg_add in OpenBSD doesn't need the specific version number of the package you want (contrary to FreeBSD). xfce and xfce-extras are sufficent. Be aware though that it will prompt you for an ambiguous dependency, but the first choice is usually fine.
 
1 members found this post helpful.
Old 01-04-2014, 02:19 PM   #8
hitest
Guru
 
Registered: Mar 2004
Location: Canada
Distribution: Void, Slackware
Posts: 7,341

Original Poster
Rep: Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744
Quote:
Originally Posted by angryfirelord View Post
Two notes on your OpenBSD section.

I'd advise picking a mirror close to you. HTTP or FTP will work fine. There's plenty of mirrors to choose from: http://www.openbsd.org/ftp.html
Yep. I pick a mirror that has proven itself to be reliable. I am more concerned about reliability than one that is closer to me. Picking a close mirror is indeed a good idea.

Quote:
The other thing is that pkg_add in OpenBSD doesn't need the specific version number of the package you want (contrary to FreeBSD). xfce and xfce-extras are sufficent. Be aware though that it will prompt you for an ambiguous dependency, but the first choice is usually fine.
Thanks. I forgot to mention that.
 
Old 01-10-2014, 08:48 PM   #9
iDavE
LQ Newbie
 
Registered: Jan 2014
Posts: 6

Rep: Reputation: Disabled
OpenBSD

Check if the PKG_PATH is set

Code:
echo $PKG_PATH
If not set, then edit the /etc/pkg.conf file and add your mirror. Below is my install path as an example

To query packages
Code:
pkg_info -Q <package name>
To delete package
Code:
pkg_delete /var/db/pkg/<package name>

Last edited by iDavE; 01-10-2014 at 08:49 PM.
 
1 members found this post helpful.
Old 01-13-2014, 01:26 PM   #10
BSDRocks
LQ Newbie
 
Registered: Jan 2014
Posts: 7

Rep: Reputation: Disabled
A good thread idea but lacking content. I guess not to many BSD users here in LQ :/

A good BSD youtube channel
http://www.youtube.com/user/bsdtutorial

Lots of good tutorials on the BSDs

Last edited by BSDRocks; 01-13-2014 at 01:30 PM.
 
Old 01-13-2014, 02:55 PM   #11
hitest
Guru
 
Registered: Mar 2004
Location: Canada
Distribution: Void, Slackware
Posts: 7,341

Original Poster
Rep: Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744
Quote:
Originally Posted by BSDRocks View Post
A good thread idea but lacking content. I guess not to many BSD users here in LQ :/

A good BSD youtube channel
http://www.youtube.com/user/bsdtutorial

Lots of good tutorials on the BSDs
The idea of the thread is for us to add content. Please feel free to add your how to if you wish.
 
Old 02-08-2014, 07:52 PM   #12
replica9000
Senior Member
 
Registered: Jul 2006
Distribution: Debian Unstable
Posts: 1,106
Blog Entries: 2

Rep: Reputation: 258Reputation: 258Reputation: 258
I'm trying FreeBSD 10, and it seems like I'm finding completely different steps to achieve the same result as thing mentioned above.

For instance, to install XFCE4, as "pkg_add: Command not found."
Code:
pkg install xfce4-wm-4.10.1
-- or --
cd /usr/ports/x11-wm/xfce4-wm
make install
Code:
echo 'dbus_enable="YES"' >> /etc/rc.conf
Code:
/usr/local/etc/rc.d/dbus start
 
Old 02-08-2014, 08:07 PM   #13
hitest
Guru
 
Registered: Mar 2004
Location: Canada
Distribution: Void, Slackware
Posts: 7,341

Original Poster
Rep: Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744Reputation: 3744
Quote:
Originally Posted by replica9000 View Post
I'm trying FreeBSD 10, and it seems like I'm finding completely different steps to achieve the same result as thing mentioned above.

For instance, to install XFCE4, as "pkg_add: Command not found."
[code]
To install XFCE in FreeBSD 10.0 issue this command:

# pkg install xfce
 
Old 02-08-2014, 08:39 PM   #14
JWJones
Senior Member
 
Registered: Jun 2009
Posts: 1,444

Rep: Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709
Battery monitoring in OpenBSD:

Get a list of sensors:

user@openbsd:~$ sysctl hw.sensors
...
hw.sensors.acpibat0.watthour0=4.35 Wh (last full capacity)
hw.sensors.acpibat0.watthour1=0.43 Wh (warning capacity)
hw.sensors.acpibat0.watthour2=0.00 Wh (low capacity)
hw.sensors.acpibat0.watthour3=3.24 Wh (remaining capacity), OK
hw.sensors.acpibat0.raw0=1 (battery discharging), OK
hw.sensors.acpibat0.raw1=1957 (rate)
...

Configure /etc/sensorsd.conf similar to:

# alert if remaining capacity < warning capacity
hw.sensors.acpibat0.watthour3:low=0.43Wh:command=/usr/X11R6/bin/xmessage "battery is low"

Start/restart sensorsd via sudo /usr/sbin/sensorsd or sudo pkill -HUP sensorsd

Set sensorsd_flags="" in /etc/rc.conf.local to stick around on boot.

If remaining capacity goes below the warning capacity, a xmessage pop-up will interrupt you.
 
1 members found this post helpful.
Old 02-08-2014, 08:46 PM   #15
JWJones
Senior Member
 
Registered: Jun 2009
Posts: 1,444

Rep: Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709
To suspend on laptop when lid is closed in OpenBSD, uncomment:

machdep.lidsuspend=1

in /etc/sysctl.conf

Last edited by JWJones; 02-08-2014 at 09:01 PM. Reason: to specify which BSD
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: FreeBSD/PC-BSD 9.1 Benchmarked Against Linux, Solaris, BSD LXer Syndicated Linux News 0 12-19-2012 06:31 PM
LXer: PC BSD 8.0 release made BSD much easier for desktop use | Installation and scre LXer Syndicated Linux News 0 02-26-2010 08:30 AM
PC BSD, Open BSD, or Free BSD ? Alexvader *BSD 5 02-08-2010 12:40 AM
Video For BSD --- New project to develop V4L compatible drivers for BSD Fritz_Katz *BSD 5 07-19-2008 11:53 PM
LXer: PC-BSD : A user friendly BSD flavor geared for the desktop LXer Syndicated Linux News 0 02-04-2006 03:01 PM

LinuxQuestions.org > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 11:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration