LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices


Reply
  Search this Thread
Old 05-15-2003, 10:27 AM   #16
cyberskye
Member
 
Registered: Feb 2003
Location: The City by the Bay
Posts: 116

Rep: Reputation: 15

Oops - just read that I don't have PM privs. Use my spam-eating email account:

leftinsane@yahoo.com
 
Old 05-15-2003, 10:30 AM   #17
deesto
Member
 
Registered: May 2002
Location: NY, USA
Distribution: FreeBSD, Fedora, RHEL, Ubuntu; OS X, Win; have used Slackware, Mandrake, SuSE, Xandros
Posts: 448

Original Poster
Rep: Reputation: 31
I can't PM or email you! But you should be able to email me using the email button. I don't mind doing a little search&replace work for your conf file! Thank you!
 
Old 05-27-2003, 01:40 PM   #18
deesto
Member
 
Registered: May 2002
Location: NY, USA
Distribution: FreeBSD, Fedora, RHEL, Ubuntu; OS X, Win; have used Slackware, Mandrake, SuSE, Xandros
Posts: 448

Original Poster
Rep: Reputation: 31
OK, to try and fix this, I removed all ports and installatins of apache (1.3 and 2), and just re-made the whole apache2 package. Now when I check the daemon with 'lynx http://localhost' or 'apache status' it's working fine.
However, when I go into httpd.conf and change the two values that seem to control the port number ('Listen' and 'ServerName'), it doesn't work. Do I need to change it elsewhere? As mentioned previously, my ISP does not allow 'traffic on port 80' on my machine, so I need to change the port.
 
Old 05-31-2003, 04:17 PM   #19
cyberskye
Member
 
Registered: Feb 2003
Location: The City by the Bay
Posts: 116

Rep: Reputation: 15
Hi Deesto. I thought we had you airbourne already .

What do you have in your file for Listen and ServerName ?

EDITTED FOR CORRECTNESS

Skye

Last edited by cyberskye; 05-31-2003 at 04:33 PM.
 
Old 06-02-2003, 09:46 AM   #20
deesto
Member
 
Registered: May 2002
Location: NY, USA
Distribution: FreeBSD, Fedora, RHEL, Ubuntu; OS X, Win; have used Slackware, Mandrake, SuSE, Xandros
Posts: 448

Original Poster
Rep: Reputation: 31
Hi Skye; I thought so too!
Here's what I have:
...
Listen 80
...
ServerName localhost:80
 
Old 06-02-2003, 01:31 PM   #21
cyberskye
Member
 
Registered: Feb 2003
Location: The City by the Bay
Posts: 116

Rep: Reputation: 15
Listen just tells it which port to bind to - otherwise it will bind to all ports.

For ServerName, did you try your FQDN:8080 (or whatever port you are running on)?

Are you using vhosting?

Skye

Quote:
when I go into httpd.conf and change the two values that seem to control the port number ('Listen' and 'ServerName'), it doesn't work.
What were they, and what did you change them to?
 
Old 06-02-2003, 01:53 PM   #22
deesto
Member
 
Registered: May 2002
Location: NY, USA
Distribution: FreeBSD, Fedora, RHEL, Ubuntu; OS X, Win; have used Slackware, Mandrake, SuSE, Xandros
Posts: 448

Original Poster
Rep: Reputation: 31
I'm running on Port 80 right now. It was the only way I could get anything to work! I would like to change it again later, once everything is working the way it should.
I'm not using virtual hosting; at least, I've not intentionally enabled it.
Here's my #old/new stuff:
...
#Listen 12.34.56.78:80
Listen 80
...
#ServerName new.host.name:80
ServerName localhost:80
....

Somebody on a mailing list said to just comment everything else out, and add a line:
Port <portNumber>
I don't know if that woud work, especially since "Port" is not included anywhere in the httpd.conf I have. Let me know what you think about that?
 
Old 06-02-2003, 05:47 PM   #23
cyberskye
Member
 
Registered: Feb 2003
Location: The City by the Bay
Posts: 116

Rep: Reputation: 15
Worth a shot. There are plenty of undocumented options


How exactly does it not work now? What are you doing to test? Localhost is a specific alias - you can;t use it to connect from another machine.
 
Old 06-03-2003, 08:43 AM   #24
deesto
Member
 
Registered: May 2002
Location: NY, USA
Distribution: FreeBSD, Fedora, RHEL, Ubuntu; OS X, Win; have used Slackware, Mandrake, SuSE, Xandros
Posts: 448

Original Poster
Rep: Reputation: 31
I can access the web site via 'lynx localhost' on this machine, or by browsing 'http:\\<myExternalIPaddress' from another machine on the network. When I try to access the site from an external machine, I get timeout\can't find server errors. I have already poked a hole in my router's built-in firewall for all port 80 traffic to be routed to the server, so I'm fairly sure there's something going on with the FreeBSD box that's not allowing non-local traffic to access port 80.
 
Old 06-03-2003, 11:52 AM   #25
5amYan
Member
 
Registered: Apr 2002
Location: The District
Distribution: FreeBSD, OBSD maybe Gentoo and Winblech XP
Posts: 291

Rep: Reputation: 30
Where are your DNS entries and what are they?

what is your domain?

dig your.domsin.here

what does it respond?``
 
Old 06-03-2003, 01:38 PM   #26
deesto
Member
 
Registered: May 2002
Location: NY, USA
Distribution: FreeBSD, Fedora, RHEL, Ubuntu; OS X, Win; have used Slackware, Mandrake, SuSE, Xandros
Posts: 448

Original Poster
Rep: Reputation: 31
Do you mean my local domain (istari) or my ISP's domain (optonline.net)?

Here's my /etc/resolv.conf file:
search Optonline.net
nameserver 167.206.3.209
nameserver 167.206.112.138
nameserver 167.206.7.4


(BTW: I keep adding the entry 'search istari' to this file, but something keeps removing it, and it's not me!!)

Here are my 'digs' and the results:
gandalf# dig istari
; <<>> DiG 8.3 <<>> istari
;; res options: init recurs defnam dnsrch
;; got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 2
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
;; QUERY SECTION:
;; istari, type = A, class = IN
;; AUTHORITY SECTION:
. 1h30m IN SOA A.ROOT-SERVERS.NET. NSTLD.VERISIGN-GRS.COM. (
2003060300 ; serial
30M ; refresh
15M ; retry
1W ; expiry
1D ) ; minimum
;; Total query time: 96 msec
;; FROM: gandalf.istari to SERVER: default -- 167.206.3.209
;; WHEN: Tue Jun 3 14:42:45 2003
;; MSG SIZE sent: 24 rcvd: 99

gandalf# dig optonline.net
; <<>> DiG 8.3 <<>> optonline.net
;; res options: init recurs defnam dnsrch
;; got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 2
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1
;; QUERY SECTION:
;; optonline.net, type = A, class = IN
;; ANSWER SECTION:
optonline.net. 32S IN A 167.206.5.7
;; AUTHORITY SECTION:
optonline.net. 23h59m49s IN NS ns.cv.net.
optonline.net. 23h59m49s IN NS ns.cvnet.com.
;; ADDITIONAL SECTION:
ns.cv.net. 18h5m5s IN A 167.206.1.30
;; Total query time: 12 msec
;; FROM: gandalf.istari to SERVER: default -- 167.206.3.209
;; WHEN: Tue Jun 3 14:44:01 2003
;; MSG SIZE sent: 31 rcvd: 109
 
Old 06-03-2003, 02:53 PM   #27
cyberskye
Member
 
Registered: Feb 2003
Location: The City by the Bay
Posts: 116

Rep: Reputation: 15
Does your ISP use protocol filtering? THat would block outside access to your webserver. What do you get when you ping the webserver DNS name - i.e. ping www.yourdomain.com. Does that resolve to your public IP address properly?

Since you can access via your LAN, I would imagine that your issue is either protocol blocking or DNS.
 
Old 06-03-2003, 03:06 PM   #28
deesto
Member
 
Registered: May 2002
Location: NY, USA
Distribution: FreeBSD, Fedora, RHEL, Ubuntu; OS X, Win; have used Slackware, Mandrake, SuSE, Xandros
Posts: 448

Original Poster
Rep: Reputation: 31
My ISP probably does anything possible to restrict its users, but I ran my web site successfully under Slackware with a very similar configuration and without ISP problems.
gandalf# ping www.optonline.net
PING www.optonline.net (66.54.41.147): 56 data bytes
64 bytes from 66.54.41.147: icmp_seq=0 ttl=244 time=12.973 ms
....

gandalf# ping istari
ping: cannot resolve istari: Unknown host
 
Old 06-03-2003, 05:10 PM   #29
5amYan
Member
 
Registered: Apr 2002
Location: The District
Distribution: FreeBSD, OBSD maybe Gentoo and Winblech XP
Posts: 291

Rep: Reputation: 30
DNS

If you want people out on the wild web to be able to see your site from outside. You need some authoritative DNS entry for your domain and host ot www or whatever.

else there is no way to translate ishtar.whatever.dom to its IP addy.

If you just want to beable to look it up on your own LAN you can edit the host files on the boxen and add
192.168.1.xx ishtar ishtar.domain.dom.
 
Old 06-03-2003, 06:00 PM   #30
cyberskye
Member
 
Registered: Feb 2003
Location: The City by the Bay
Posts: 116

Rep: Reputation: 15
Why are you pinging their webserver? I meant yours. What is your domain name? If it's ishtar.com then what happens when you ping www.ishtar.com (or whatever you plan on having your server repsond to)?

If you get "unknown host" or the like then you have DNS problems (at least)

If you get timeout messages, you know that DNS is ok, but that something is blocking - firewall, router, isp protocol blocking, etc

Last edited by cyberskye; 06-03-2003 at 06:02 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FreeBSD with MySQL/Apache Temujin_12 *BSD 2 11-15-2005 04:43 AM
Apache, MySQL and PHP with FreeBSD? Mega Man X *BSD 9 01-24-2005 05:08 PM
Platform: RedHat or FreeBSD for Apache 2 jj12345 Red Hat 2 10-29-2004 09:10 AM
Optimizing Apache for performance on FreeBSd !! apache Linux - Networking 1 07-28-2004 09:07 AM
Apache 2.0.48 on Freebsd 5.2 problems jamminparidise *BSD 5 03-05-2004 10:58 AM

LinuxQuestions.org > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 04:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration