LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   *BSD (https://www.linuxquestions.org/questions/%2Absd-17/)
-   -   Why is my mouse scroll not working? (https://www.linuxquestions.org/questions/%2Absd-17/why-is-my-mouse-scroll-not-working-163310/)

Honoriu 03-28-2004 05:53 AM

Why is my mouse scroll not working?
 
I have a scroll mouse: KeyMouse and I can't use my scroll. I don't know how to fix it. I tried from system settings, but it didn't work. What can I do?

Andrew Benton 03-28-2004 06:17 AM

Open /etc/X11/XF86Config in a text editor (you'll have to do it as root) and try some different settings in the section "InputDevice". The scroll wheel only works for me if I have it set to "IMPS/2" with the option "ZAxisMapping" set to "4 5" like so
Code:

Section "InputDevice"

# Identifier and driver

    Identifier        "Mouse1"
    Driver        "mouse"
    Option "Protocol"    "IMPS/2"
    Option "Device"      "/dev/psaux"
    Option "ZAxisMapping" "4 5"


rehab junkie 03-28-2004 07:38 AM

I have problems with the mouse protocol set to ImPS/2 (despite having a PS/2 Intellimouse) - I just leave it at "auto" and add the Option "ZAxisMapping" "4 5" line.

vinay_s_s 03-28-2004 04:46 PM

also the following line can be added just to be on the safer side:
Option "Buttons" "5"

mrcheeks 03-28-2004 05:00 PM

Revision of Andrew post
ode:
Section "InputDevice"

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"

*change IMPS2 by Auto, i believe he is a linux/windows only user.

*You can also add
Option "Buttons" "Mouse_NumberOfButtons"

kjogeva 05-05-2004 09:00 AM

With what I can edit the conf file??? I tried vi, but i can't save.:(



:newbie:

Stack 05-05-2004 09:24 AM

You need to be root to edit the file then just hit "esc" ":" "w" "q"

kjogeva 05-05-2004 09:32 AM

how can i be a root?

Stack 05-05-2004 11:59 AM

type in su
if you are part of the wheel group, or you need to log out and log in by hand as root


All times are GMT -5. The time now is 10:24 AM.