LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Home Forums Tutorials Articles Register
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices


Reply
  Search this Thread
Old 11-21-2014, 04:08 PM   #1
astrogeek
Moderator
 
Registered: Oct 2008
Distribution: Slackware [64]-X.{0|1|2|37|-current} ::12<=X<=15, FreeBSD_12{.0|.1}
Posts: 6,263
Blog Entries: 24

Rep: Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194
Where should I put vt options for boot?


I have updated my FreeBSD10.0 to 10.1 and would like to give vt a try to get utf8 console.

I initially enabled it in loader.conf but the default font size and screen resolution are all wrong for my system.

From man vt I find that I can set these as options...

Code:
SYNOPSIS
     options TERMINAL_KERN_ATTR=_attribute_
     options TERMINAL_NORM_ATTR=_attribute_
     options VT_MAXWINDOWS=N
     options VT_ALT_TO_ESC_HACK=1
     options VT_TWOBUTTON_MOUSE
     options VT_FB_DEFAULT_WIDTH=X
     options VT_FB_DEFAULT_HEIGHT=Y
     options SC_NO_CUTPASTE
     device vt

     In loader.conf(5):
     hw.vga.textmode=1
     kern.vty=vt

     In loader.conf(5) or sysctl.conf(5):
     kern.vt.kbd_halt=1
     kern.vt.kbd_poweroff=1
     kern.vt.kbd_reboot=1
     kern.vt.kbd_debug=1
     kern.vt.kbd_panic=0

...but I am unclear as to where these options should go to be read at boot time. loader.conf and rc.conf do not seem right.

===========================
Update - If I am understanding what I have read, the "option" lines above are kernel build options, NOT runtime options..?!? So I think that setting these requires a kernel rebuild...?

I have set a default video mode respected by sc (in rc.conf), but seems to be ignored by vt.

For the time being I have reverted to the sc console until I learn more about vt... need to get my only production BSD system back to work!

Last edited by astrogeek; 11-21-2014 at 05:00 PM.
 
Old 11-21-2014, 05:22 PM   #2
angryfirelord
Member
 
Registered: Dec 2005
Distribution: Fedora, CentOS
Posts: 515

Rep: Reputation: 66
Correct, the options are for building the kernel. FreeBSD 9.3 and 10 don't have vt enabled in the GENERIC kernel, but 10.1 does. You only need these two lines in /boot/loader.conf:
Code:
hw.vga.textmode=1
kern.vty=vt
The other options appear to be for 11-CURRENT, so I wouldn't use those yet.
 
1 members found this post helpful.
Old 11-21-2014, 05:38 PM   #3
astrogeek
Moderator
 
Registered: Oct 2008
Distribution: Slackware [64]-X.{0|1|2|37|-current} ::12<=X<=15, FreeBSD_12{.0|.1}
Posts: 6,263

Original Poster
Blog Entries: 24

Rep: Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194Reputation: 4194
Quote:
Originally Posted by angryfirelord View Post
Correct, the options are for building the kernel. FreeBSD 9.3 and 10 don't have vt enabled in the GENERIC kernel, but 10.1 does. You only need these two lines in /boot/loader.conf:
Code:
hw.vga.textmode=1
kern.vty=vt
The other options appear to be for 11-CURRENT, so I wouldn't use those yet.
Thanks for the reassurance!

I did not realize the incomplete state of vt until I began researching this problem... looks like a future feature still.

Still learning my way around FreeBSD, this was today's lesson!
 
  


Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help about dd command new options to put in bash script destinytia1 Linux - Newbie 10 03-08-2012 01:54 AM
Tomcat 6.0.24 - How do I disable DELETE, PUT, OPTIONS? szboardstretcher Programming 2 11-30-2011 08:12 AM
[SOLVED] Kernel boot options removed by fault, no boot options cdt Linux Mint 8 09-08-2011 11:25 PM
wireless Keyboard not working to select boot options (Grub boot loader) psrini_vasan Fedora 7 12-16-2009 05:45 PM
Grub boot loader menu shows two linux boot options pramos Linux - Newbie 3 09-12-2004 11:40 PM

LinuxQuestions.org > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 01:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration