LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   *BSD (https://www.linuxquestions.org/questions/%2Absd-17/)
-   -   Undefined Screen " XFree86" reference by serverLayout "XFree86 Configured" (https://www.linuxquestions.org/questions/%2Absd-17/undefined-screen-xfree86-reference-by-serverlayout-xfree86-configured-278922/)

comox 01-17-2005 01:47 PM

Undefined Screen " XFree86" reference by serverLayout "XFree86 Configured"
 
Hi,

I have a problem with my Xserver.
Trying to lunch it but I get the following error message:

"Undefined Screen " XFree86" reference by serverLayout "XFree86 Configured"

What does it mean and what can I do to fix it .

THanks,

leonscape 01-17-2005 02:13 PM

You need to alter your XF86Config. What you need to do is look what the identifier is in your screen section

Code:

Section "Screen"
 Identifier "Screen Configured"

Say it looks like the above change the serverlayout to match it like

Code:

Section "ServerLayout"
 Identifier "XFree86 Configured"
# Screen  "XFree86"
Screen "Screen Configured"

I've commented the line out with a hash, You can simply edit or delete it if you prefer.

comox 01-17-2005 05:40 PM

Hi,

Now the error message I get is:

" xf86Openserial: NO Device specified.
"Mouse: cannot open input Device
PreInit failed for input device "Mouse"

My mouse "InputDevice" section has the following configuration.

Section "InputDevice"
#Identifier and Driver

"Identifier " Mouse"
"Driver " mouse"


Some tell where is the mistake.

Thanks,

leonscape 01-17-2005 05:46 PM

I'm sorry but I'm reaching the limits of my knowledge with *BSD, but I think what's missing is the device line, which will be something like:

Option "Device" "/dev/input/mice"

But the device is almost defintaley not /dev/input/mice, you'll need to look at your distro's docs for that.

frob23 01-17-2005 06:18 PM

Code:

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/sysmouse"
        Option      "Buttons" "6"

Note: This is for a wheel mouse... fix the last line for the for your actual mouse.

comox 01-17-2005 06:26 PM

Great Frob23,

Now I'm done.

In case I want Freebsd to automatically start in graphical mode what should I do ?

Thanks,

frob23 01-17-2005 06:46 PM

Edit /etc/ttys

Change this line:
Code:

ttyv8  "/usr/X11R6/bin/xdm -nodaemon"  xterm  off  secure
to this:
Code:

ttyv8  "/usr/X11R6/bin/xdm -nodaemon"  xterm  on  secure

frob23 01-17-2005 06:47 PM

Note: make sure any user you want to log in through that has a valid ~/.xsession -- as ~/.xinitrc will not work. And make sure that ~/.xsession is executable.


All times are GMT -5. The time now is 02:15 PM.