LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   *BSD (https://www.linuxquestions.org/questions/%2Absd-17/)
-   -   Startx - Fatal server error, No screens found (https://www.linuxquestions.org/questions/%2Absd-17/startx-fatal-server-error-no-screens-found-138867/)

Optyx 01-26-2004 01:23 PM

Startx - Fatal server error, No screens found
 
I am new to BSD, in fact this is the first time i have ever tried it, i read up on it, liked the sounds of it and Replaced my nice Slackware installation with it.

I did the "Full Install" option and didnt really configure anything but the mouse and dhcp (wich didnt work cause i cant telenet).

Now im no where near advanced enough to start playing in black and white- i need a Gui for the time being.
But when i type in Startx i get fatal server error , no screens found.

Now i can not utelise this pc im using right now for much longer- i would appreciate a swift reply when you have the time - else i re-install slack and wonder what i might have missed out on.

rberry88 01-26-2004 01:32 PM

If you post your hardware specs (monitor, mouse, keyboard, graphics card)and the output of:
Code:

cat /etc/X11/XF86Config

or

cat /etc/X11/XF86Config-4

We would be able to help you alot more than just guessing which is what I think you are asking us to do now.

rberry88

Optyx 01-26-2004 01:41 PM

I little line at the top of the screen with a heart/spade and a few other weird misc objects.
When i move the mouse to the top where the objects are the mouse mirrors its self only where it has the jibbersish.

I am running a 4mb Rage / a Hewlett Packard mx50 monitor, the mouse is fine and working.

rberry88 01-26-2004 02:39 PM

I should have told you that you need to type that a text prompt since your X is not working, if you did then try hitting CTRL+ALT+BACKSPACE or CTRL+ALT+F2(F3)(F4) to see if you can get a working text prompt.

rberry88

Optyx 01-26-2004 03:06 PM

Thank God i got Knoppix in the mail the other day- i forgot about it and thought i was going to have to wait till the mother woke to post more quesyions etc.

Ok im on the un-working BSD box now (Through knoppix)

I am not to sure what you mean by text-prompt but i will give it a go anyway,

This is going to be annoying rebooting slack- and booting knoppix etc multiple times but i guess not everything in life is meant to be easy.
Im sure ( hoping) the outcome is worth the instal over slack.
As im sure it is.

Here goes nothing, ill post in 5.

Optyx 01-26-2004 03:42 PM

I cant figure it out, its not worth the hassle at this point in time anyway.

I have been told i am better of with a root-games box being a slack box than a bsd box anyway.

Thankyou for the help.
Maybey one day soon ill give it another go when i have supported hardware (wich bsd obviously lacks).
Back to slack we go.

rehab junkie 01-26-2004 09:29 PM

Supported/unsupported video cards are more a property of X than of the OS itself. I find it hard to believe that an ATi Rage video card is unsupported.

But we need to know more to help you - what's your distribution/revision? XFree86 version? Did you run XFree86 Config and Desktop Config from the sysinstall menu after installing BSD (if it was FreeBSD) or xf86config from a shell after installing? If there's no /etc/X11/XF86Config file X will not start.

Optyx 01-26-2004 11:39 PM

I am still behind Knoppix incase i do find an answer- i also was shocked that it didnt support this card, everything else has and i have installed well over 10 "Linux" distro's on this box.

I tryed running the config from the shell to the best o my knowledge- i did get a little vertical list of the cards to choose and my one of the last ones said ATI so im stil confused as to why it wouldent work.

rberry88 01-27-2004 12:54 AM

Its most likely due to the incorrect horizontal/vertical refresh rates that were set when you configured X. If you can edit the XF86Config file located in the /etc/X11/ directory then you can change the default resolution to 800x600 and insert the refresh rates from your monitor manual to get it up and running. From there you can adjust the resolution to 1024x768 or higher to see if it works.

rberry88

rehab junkie 01-27-2004 03:08 AM

From what I see (and know) of Rage cards, the ati driver should work for it. Care to post your XF86Config file for us? Or mail it to support - at - insaneinthemainframe.com and I'll have a look at it.


:)

frob23 01-27-2004 03:30 PM

If it still isn't working... have you looked at /var/log/XFree86.0.log? This file will tell you (near the end) what exactly is going wrong to keep X from starting. If you could maybe tell us where the errors start and what they say?

If your card works under 10 different linux distros there is no reason it would not work in FreeBSD.

Featherlinuxguy 05-07-2006 12:20 AM

Alright, im having the same problem. I have Debian 3.1 r2 installed and working on my Dell Optiplex GX400 but X wont start up. As with this guy i type

alex@debian: startx

and it spits out a bunch of info at me and near the end its giving me that same "no screens found" shit. Right now im on my laptop with the same distro (debian 3.1) and i dont konw whats going on. i tried doing what you guys said to the guy with the same problem but i dont know how to look at all these files that you guys are asking for info from. Help me masters of computers!

lysergicdiethylamide 05-07-2006 12:34 AM

hey sorry its been like a year since ive been on here, its feather linux guy. i cant beleve i actually used that piece of shit version for close to 2 whole months! but im still having trouble with X...

frob23 05-07-2006 06:12 PM

What have you done to configure it?

lysergicdiethylamide 05-08-2006 11:28 PM

im doing

alex@debian: dpkg-reconfigure xserver-xfree86

and i go through all the setup stuff for the video card (which is an ATI Rage) and then i just go through the rest.


All times are GMT -5. The time now is 09:39 AM.