LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Home Forums Tutorials Articles Register
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices


Reply
  Search this Thread
Old 03-04-2006, 08:39 PM   #1
RoiSoleil14
LQ Newbie
 
Registered: Mar 2006
Posts: 3

Rep: Reputation: 0
Running wireless command on boot


Hi, I finally got my wireless working with FreeBSD
However I have so far just typed these commands in konsole after loggin in. How do I make all of these commands run on start?

Code:
1)kldload wlan_wep
2)ifconfig ural0 netmask 255.255.255.0 ssid xxxxxxxx wepmode on wepkey 0x[WEP] weptxkey 1
3)dhclient ural0
Thanks a lot.

Roisoleil14
 
Old 03-05-2006, 01:21 PM   #2
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 77
Put "kldload wlan_wep" in /boot/loader.conf. The ifconfig line can go in /etc/rc.conf e.g
Code:
ifconfig_ural0="netmask 255.255.255.0 ssid xxxxxxxx wepmode on wepkey 0x[WEP] weptxkey1"
I am not so sure about the dhclient part. DHCP is usually enabled by doing "dhcp_enable=YES" or by doing "ifconfig_ural0="DHCP" in /etc/rc.conf.
 
Old 03-05-2006, 07:22 PM   #3
RoiSoleil14
LQ Newbie
 
Registered: Mar 2006
Posts: 3

Original Poster
Rep: Reputation: 0
yeah, i got it working with the following :

in /boot/loader.conf
Code:
 wlan_wep_load="YES"
in /etc/rc.conf
Code:
 ifconfig_ural0="DHCP netmask 255.255.255.0 ssid xxxxxxxx wepmode on wepkey 0x[WEP] weptxkey 1"
thanks for help

Roisoleil14

Last edited by RoiSoleil14; 03-05-2006 at 07:24 PM.
 
  


Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems while running Debian..(Power applet, Automatic wireless & mute on boot) williamp0044 Debian 1 12-28-2004 11:47 AM
sh command running as nobody chongluo Linux - Security 1 12-01-2004 06:03 AM
running a command at boot toddncl Linux - General 3 07-30-2004 09:08 AM
Running a command from anywhere tez Linux - Newbie 5 02-27-2004 10:07 PM
command running on cd in Daem0hn Linux - General 3 07-22-2003 03:13 AM

LinuxQuestions.org > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 07:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration