LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices


Reply
  Search this Thread
Old 08-21-2018, 02:54 PM   #1
mgoblue0970
LQ Newbie
 
Registered: Aug 2015
Posts: 20

Rep: Reputation: Disabled
Question about IPv4 when installing DragonFly latest/5.2.2


Hello:

Someone told me to take a look at DragonFly BSD recently and I decided to take it for a spin. I downloaded the latest bzip'd ISO from their website and wired that ISO up to a VirtualBox VM.

I checked https://www.linuxquestions.org/quest...en-way-783841/ before posting. Didn't see an answer to the questions below though.

When it booted from ISO, I logged in as the installer user.

It launches a TUI and I basically selected all the defaults. I get to the configuration menu and I noticed that for configuring the network, it's set up for IPv6 by default (and won't accept an IPv4 address without throwing an error) and there's no option (like a checkbox or radio button or something) for using IPv4.

Is there a way at install time to use IPv4 for the network?

There's nothing in the DragonFly BSD documentation for this problem. It just basically describes the TUI's fields... which are defaulting to IPv6 for me.
 
Old 08-22-2018, 09:28 AM   #2
cynwulf
Senior Member
 
Registered: Apr 2005
Posts: 2,115
Blog Entries: 5

Rep: Reputation: 1165Reputation: 1165Reputation: 1165Reputation: 1165Reputation: 1165Reputation: 1165Reputation: 1165Reputation: 1165Reputation: 1165
I've always used IPv4 and had no issues. This is likely to do with how your VM is configured. As I recall, Virtualbox uses different methods such as bridging or NAT. You probably want to have a play around with those settings.

You would be better served by a bare metal install however, if that's possible.
 
Old 08-22-2018, 01:27 PM   #3
mgoblue0970
LQ Newbie
 
Registered: Aug 2015
Posts: 20

Original Poster
Rep: Reputation: Disabled
Quote:
I've always used IPv4 and had no issues
I'm trying to use IPv4. It defaults to 6 during install and I cannot find a place to change it!

Quote:
This is likely to do with how your VM is configured
How so? One doesn't specify a version when enabling a NIC in the VM's settings.

Quote:
Virtualbox uses different methods such as bridging or NAT
Yes... but has nothing to do with the question.
 
Old 08-23-2018, 07:55 AM   #4
cynwulf
Senior Member
 
Registered: Apr 2005
Posts: 2,115
Blog Entries: 5

Rep: Reputation: 1165Reputation: 1165Reputation: 1165Reputation: 1165Reputation: 1165Reputation: 1165Reputation: 1165Reputation: 1165Reputation: 1165
Use DHCP and if you do not get an "inet" address, but just an "inet6" fe80:: address, it is likely to do with how your Virtualbox LAN or the host system is set up.

I've just done a test install of 5.2.2 release in Virtualbox 5.2.18 installed under a Windows host.

Using DHCP gets me an ipv4 DHCP lease with an auto assigned (fe80:: ) ipv6 address. So I can confirm that IPv4 is working and there is connectivity with the WAN/LAN.

Switching to a VT logging in as root and issuing:
Code:
# ifconfig em0
Shows an inet address in the private 10.x.x.x range. Obviously as Virtualbox acts as the NAT router, it's configuration is somewhat relevant. In this case the setting "NAT", which was the default in VirtualBox's network settings for "Adapter 1", is routing ipv4 from the host system.

I changed the setting to "host only" and again ran through the network config using DHCP and this time it acquired a DHCP lease in the 192.168.x.x range, but no route to host...
 
Old 08-23-2018, 04:59 PM   #5
mgoblue0970
LQ Newbie
 
Registered: Aug 2015
Posts: 20

Original Poster
Rep: Reputation: Disabled
By default, VB routes from guest to host via NAT. In the network manager, it's in the 10.0.2.x subnet by default (but can be completely changed as deisred).

If one just wants to get network connectivity in the guest from the host's network connection, there's no need to change a thing -- that's what NAT does for you. There's no need to override the tool. Work smarter not harder.

If one wants to connect to other VMs too, the preferred method is to use multiple NICs... leaving em0 as NAT to the host and configuring a NAT Network for em1 in the network manger. Which is what I have done.

THERE IS NO SETTING IN VB TO SPECIFY IPV4 OR IPV6. I don't know how to make that any clearer.

The problem I ran into is in the TUI at install time, when specifying a IPv4 address the installer throws an error. I did notice since my OP that even though the installer barfs on a IPv4 address it still configures the NIC with the x.x.x.x address. It looks like a bug with the installer. So now I just ignore the error and press on. After rebooting from an install, the error on the IP address is never seen again.
 
  


Reply

Tags
bsd, configuration, install, ipv4, network settings


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
In tspc ipv6 tunnelling, does tunnel broker required for ipv4 to ipv4 communication? nyk.mat Linux - Newbie 2 08-13-2013 09:48 PM
Disabling IPv4 packet forwarding: net.ipv4.ip_forward = 0 (CentOS 5.5) troiwulful Red Hat 3 11-22-2010 11:04 AM
another ipv4 question vlyamtse Linux - Networking 5 09-03-2009 02:45 PM
IPv4 Question RecoilUK Linux - Networking 4 11-04-2001 05:13 PM

LinuxQuestions.org > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 02:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration