LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices


Reply
  Search this Thread
Old 10-05-2017, 05:09 PM   #1
LouCFur
LQ Newbie
 
Registered: Oct 2017
Posts: 8

Rep: Reputation: Disabled
Question Please, Need Help with configuring xorg/X11


Hello,

I'm new to FreeBSD and this is my second attempt at installing it. Just like last time, I have no problem with the base installation, that goes smoothly. Then my next step was to install x11:
# pkg install xorg
The xorg installation goes smoothly as well.
after the installation when I try '# startx' I get error messages and cannot connect to the X Server. Here is the output:


root@Alderaan:~# startx
xauth: file /root/.serverauth.945 does not exist



X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD Alderaan.System 11.1-RELEASE FreeBSD 11.1-RELEASE #0 r321309: Fri Jul 21 02:08:28 UTC 2017 root@releng2.nyi.freebsd.org:/usr
/obj/usr/src/sys/GENERIC amd64
Build Date: 03 October 2017 09:22:31AM

Current version of pixman: 0.34.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Oct 5 20:40:58 2017
(==) Using default built-in configuration (39 lines)
scfb trace: probe start
scfb trace: probe done
(EE)
Fatal server error:
(EE) Cannot run in framebuffer mode. Please specify busIDs for all framebuffer devices
(EE)
(EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE)
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
root@Alderaan:~#





I have tried manual configuration but I feel like I'm missing something, xorg still doesn't work, it seems like the system is not detecting the screen. I have a laptop, a Toshiba Satellite C55t-B5230. I am having a hard time finding any information about the screen/monitor besides size and resolution. I need to know what else I need to do to get xorg running so I can use a GUI as well as the CL. Any help is much appreciated.

Thank you,
Lou
 
Old 10-07-2017, 05:29 AM   #2
fatmac
Senior Member
 
Registered: Sep 2011
Location: Upper Hale, Surrey/Hants Border, UK
Distribution: AntiX & Vuu-Do.
Posts: 1,917

Rep: Reputation: Disabled
If I remember, 'X' won't start as the root user, try starting it as a normal user.

You might find this useful.
https://www.freebsd.org/doc/en/books/handbook/

Last edited by fatmac; 10-07-2017 at 05:31 AM.
 
Old 10-07-2017, 04:59 PM   #3
LouCFur
LQ Newbie
 
Registered: Oct 2017
Posts: 8

Original Poster
Rep: Reputation: Disabled
Thanks for tip, Ill give it a shot and let u know how it goes.

p.s. would it be helpful if I posted a copy of the log file?p
 
Old 10-07-2017, 05:36 PM   #4
sevendogsbsd
Member
 
Registered: Sep 2017
Location: Texas
Distribution: None - FreeBSD
Posts: 70

Rep: Reputation: Disabled
Also, an xorg.conf is not needed any longer although won't hurt anything at this point. A better way is to create individual config files under /usr/local/etc/X/xorg.conf.d.

I think I got that path correct...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing xorg.conf file in /etc/X11/xorg.conf Altiris Linux - Newbie 2 08-23-2013 11:46 PM
[SOLVED] Error with xorg-x11-server-Xorg callumacrae Fedora 1 10-13-2009 02:22 PM
Needs help configuring /etc/X11/xorg.conf Monitor Refresh Rates itz2000 Linux - Newbie 8 04-08-2007 03:45 AM
xorg-x11-devel dependant on old version of xorg-x11-libs thetawaverider Linux - Software 1 11-09-2006 07:22 AM
xorg-x11-libs required by xorg-x11-devel darknails Fedora 1 01-13-2005 02:34 PM

LinuxQuestions.org > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 06:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration