LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices


Reply
  Search this Thread
Old 06-29-2021, 10:00 PM   #1
Turbocharger
LQ Newbie
 
Registered: Nov 2015
Distribution: Kubuntu, FreeBSD, OpenIndiana, Mageia
Posts: 12

Rep: Reputation: Disabled
OpenBSD 6.9 phpLDAPadmin web page tells "Missing required extension"


Missing required extension
Your install of PHP appears to be missing LDAP support.

Please install LDAP support before using phpLDAPadmin.
(Dont forget to restart your web server afterwards)

It also says "Deprecated: Array and string offset access syntax with curly braces is deprecated in /var/www/phpldapadmin/lib/functions.php on line 1641"

Also, when I try to login using Firefox, I get this error message :

Fatal error: Uncaught Error: Call to undefined function ldap_explode_dn() in /var/www/phpldapadmin/lib/functions.php:2548 Stack trace: #0 /var/www/phpldapadmin/lib/functions.php(2601): ldap_explode_dn_patch() #1 /var/www/phpldapadmin/lib/Tree.php(135): pla_explode_dn() #2 /var/www/phpldapadmin/lib/Tree.php(173): Tree->indexDN() #3 /var/www/phpldapadmin/lib/Tree.php(62): Tree->addEntry() #4 /var/www/phpldapadmin/lib/page.php(227): Tree::getInstance() #5 /var/www/phpldapadmin/lib/page.php(418): page->tree() #6 /var/www/phpldapadmin/htdocs/cmd.php(78): page->display() #7 /var/www/phpldapadmin/htdocs/index.php(153): include('/var/www/phplda...') #8 {main} thrown in /var/www/phpldapadmin/lib/functions.php on line 2548

With Chrome, I simply get this message :

This page isnít working
my_domain is currently unable to handle this request.
HTTP ERROR 500

OpenBSD 6.9 -release

php-7.4.16p0 php-ldap-7.4.16p0 phpldapadmin-1.2.5p0 built from the ports ; same problem with phpldapadmin-1.2.5p0 php-ldap-7.4.20 and php-7.4.20 installed with PKG

# dmesg
OpenBSD 6.9 (GENERIC) #464: Mon Apr 19 10:28:56 MDT 2021
deraadt@amd64.openbsd.org:/usr/src/sys/arch/amd64/compile/GENERIC
real mem = 2130640896 (2031MB)
avail mem = 2050850816 (1955MB)
random: good seed from bootblocks
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.5 @ 0xe1000 (10 entries)
bios0: vendor innotek GmbH version "VirtualBox" date 12/01/2006
bios0: innotek GmbH VirtualBox
acpi0 at bios0: ACPI 4.0
acpi0: sleep states S0 S5
acpi0: tables DSDT FACP APIC SSDT
acpi0: wakeup devices
acpitimer0 at acpi0: 3579545 Hz, 32 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: AMD FX(tm)-6300 Six-Core Processor, 3493.94 MHz, 15-02-00
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,P GE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT ,SSE3,PCLMUL,SSSE3,CX16,SSE4.1,SSE4.2,POPCNT,AES,X SAVE,AVX,NXE,MMXX,FFXSR,RDTSCP,LONG,LAHF,CMPLEG,AM CR8,ABM,SSE4A,MASSE,3DNOWP,ITSC
cpu0: 64KB 64b/line 2-way I-cache, 16KB 64b/line 4-way D-cache, 2MB 64b/line 16-way L2 cache
cpu0: ITLB 48 4KB entries fully associative, 24 4MB entries fully associative
cpu0: DTLB 64 4KB entries fully associative, 64 4MB entries fully associative
cpu0: smt 0, core 0, package 0
mtrr: CPU supports MTRRs but not enabled by BIOS
cpu0: apic clock running at 1000MHz
cpu at mainbus0: not configured
cpu at mainbus0: not configured
cpu at mainbus0: not configured
ioapic0 at mainbus0: apid 4 pa 0xfec00000, version 20, 24 pins, remapped
acpiprt0 at acpi0: bus 0 (PCI0)
acpipci0 at acpi0 PCI0: 0x00000000 0x00000011 0x00000001
acpiac0 at acpi0: AC unit online
acpicpu0 at acpi0: C1(@1 halt!)
acpivideo0 at acpi0: GFX0
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel 82441FX" rev 0x02
pcib0 at pci0 dev 1 function 0 "Intel 82371SB ISA" rev 0x00
pciide0 at pci0 dev 1 function 1 "Intel 82371AB IDE" rev 0x01: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
wd0 at pciide0 channel 0 drive 0: <VBOX HARDDISK>
wd0: 128-sector PIO, LBA, 25600MB, 52428800 sectors
wd1 at pciide0 channel 0 drive 1: <VBOX HARDDISK>
wd1: 128-sector PIO, LBA, 10240MB, 20971520 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2
wd1(pciide0:0:1): using PIO mode 4, Ultra-DMA mode 2
atapiscsi0 at pciide0 channel 1 drive 0
scsibus1 at atapiscsi0: 2 targets
cd0 at scsibus1 targ 0 lun 0: <VBOX, CD-ROM, 1.0> removable
wd2 at pciide0 channel 1 drive 1: <VBOX HARDDISK>
wd2: 128-sector PIO, LBA, 10240MB, 20971520 sectors
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
wd2(pciide0:1:1): using PIO mode 4, Ultra-DMA mode 2
vga1 at pci0 dev 2 function 0 "VMware SVGA II" rev 0x00
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
em0 at pci0 dev 3 function 0 "Intel 82540EM" rev 0x02: apic 4 int 19, address 08:00:27:71:36:c0
"InnoTek Guest Service" rev 0x00 at pci0 dev 4 function 0 not configured
auich0 at pci0 dev 5 function 0 "Intel 82801AA AC97" rev 0x01: apic 4 int 21, ICH
ac97: codec id 0x83847600 (SigmaTel STAC9700)
audio0 at auich0
ohci0 at pci0 dev 6 function 0 "Apple Intrepid USB" rev 0x00: apic 4 int 22, version 1.0
piixpm0 at pci0 dev 7 function 0 "Intel 82371AB Power" rev 0x08: apic 4 int 23
iic0 at piixpm0
em1 at pci0 dev 8 function 0 "Intel 82543GC" rev 0x02: apic 4 int 16, address 08:00:27:ed:2b:07
ehci0 at pci0 dev 11 function 0 "Intel 82801FB USB" rev 0x00: apic 4 int 19
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 configuration 1 interface 0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
mpi0 at pci0 dev 20 function 0 "Symbios Logic 53c1030" rev 0x00: apic 4 int 20
mpi0: VBox MPT Fusion, firmware 0.0.0.0
scsibus2 at mpi0: 16 targets, initiator 7
sd0 at scsibus2 targ 0 lun 0: <VBOX, HARDDISK, 1.0>
sd0: 10240MB, 512 bytes/sector, 20971520 sectors
sd1 at scsibus2 targ 1 lun 0: <VBOX, HARDDISK, 1.0>
sd1: 10240MB, 512 bytes/sector, 20971520 sectors
sd2 at scsibus2 targ 2 lun 0: <VBOX, HARDDISK, 1.0>
sd2: 10240MB, 512 bytes/sector, 20971520 sectors
sd3 at scsibus2 targ 3 lun 0: <VBOX, HARDDISK, 1.0>
sd3: 10240MB, 512 bytes/sector, 20971520 sectors
mpi0: target 0 Async at 0MHz width 8bit offset 0 QAS 0 DT 0 IU 0
mpi0: target 1 Async at 0MHz width 8bit offset 0 QAS 0 DT 0 IU 0
mpi0: target 2 Async at 0MHz width 8bit offset 0 QAS 0 DT 0 IU 0
mpi0: target 3 Async at 0MHz width 8bit offset 0 QAS 0 DT 0 IU 0
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
usb1 at ohci0: USB revision 1.0
uhub1 at usb1 configuration 1 interface 0 "Apple OHCI root hub" rev 1.00/1.00 addr 1
vscsi0 at root
scsibus3 at vscsi0: 256 targets
softraid0 at root
scsibus4 at softraid0: 256 targets
sd4 at scsibus4 targ 1 lun 0: <OPENBSD, SR RAID 5, 006>
sd4: 20472MB, 512 bytes/sector, 41928448 sectors
sd5 at scsibus4 targ 2 lun 0: <OPENBSD, SR RAID 0, 006>
sd5: 30709MB, 512 bytes/sector, 62892672 sectors
root on wd0a (ad33bce6618a3afb.a) swap on wd0b dump on wd0b
 
Old 06-30-2021, 09:08 AM   #2
jggimi
Member
 
Registered: Jan 2016
Distribution: None. Just OpenBSD.
Posts: 235

Rep: Reputation: 108Reputation: 108
As noted here and also here, please ensure you provision php-ldap after installation, as documented in the pkg-readme.
 
1 members found this post helpful.
Old 06-30-2021, 11:13 AM   #3
Turbocharger
LQ Newbie
 
Registered: Nov 2015
Distribution: Kubuntu, FreeBSD, OpenIndiana, Mageia
Posts: 12

Original Poster
Rep: Reputation: Disabled
Like you said on another forum, a simple

# ln -sf /etc/php-7.4.sample/ /etc/php-7.4
# pkill php-fpm-7.4
# php-fpm-7.4
# rcctl restart apache2

made phpLDAPadmin work without complaining about lack of LDAP support in PHP.

Thank you so much.

Last edited by Turbocharger; 06-30-2021 at 04:15 PM. Reason: removing information said in following reply
 
Old 06-30-2021, 04:15 PM   #4
Turbocharger
LQ Newbie
 
Registered: Nov 2015
Distribution: Kubuntu, FreeBSD, OpenIndiana, Mageia
Posts: 12

Original Poster
Rep: Reputation: Disabled
phpLDAPadmin doesn't work with php-fpm-7.4; I get these error messages

First, this message on top of phpLDAPadmin welcome page :

Deprecated: Array and string offset access syntax with curly braces is deprecated in /var/www/phpldapadmin/lib/functions.php on line 1641

Most importantly, after login, I can't create entries because I get these messages :

PHP Debug Backtrace
File /var/www/phpldapadmin/lib/functions.php (190)
Function error (a:5:{i:0;s:102:"Unrecognized error number: 8192: A...)
File /var/www/phpldapadmin/lib/functions.php (58)
Function app_error_handler (a:5:{i:0;i:8192;i:1;s:69:"Array and string offset ...)
File /var/www/phpldapadmin/lib/functions.php (58)
Function require_once
File /var/www/phpldapadmin/lib/functions.php ()
Function pla_autoload (a:1:{i:0;s:14:"TemplateRender";})
File /var/www/phpldapadmin/htdocs/template_engine.php (40)
Function spl_autoload_call (a:1:{i:0;s:14:"TemplateRender";})
File /var/www/phpldapadmin/htdocs/cmd.php (59)
Function include (a:1:{i:0;s:48:"/var/www/phpldapadmin/htdocs/templa...)

When I click on the first link, I get :

URL : https://my_domain:444/tools/unserialize.php?index=0

File not found.

When I click on the second link, I get :

https://my_domain:444/tools/unserialize.php?index=1

File not found.

When I click on the third link, I get :

https://my_domain:444/tools/unserialize.php?index=3

File not found.

On the fourth link, I get :

https://my_domain:444/tools/unserialize.php?index=4

File not found.

On the fifth link, I get :

https://my_domain:444/tools/unserialize.php?index=5

File not found.

But it works perfectly with php-fpm-7.3 installed via PKG, after having done :

# pkg_add php
1: php-7.3.28
# pkg_add php-apache
1: php-apache-7.3.28
# pkg_add php-ldap
1: php-ldap-7.3.28
# ln -sf /etc/php-7.3.sample/ /etc/php-7.3
# pkill php-fpm-7.4
# php-fpm-7.3
# rcctl restart apache2
# ps -aux | grep php-fpm
www 18699 0.0 0.1 9192 2800 ?? S 12:59AM 0:00.00 php-fpm-7.3: pool phpldapadmin (php-fpm-7.3)
www 45414 0.0 0.1 9192 2812 ?? S 12:59AM 0:00.00 php-fpm-7.3: pool phpldapadmin (php-fpm-7.3)
www 45766 0.0 0.1 9192 2840 ?? S 12:59AM 0:00.00 php-fpm-7.3: pool www (php-fpm-7.3)
www 53094 0.0 0.1 9192 2824 ?? S 12:59AM 0:00.00 php-fpm-7.3: pool www (php-fpm-7.3)

Note : this is for phpLDAPadmin version 1.2.5 on OpenBSD 6.9 -current.

Another simple trick if you can find a FreeBSD 12.2 host with phpLDAPadmin installed on it, is to copy these folders from the FreeBSD phpLDAPadmin (which is version 1.2.6.2) and paste them to replace the same folders on your OpenBSD 6.9's phpLDAPadmin :

htdocs
lib

With this, you can keep running php-fpm-7.4 on OpenBSD.

Last edited by Turbocharger; 06-30-2021 at 05:20 PM. Reason: add information
 
Old 06-30-2021, 05:48 PM   #5
Turbocharger
LQ Newbie
 
Registered: Nov 2015
Distribution: Kubuntu, FreeBSD, OpenIndiana, Mageia
Posts: 12

Original Poster
Rep: Reputation: Disabled
I reported this problem to the OpenBSD team and they replied me that phpLDAPadmin will be upgraded to 1.2.6 or 1.2.6.2 in the coming days for 6.9 -current.

Wait and see.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"Xlib: extension "XFree86-DRI" missing on display ":0.0"." davcefai Debian 1 02-15-2014 03:11 AM
Looking for a web browser extension that reverses web-page colors punchy71 Linux - Software 2 12-12-2011 12:30 PM
[Xlib: extension "Generic Event Extension" missing on display] nomachine/x11 forward digger86 Linux - Software 0 05-21-2010 01:29 AM
"Xlib: extension "XFree86-DRI" missing on display ":0.0"." zaps Linux - Games 9 05-14-2007 03:07 PM
phpldapadmin missing Proceed button BizWim Linux - Networking 0 08-11-2006 07:52 AM

LinuxQuestions.org > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 04:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration