LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   *BSD (https://www.linuxquestions.org/questions/%2Absd-17/)
-   -   OpenBSD 5.5 black screen (https://www.linuxquestions.org/questions/%2Absd-17/openbsd-5-5-black-screen-4175504225/)

moisespedro 05-07-2014 11:25 AM

OpenBSD 5.5 black screen
 
I was going to try the new OpenBSD but it didn't work, I don't get display, I lose the signal right before the console login :(
Since I am a Linux noob and a complete BSD noob I don't know what to do, what is odd is that some time ago I tried OpenBSD 5.4 and it went fine

kfritz 05-08-2014 07:58 AM

The output of dmesg would be helpful -- you can probably ssh to the machine after it goes black.

But, it's likely a KMS problem. Does your mystery hardware have Intel graphics? At the "boot>" prompt, enter "boot -c", then "disable inteldrm", then "quit".

If that works, or not, try the latest snapshot and see if it's fixed there. If it's still broken there, it would be helpful to send a message to the misc mailing list with your problem and dmesg output.

nebelfrau 05-08-2014 09:13 AM

Sorry, this doesn't really say too much. Besides what kfritz mentioned above, we would also need to know a couple of things..

What did you do leading up to the black screen? What was your install method? Did you even GET the OS installed? Hardware? Virtualware?

For whatever it is worth, I have just installed OpenBSD5.5 amd64 & i386 on both virtual and hardware without a hitch. I also followed the manual as if my life depended on it.

Also, based on the genericness of your error, this has happened to me on every single OS I have ever tried to install. Granted it was my fault for trying to be experimental, but it has happened.

moisespedro 05-08-2014 11:06 AM

I am sorry for the lack of hardware information and, by the way, I don't use an Intel card. I have a Radeon 6670. As of right now I can't post any dmesg output because: 1 - I wouldn't know how to do it without access to the display, would probably mount the partition on a Linux system and grab the log file and 2 - I went back to OpenBSD 5.4, which works fine. Anyways, most of the lack of information is because I am a complete noob lol This is my first contact with a BSD system ever.

I did the install process following the guide/FAQ and the informations on the screen, what was pretty easy.

kfritz 05-08-2014 09:02 PM

If you give it another try, at the "boot>" prompt, enter "boot -c", then "disable radeondrm", then "quit".

moisespedro 05-11-2014 10:40 AM

I got it working :D

But I am stuck with 1280x1024 resolution (on console and on Xorg, under XFCE session)

This is my dmesg
http://paste.debian.net/98843/

It doesn't make much sense to me that, even with a 6670 radeon card, I have to disable the radeon thing.

moisespedro 05-13-2014 06:28 AM

Got it running after manually installing the radeon firmware, I am loving OpenBSD such a sweet system


All times are GMT -5. The time now is 05:58 AM.