LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices


Reply
  Search this Thread
Old 08-24-2004, 10:47 PM   #1
smurfzilla
LQ Newbie
 
Registered: Aug 2004
Posts: 5

Rep: Reputation: 0
openBSD 3.5 sm-msp-queue error ?


2 months ago I installed and set up openBSD 3.5 to use for firewall/routing of my local network. I am new to the universe of *nix/BSD and am learning as I go. I've searched the forums and googled for various words in this error, and have found nothing to even put me on the right track to fix the problem. I can just reinstall, but I would rather learn how to fix this problem correctly if possible.

I live in florida, and the recent hurricane left me without power for 10 days. I shutdown all my systems before the storm, but forgot about the openBSD box, because of it's infrequent use. It was on a UPS, but 10 days was a bit much to ask of it. The system was obviously shutdown incorrectly. Now that I have power back, the box will lockup/reboot every 8 hours.

30 minutes after boot, and repeated every 30 minutes after that I get this message across the console, which I assume is being posted to a log somewhere. If this logfile will help in diagnosis, please let me know where to find it, and I can post it for you. The message is :

<Date> <time> <machinename> sm-msp-queue[2702]: i7IL01qY018566: SYSERR(root): readqf: ./qfi7IL01qY018566: incomplete queue file read

The only services I have set up to run are pf, and dhcpd. I have not turned off/on any other services from the default 3.5 install. Please let me know if there are any logs, or information I can provide to aide you. Thank you for your time.
 
Old 08-25-2004, 12:52 AM   #2
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 75
That's Sendmail. It looks like it has a message stuck that got partially queued. Best thing would be to manually clean out the Sendmail queue by rm'ing the file specified above (qfi7IL01qY018566).
 
Old 08-25-2004, 08:28 AM   #3
smurfzilla
LQ Newbie
 
Registered: Aug 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Thank you for your help chort. What dir should I start looking for the file?

Thanks for your time,

smurfzilla
 
Old 08-25-2004, 08:35 AM   #4
smurfzilla
LQ Newbie
 
Registered: Aug 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Is there a command similar to grep that searches for files themselves, rather then inside files ? I'm currently trying to use ls, but can't figure out how to wild card it.

-smurf

**edit
with a little searching here, i found the find cmd, which let me find the location of the file. Thanks for your help chort, and I'll let you know if rm'ing the file fixes my problem.


Last edited by smurfzilla; 08-25-2004 at 09:00 AM.
 
Old 08-26-2004, 11:54 AM   #5
smurfzilla
LQ Newbie
 
Registered: Aug 2004
Posts: 5

Original Poster
Rep: Reputation: 0
After finding and rm'ing the offending file. All seemed well for awhile. I no longer get the sm-msp-queue error, but I now am getting random lockups. The time used be 8 hours before lockup, now it is seemingly random intervals. The shortest being 20 min. Any idea where to look for problems?
 
Old 08-31-2004, 11:05 AM   #6
smurfzilla
LQ Newbie
 
Registered: Aug 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Problem is solved. After a failed reinstall, I tried another hd. The reinstall also failed. I replaced the ram, and reinstalled on the original drive and all is well. So far the box has been up for 1 day.

-smurf
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
openbsd 3.8 and virtualhosts error klemen *BSD 4 11-24-2005 11:18 AM
Error on pkg_add on openbsd 3.8 klemen *BSD 0 10-06-2005 11:56 AM
install modem hsf, msp 3880u from aztec amolgupta Linux - Hardware 1 02-09-2005 05:27 PM
sendmail, sm-msp-queue for outgoing logfile after ssl lildrummerboy Linux - Newbie 0 07-26-2004 09:09 AM
Stange OpenBSD 3.5 error. lil_drummaboy *BSD 2 05-23-2004 06:05 PM

LinuxQuestions.org > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 07:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration