Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Other *NIX Forums > *BSD
User Name
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.


  Search this Thread
Old 05-02-2005, 04:14 PM   #1
Registered: Apr 2005
Location: a little Forest in Virginia
Distribution: FreeBSD 5.3
Posts: 44

Rep: Reputation: 15
mysql - back to square one

hello again!

after the weekend i reviewed my previous posting concerning mysql 5 and apparently I AM MISSING THE BOAT!

i believe that you guys are giving the assistance needed but somewhere along the way the message is not being read correctly by this noob sitting at this keyboard.

here is what i have.

a freshly installed FreeBSD 5.3 and the ports have been installed and updated

during the install phase of the OS i added two other groups (myself and mysql) and two additional user ids (myself and mysql)

here is what i have tried

1. installed as mysql (died after the first screen)

2. installed as root (made it through the install process)
however, root owns everything and mysql_install_db is not sucessful
so, "su root" was issued and mysql_install_db tried again still no go
i also tried mysqld_safe and that failed too

the install appears correct when root does it. no errors that i can see except it will not create the DBs, run mysqld_safe.

when this was attempted as user mysql it fails saying that it does not have sufficient rights so i gathered that doing "su root" to do the install is a bad thing as well as installing as root.


what are the correct steps before i step off the cliff again?

your help is very apprciated BTW
Old 05-28-2005, 11:04 PM   #2
Registered: Mar 2005
Distribution: FreeBSD, Slack, Fedora3
Posts: 35

Rep: Reputation: 15
I had a very similar problem on a slackware box and had to run the following two commands:

# chown mysql /var/lib/mysql/*

# chown mysql /var/lib/mysql/mysql/*

However the location may be different for BSD, I looked in my FreeBSD box and I currently don't have MySQL installed.

After that mine worked fine, I hope this helps for you.

Old 05-29-2005, 12:44 AM   #3
LQ Newbie
Registered: May 2005
Posts: 18

Rep: Reputation: 0
why are you creating a mysql user for, installing through ports will create both the user and the database for you. To start it on startup, you put the enable string in the rc.conf as the instruction in the UPDATING file in the ports directory.
Old 05-29-2005, 11:32 AM   #4
Senior Member
Registered: Nov 2004
Location: Third rock from the Sun
Distribution: NetBSD-2, FreeBSD-5.4, OpenBSD-3.[67], RHEL[34], OSX 10.4.1
Posts: 1,197

Rep: Reputation: 46
I'll second that. Your creating the user/group before hand is probably causing you trouble.

Remove that user and group and let the ports do their thing, then add the mysql_enable="YES" to rc.conf and you're done.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem importing database back to MySql shubb Programming 3 11-29-2005 02:36 PM
Square fonts with CEDEGA? Spooky Linux - Games 1 05-14-2005 03:14 PM
How to back up mysql database? aroop Linux - Software 1 03-29-2005 10:11 AM
square one - how do I make it go? linuxceptic Linux - Wireless Networking 3 02-04-2004 08:23 PM
Square mouse pointer ? d4d4n9 Mandriva 11 12-28-2003 08:44 AM > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 12:34 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration