LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   *BSD (https://www.linuxquestions.org/questions/%2Absd-17/)
-   -   mysql - back to square one (https://www.linuxquestions.org/questions/%2Absd-17/mysql-back-to-square-one-319446/)

bshearer 05-02-2005 04:14 PM

mysql - back to square one
 
hello again!

after the weekend i reviewed my previous posting concerning mysql 5 and apparently I AM MISSING THE BOAT!

i believe that you guys are giving the assistance needed but somewhere along the way the message is not being read correctly by this noob sitting at this keyboard.

here is what i have.

a freshly installed FreeBSD 5.3 and the ports have been installed and updated

during the install phase of the OS i added two other groups (myself and mysql) and two additional user ids (myself and mysql)

here is what i have tried

1. installed as mysql (died after the first screen)

2. installed as root (made it through the install process)
however, root owns everything and mysql_install_db is not sucessful
so, "su root" was issued and mysql_install_db tried again still no go
i also tried mysqld_safe and that failed too

the install appears correct when root does it. no errors that i can see except it will not create the DBs, run mysqld_safe.

when this was attempted as user mysql it fails saying that it does not have sufficient rights so i gathered that doing "su root" to do the install is a bad thing as well as installing as root.

so...

what are the correct steps before i step off the cliff again?

your help is very apprciated BTW ;)

pjbii 05-28-2005 11:04 PM

I had a very similar problem on a slackware box and had to run the following two commands:

# chown mysql /var/lib/mysql/*

# chown mysql /var/lib/mysql/mysql/*

However the location may be different for BSD, I looked in my FreeBSD box and I currently don't have MySQL installed.

After that mine worked fine, I hope this helps for you.

pjbii

alantis13 05-29-2005 12:44 AM

why are you creating a mysql user for, installing through ports will create both the user and the database for you. To start it on startup, you put the enable string in the rc.conf as the instruction in the UPDATING file in the ports directory.

sigsegv 05-29-2005 11:32 AM

I'll second that. Your creating the user/group before hand is probably causing you trouble.

Remove that user and group and let the ports do their thing, then add the mysql_enable="YES" to rc.conf and you're done.


All times are GMT -5. The time now is 10:02 AM.