LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   *BSD (https://www.linuxquestions.org/questions/%2Absd-17/)
-   -   How to get KDE in FreeBSD (https://www.linuxquestions.org/questions/%2Absd-17/how-to-get-kde-in-freebsd-457591/)

blong4life 06-23-2006 10:37 AM

How to get KDE in FreeBSD
 
Is there a way to install KDE or something in FreeBSD so you can use a graphical login and a desktop and everything. All I can seem to do it get x server started so there is an IDE but only a command window
I'm using FreeBSD 5.5

Thnks

BLong

:newbie:

reddazz 06-23-2006 11:52 AM

Code:

#pkg_add -r kde
If you do not want to install all of kde, try
Code:

#pkg_add -r kde-lite
To enable KDM edit /etc/inittab and change the ttyv8 line to
Code:

ttyv8 "/usr/local/bin/kdm -nodaemon" xterm on secure

Ha1f 06-23-2006 02:22 PM

better yet, use ports:

Code:

#cd /usr/ports/x11/kde3
#make install clean

or

Code:

#cd /usr/ports/x11/kde-lite
#make install clean


taylor_venable 06-23-2006 04:54 PM

While I like building from source as often as possible (I think benefits like more configurability and CPU-specific optimization make it worth while), making all of KDE from the Ports tree would probably take a very long time. Almost definitely longer than an hour; maybe more than two hours. It depends on your CPU. If you don't mind, then by all means go head; but I just think a little warning is in order.

kdrlx 06-24-2006 04:08 AM

Why -r ?
 
Most probably you must have installed FreeBSD from a CD from some source right?

Why do you have to waste time and bandwidth with compiling from source or pkg_addING it. It must be on one of your CDs(most probably the second one).

Just run [sysinstall] as *root* and select Configure -> Packages -> KDE and select kde(Version_Number)

Sysinstall should also select all the dependencies for you.

Put the correct CD in and you should be fine.

------
FreeBSD 6.1 Stable
Pentium III 650MHz
256 MB

Ha1f 06-24-2006 09:07 AM

but thats out of date, as are packages.

run portsnap fetch; portsnap extract (or update) and you update your whole ports tree. then _if_ you compile from source youll be as up to date as possible. the packages are often lower versions than available in ports.

reddazz 06-24-2006 09:52 AM

Quote:

Originally Posted by taylor_venable
While I like building from source as often as possible (I think benefits like more configurability and CPU-specific optimization make it worth while), making all of KDE from the Ports tree would probably take a very long time. Almost definitely longer than an hour; maybe more than two hours. It depends on your CPU. If you don't mind, then by all means go head; but I just think a little warning is in order.

When I compiled all of KDE 3.5.3 from ports, I think it took the best part of about 5+ hours on a Sempron 2600 32 bit.

Zmyrgel 06-30-2006 07:51 AM

It took me 10+ hours to compile all of KDE in Gentoo with AMD 3800+ X2, for giving reference. Not sure how it's done on FreeBSD, though.

as400 07-01-2006 09:45 AM

According to the directions on posts #2 and #3...Do you have to be ONLINE in order to install KDE on the directions or commands posted on those reply numbers? Because I will be moving to another country and I will not have any Internet for a while until I do...And who knows when will that be...

So if anyone...Can someone please answer this? I would appreciate it. And not just for me. What if someone wants to install apps and the KDE desktop if someone does NOT have any Internet connection? So HOW will one install KDE using the Ports or the PKG_ADD method? Because those two methods do require a Internet connection in order to connect to the Ports or Pkg_ADD webserver....No???

Please please please advise on this for me...Thanks

Ha1f 07-01-2006 10:02 AM

well, you could

a) use disk #2 (which is a package cd) to install things that you need or

b)get packages off the internet (download then ahead of time?) and use pkg_add

you need the internet for ports to work

as400 07-01-2006 05:46 PM

So if one does NOT have any Internet connection, than how can one install these apps for FreebSD? I mean, you have to have a connection to connect to the PKG_ADD or the Ports Web-Server? I mean, I hate to say this, but thats weird...in my opinion...

Ha1f 07-01-2006 06:21 PM

ports downloads the most up to date packages, then makes/installs them. its more up to date than the packages used by pkg_add. pkg_add installs packages, and CAN be used locally, but thses arent always as up to date as ports.

taylor_venable 07-01-2006 07:11 PM

Trust the Wisdom of the Handbook: http://www.freebsd.org/doc/en_US.ISO...ook/ports.html


All times are GMT -5. The time now is 10:10 AM.