LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices


Reply
  Search this Thread
Old 10-29-2008, 04:05 PM   #1
tamtam
Member
 
Registered: May 2004
Distribution: Slackware.
Posts: 323

Rep: Reputation: 33
Unhappy Going graphical


Hi people, this is first venture with FreeBSD. After installation I was looking forward to getting to grips with the OS. So after installation I promptly got to the login, logged in as root. First of all lets get graphical. pushed out the startx command and in a blink of an eye, nothing. My fine 19 inch flat screen flickered and displayed no signal and died with a no signal display. I was unable to get back to the command prompt.

Okay maybe I missed something.

On another PC I promptly started reading the FreeBSD docs. Following the instructions I ran the following on rebooting into FreeBSD..
Code:
# cd /usr/ports/x11/xorg
# make install clean
Again nothing.

Rebooted again and tried the next suggestion...
Code:
# Xorg -configure
# Xorg -config xorg.conf.new
Again nothing. I then read the newly created xorg.conf.new. I also rebooted into Slackware and printed off the xorg.conf used in Slackware.

Comparing Slacks xorg.conf with FreeBSD's, they are near enough identical apart from a couple of minor points.

Slacks conf "keyboard"
Code:
Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option       "XkbModel"  "pc105"
	Option       "XkbLayout"  "gb"
EndSection
Frees conf "keyboard"
Code:
Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
EndSection
The "Card0" in Slackware
Code:
	Identifier  "Card0"
	Driver      "radeon"
	VendorName  "ATI Technologies Inc"
	BoardName   "Radeon 9100 IGP"
	BusID       "PCI:2:5:0"
The "Card0" in FreeBSD
Code:
	Identifier  "Card0"
	Driver      "ati"
	VendorName  "ATI Technologies Inc"
	BoardName   "Radeon 9100 IGP"
	BusID       "PCI:2:5:0"
The screen was almost identical as well.
Slackware...
Code:
        Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	DefaultDepth 24
	SubSection "Display"
        ..... the same from here
FreeBSD...
Code:
        Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
        ..... the same from here
Okay the differences I edited into xorg.conf.new on FreeBSD were the
"XkbModel" "pc105" and "XkbLayout" "gb" as well as the DefaultDisplay set to 24. I left the Driver for the card set at ati. How do i know if FreeBSD has a Radeon Driver? Okay.

Same result nothing. Where am I going wrong?
 
Old 10-29-2008, 04:40 PM   #2
nifund9
Member
 
Registered: Oct 2004
Distribution: Slackware 12.1, FreeBSD 7.0, UbuntuStudio 8.10
Posts: 32

Rep: Reputation: 15
Yes, I believe FreeBSD has a radeon driver. Try running 'xorgconfig' so you can choose the settings yourself.

Last edited by nifund9; 10-29-2008 at 04:44 PM.
 
Old 10-29-2008, 04:42 PM   #3
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora
Posts: 3,935
Blog Entries: 5

Rep: Reputation: Disabled
A couple questions:
  1. Did you update your ports tree before installing xorg? and (related)...
  2. what version of xorg are you running now?
  3. What does /var/log/Xorg.0.log say about all this?

I'm presuming you are following the steps outlined here: http://www.freebsd.org/doc/en_US.ISO.../x-config.html

I also want to point out that xorg is xorg - this isn't FreeBSD's xorg (it was just ported there). If the same xorg version works in Slackware, it should work in FreeBSD.
 
Old 10-29-2008, 04:54 PM   #4
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora
Posts: 3,935
Blog Entries: 5

Rep: Reputation: Disabled
Bearing in mind I'm really a xorg novice, I would add one more thing:
Code:
%cd /usr/ports && make search display=path key=radeon
Path:   /usr/ports/sysutils/radeontool
Path:   /usr/ports/x11/xorg
Path:   /usr/ports/x11-drivers/xf86-video-radeonhd
Path:   /usr/ports/x11-drivers/xorg-drivers
Perhaps try installing the xf86-video-radeonhd port and going through the steps again. (More info on that driver on xorg's site here: http://wiki.x.org/wiki/radeonhd)
 
Old 10-29-2008, 04:59 PM   #5
tamtam
Member
 
Registered: May 2004
Distribution: Slackware.
Posts: 323

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by anomie View Post
A couple questions:
  1. Did you update your ports tree before installing xorg? and (related)...
  2. what version of xorg are you running now?
  3. What does /var/log/Xorg.0.log say about all this?
Update your ports tree - enlighten me, being a newbie and such.

Quote:
I'm presuming you are following the steps outlined here: http://www.freebsd.org/doc/en_US.ISO.../x-config.html
Thats where I am at...best docs for an OS I have read so far
Quote:
I also want to point out that xorg is xorg - this isn't FreeBSD's xorg (it was just ported there). If the same xorg version works in Slackware, it should work in FreeBSD.
Thats what I assumed when I compared conf files.
 
Old 10-29-2008, 05:21 PM   #6
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora
Posts: 3,935
Blog Entries: 5

Rep: Reputation: Disabled
Follow the steps here under "Portsnap Method": http://www.freebsd.org/doc/en_US.ISO...rts-using.html

Once you've completed those steps, also do the following:

# cd /usr/ports/ports-mgmt/portmaster && make install clean

# rehash

# portmaster /usr/ports/x11/xorg

Finally, once all that is done, begin again with the installing/configuring X11 documentation. (And if you continue to run into issues, post your FreeBSD version; I noticed you never mentioned it.)
 
Old 10-29-2008, 05:52 PM   #7
tamtam
Member
 
Registered: May 2004
Distribution: Slackware.
Posts: 323

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by anomie View Post
Follow the steps here under "Portsnap Method": http://www.freebsd.org/doc/en_US.ISO...rts-using.html

Once you've completed those steps, also do the following:

# cd /usr/ports/ports-mgmt/portmaster && make install clean

# rehash

# portmaster /usr/ports/x11/xorg

Finally, once all that is done, begin again with the installing/configuring X11 documentation. (And if you continue to run into issues, post your FreeBSD version; I noticed you never mentioned it.)
Can you please explain why I need to do this and what it achieves?

And also at the moment I am not connected to the internet, I have not configured the network yet.

I have installed from the cdroms, and also installed gnome during the installation.

Also I am getting a error during boot up related to the mouse. It is a Logitech Intellimouse connected via usb to a PS2 connection via a PS2 converter.
 
Old 10-29-2008, 05:55 PM   #8
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora
Posts: 3,935
Blog Entries: 5

Rep: Reputation: Disabled
Sure - you need to update your ports tree to get the latest xorg software. Since we (still) don't know which FreeBSD version you're running, it is hard to know which xorg version you installed.

I recommended installing portmaster because it makes ports management a lot easier. Using the portmaster command as I specified will upgrade your xorg installation to the latest version.

Could you get set up with a 'net connection?
 
Old 10-29-2008, 06:15 PM   #9
tamtam
Member
 
Registered: May 2004
Distribution: Slackware.
Posts: 323

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by anomie View Post
Sure - you need to update your ports tree to get the latest xorg software. Since we (still) don't know which FreeBSD version you're running, it is hard to know which xorg version you installed.

I recommended installing portmaster because it makes ports management a lot easier. Using the portmaster command as I specified will upgrade your xorg installation to the latest version.

Could you get set up with a 'net connection?
Version = FreeBSD 7.0-RELEASE i386
X.Org X Server 1.4.0

Important part of Xorg.0.log
Code:
(==) Log File: "/var/log/Xorg.0.org", Time date and time here
(==) Using config file: "/etc/X11/xorg.conf"
Parse error on line 378 of section Device in file /etc/X11/xorg.conf
     "ATI" is not a valid keyword in this section.
(EE) Problem parsing the config file
(EE) Error parsing the config file

Fatal server error:
No Screens Found
 
Old 10-30-2008, 04:40 AM   #10
tamtam
Member
 
Registered: May 2004
Distribution: Slackware.
Posts: 323

Original Poster
Rep: Reputation: 33
Thanks for your patience anomie.

I did install ports during the installation. Will enable the network when I get home tonight and try the update method. The following is rather puzzling though.
Code:
(==) Log File: "/var/log/Xorg.0.org", Time date and time here
(==) Using config file: "/etc/X11/xorg.conf"
Parse error on line 378 of section Device in file /etc/X11/xorg.conf
     "ATI" is not a valid keyword in this section.
(EE) Problem parsing the config file
(EE) Error parsing the config file

Fatal server error:
No Screens Found
When I open xorg.conf in /etc/X11 it only contains 141 lines. Obviously I am missing something here. The only reference to "ATI" I can find in xorg.conf is in the VendorName under the Identfier "card0".
 
Old 10-30-2008, 11:29 AM   #11
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora
Posts: 3,935
Blog Entries: 5

Rep: Reputation: Disabled
Quote:
Originally Posted by tamtam
Will enable the network when I get home tonight and try the update method.
I think that'll be the best approach. The nice thing is, after you update, you can try deleting /etc/X11/xorg.conf and then simply try startx again. Xorg 7.3 is supposed to be a little smarter about just working (even without a config file).

As for the parse error - very odd about the line numbers. But rather than investing time and energy into that, an update is pretty quick and painless.
 
Old 10-30-2008, 04:27 PM   #12
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora
Posts: 3,935
Blog Entries: 5

Rep: Reputation: Disabled
I see you've opened a (mostly) identical thread on daemonforums, so I'm presuming the discussion will continue there.

http://daemonforums.org/showthread.php?t=2303
 
Old 10-30-2008, 05:03 PM   #13
tamtam
Member
 
Registered: May 2004
Distribution: Slackware.
Posts: 323

Original Poster
Rep: Reputation: 33
Thumbs down

Quote:
Originally Posted by anomie View Post
I see you've opened a (mostly) identical thread on daemonforums, so I'm presuming the discussion will continue there.

http://daemonforums.org/showthread.php?t=2303
Keeping my options open so to speak. Been at this constantly for three nights now without success. Would like to continue on both forums.

Okay, followed your guidelines from above...

Quote:
Follow the steps here under "Portsnap Method": http://www.freebsd.org/doc/en_US.ISO...rts-using.html

Once you've completed those steps, also do the following:

# cd /usr/ports/ports-mgmt/portmaster && make install clean

# rehash

# portmaster /usr/ports/x11/xorg
The result of which does not look promising...
Code:
Port Directory: /usr/ports/x11-drivers/xf86-video-i810
      This port is marked BROKEN.
      Does not compile.
      If you are sure you can build it remove BROKEN line in the 
      Makefile and try again.
Update for xf86-video-i810-1.6.5.3 failed.
Aborting update.
Update for xorg-drivers-7.3 failed.
Aborted update.
Well that will be it then.

Will I never get FreeBSD going graphical?
 
Old 10-30-2008, 08:42 PM   #14
nifund9
Member
 
Registered: Oct 2004
Distribution: Slackware 12.1, FreeBSD 7.0, UbuntuStudio 8.10
Posts: 32

Rep: Reputation: 15
I had the same error after running portmanager,
Code:
(==) Log File: "/var/log/Xorg.0.org", Time date and time here
(==) Using config file: "/etc/X11/xorg.conf"
Parse error on line 378 of section Device in file /etc/X11/xorg.conf
     "ATI" is not a valid keyword in this section.
(EE) Problem parsing the config file
(EE) Error parsing the config file

Fatal server error:
No Screens Found
except it was "i810" instead of "ATI", and I lost the desktop. I ran "pkg_add i810" and ran xorgconfig and got the desktop back.
I'm still new to FreeBSD, but you might try "pkg_add ati" and regonfiguring the setting if need be. Hope this helps in some way.
 
Old 10-31-2008, 11:49 AM   #15
tamtam
Member
 
Registered: May 2004
Distribution: Slackware.
Posts: 323

Original Poster
Rep: Reputation: 33
Okay strategy is to a reinstall of FreeBSD and start again.

What shall I install during the intial installation, given in mind the FreeBSD handbook.

Someone has already suggested that I dont install X during the installation. What about ports.

After installation what steps should I follow to install X.

Looking for guidance here, thanks in advance.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Graphical Interface songeek Solaris / OpenSolaris 8 04-23-2009 02:30 PM
graphical/non-graphical mode linux_2007_ Linux - Newbie 5 03-06-2007 10:45 AM
graphical lilo....doensn't go graphical -0- Slackware 3 02-01-2005 09:47 PM
first vc graphical Oxagast Linux - General 1 09-07-2003 02:49 PM
graphical system bluewolf021 Linux - Hardware 1 02-18-2003 01:50 PM

LinuxQuestions.org > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 01:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration