LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices


Reply
  Search this Thread
Old 08-04-2004, 10:10 AM   #1
noir911
Member
 
Registered: Apr 2004
Posts: 682

Rep: Reputation: Disabled
fstab DOS write


I have made an entry in /etc/fstab to mount FAT32 during bootup.

/dev/wd0i /mnt/dos msdos rw 0 0

The fs is properly mounted for normal users and root. But normal users can't
write in the filesystem.

I was wondering what to do to enable write for normal users. The man page
doesn't say much about it either.

TIA.
 
Old 08-04-2004, 11:11 AM   #2
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,993

Rep: Reputation: 388Reputation: 388Reputation: 388Reputation: 388
Change it to this:

/dev/wd0i /mnt/dos msdos umask=0,iocharset=iso8859-1,codepage=850,quiet 0 0
 
Old 08-05-2004, 12:28 PM   #3
noir911
Member
 
Registered: Apr 2004
Posts: 682

Original Poster
Rep: Reputation: Disabled
Quote:
Originally posted by kilgoretrout
Change it to this:

/dev/wd0i /mnt/dos msdos umask=0,iocharset=iso8859-1,codepage=850,quiet 0 0
Obviously it does not work. There's nothing like this in the man page. Wrong solution.
 
Old 08-05-2004, 01:28 PM   #4
frob23
Senior Member
 
Registered: Jan 2004
Location: Roughly 29.467N / 81.206W
Distribution: OpenBSD, Debian, FreeBSD
Posts: 1,450

Rep: Reputation: 48
/dev/wd0i /mnt/dos msdos rw 0 0

Leave that line in fstab. But do the following -- just once, every time after you will be fine.

umount /mnt/dos
chmod a+w /dev/wd0i
chmod a+w /mnt/dos
mount /mnt/dos

From then on... everyone should be able to write all over that partition. It isn't exactly secure but it is what you wanted.

You can force the umask by changing the fstab line to the following... but it shouldn't be needed:
/dev/wd0i /mnt/dos msdos rw,-m=777 0 0

And, according to the man page: The default mask is taken from the directory on which the file system is being mounted.

Edit: added a little more info on why this solution works and an option to change if the change must be made in /etc/fstab.

Last edited by frob23; 08-05-2004 at 01:50 PM.
 
Old 08-05-2004, 02:49 PM   #5
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,993

Rep: Reputation: 388Reputation: 388Reputation: 388Reputation: 388
Quote:
Obviously it does not work. There's nothing like this in the man page. Wrong solution.
Did you even try it??
 
Old 08-06-2004, 11:23 AM   #6
frob23
Senior Member
 
Registered: Jan 2004
Location: Roughly 29.467N / 81.206W
Distribution: OpenBSD, Debian, FreeBSD
Posts: 1,450

Rep: Reputation: 48
Try not to let it bother you but noir911 obviously has an issue with being polite to people who try to help him. I've seen it in this thread and another. If it really bothers you then just don't offer that person help in the future until they have learned (use the ignore selection for the user to remind yourself later). Very few people test my patience enough to earn an ignore... but being blatently rude to the people offering assisstence brings them far on that road.



I only bring this up because noir911 was a coin-flip away from being ignored for exactly what you pointed out.

Last edited by frob23; 08-06-2004 at 11:25 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SuSE fstab] No write access pEeDy Linux - Newbie 7 10-11-2005 02:58 AM
Cant write to Dos partition in LE oakie15 Mandriva 1 05-10-2005 10:04 AM
What should I write in my /etc/fstab chutsu Slackware 3 09-27-2004 08:01 AM
cant write to dos partition square_eyes Linux - General 3 04-21-2003 11:50 AM
Fstab and Dos Sylhouette Linux - Software 4 12-12-2001 01:40 PM

LinuxQuestions.org > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 04:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration