LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices


Reply
  Search this Thread
Old 12-04-2003, 10:54 PM   #1
Vyeperman
Member
 
Registered: Jul 2003
Location: California
Distribution: Gentoo 1.4
Posts: 108

Rep: Reputation: 15
FreeBSD X11


I wen't to the FreeBSD handbook and did exactly what they said to do through the setting up of X and it fails when I do the command startx and all it says is

Code:
Fatal Server error: no screens found 
X connection to :0.0 broken (explicit kill or server shutdown). xauth: (argv):1: bad display name ".sd.cox.net:0" in "remove" command
I am confused since I did exactly what it said and played around and tried new things and nothing works please help.
 
Old 12-04-2003, 11:47 PM   #2
RJW
Member
 
Registered: Nov 2003
Location: Australia[WA]
Distribution: FreeBSD 5.x/6.x
Posts: 146

Rep: Reputation: 15
Have you created the file `/etc/XF86Config'?

If not, the following command will create a _basic_ one for you:
Code:
XFree86 -configure
Otherwise, can you post your `/etc/XF86Config', please?

The error ``xauth: (argv):1: bad display name ".sd.cox.net:0" in "remove" command'' means it can't resolve your computers hostname. What you need to do is place that entry in your `/etc/hosts' file:
Code:
127.0.0.1 <hostname> <hostname>.<hostdomain>
 
Old 12-04-2003, 11:57 PM   #3
Vyeperman
Member
 
Registered: Jul 2003
Location: California
Distribution: Gentoo 1.4
Posts: 108

Original Poster
Rep: Reputation: 15
Ok yes I did run XFree86 -configure, but when I ran the command xf86cfg -textmode I figured it would edit the correct file that I needed to use. When I typed "startx" it would go blank then it would say in all the text that it was using the config file /etc/X11/XF86Config so I wen't and looked at that and it looked correct then I looked at the one you said and it's configured wrong. So how can I do the "xf86cfg -textmode" configuration tool but edit the correct file?

for the hostname is this fine?

127.0.0.1 localhost sd.cox.net?

If not please clarify I don't understand what you mean. ( maybe an example?)
Thanks in advance.
 
Old 12-05-2003, 12:33 AM   #4
RJW
Member
 
Registered: Nov 2003
Location: Australia[WA]
Distribution: FreeBSD 5.x/6.x
Posts: 146

Rep: Reputation: 15
The manual page `xf86cfg' tells me the argument `-xf86config' is the XF86Config file to edit. Thus `xf86cfg -xf86config /etc/XF86Config -textmode' should do the trick.

For the host entry, you should use:
Code:
127.0.0.1 sd sd.cox.net
 
Old 12-05-2003, 12:55 AM   #5
Vyeperman
Member
 
Registered: Jul 2003
Location: California
Distribution: Gentoo 1.4
Posts: 108

Original Poster
Rep: Reputation: 15
Ok I typed
xf86cfg /etc/XF86Config -textmode
Code:
Usage: xf86cfg [-option...]  
options:
-xf86config <XF86Config>  Alternate configuration file.
-modulepath <module-path> XFree86 modules location.
-serverpath <server-path> X server to start (if $DISPLAY is not defined).
-fontpath <font-path> Font path for fonts.
-rgbpath <rgb-path> Where the rgb.txt file is located.
-textmode Use this option for the text only interface.
-nomodules Use this option if xf86cfg is slow to start.
-verbose <number> Verbosity used in the loader (default 1)
-verify Verify modules/options integrity.
So then I tried "xf86cfg XF86Config -textmode" (first option) and I got the exact same code. Then I just did "cp /etc/X11/XF86Config /etc/XF86Config" and then did "startx" and got the exact same thing even with the changes made to the /etc/hosts file I got the same message about the hostname.
=/
 
Old 12-05-2003, 01:50 AM   #6
RJW
Member
 
Registered: Nov 2003
Location: Australia[WA]
Distribution: FreeBSD 5.x/6.x
Posts: 146

Rep: Reputation: 15
No. The command is:
Code:
xf86cfg -xf86config /etc/XF86Config -textmode
What is the output of the following command:
Code:
hostname

Last edited by RJW; 12-05-2003 at 02:21 AM.
 
Old 12-05-2003, 05:15 PM   #7
Vyeperman
Member
 
Registered: Jul 2003
Location: California
Distribution: Gentoo 1.4
Posts: 108

Original Poster
Rep: Reputation: 15
ok I did the command and configured everything via that command.

The output is ".sd.cox.net"
 
Old 12-06-2003, 04:59 AM   #8
RJW
Member
 
Registered: Nov 2003
Location: Australia[WA]
Distribution: FreeBSD 5.x/6.x
Posts: 146

Rep: Reputation: 15
Does X work now?

And you hostname shouldn't have the period prefixed to it. In your `/etc/rc.conf' file, edit/add the entry `hostname="sd.cox.net"'.
 
Old 12-06-2003, 03:04 PM   #9
Vyeperman
Member
 
Registered: Jul 2003
Location: California
Distribution: Gentoo 1.4
Posts: 108

Original Poster
Rep: Reputation: 15
No X does not work.
Still does the same thing.
It still says .sd.cox.net is there something I need to kill/restart?
 
Old 12-06-2003, 08:05 PM   #10
RJW
Member
 
Registered: Nov 2003
Location: Australia[WA]
Distribution: FreeBSD 5.x/6.x
Posts: 146

Rep: Reputation: 15
Okay, you'll need to post your entire `/etc/XF86Config' and `/etc/rc.conf' files.
 
Old 12-06-2003, 11:57 PM   #11
Vyeperman
Member
 
Registered: Jul 2003
Location: California
Distribution: Gentoo 1.4
Posts: 108

Original Poster
Rep: Reputation: 15
I thought I heard something like your not aloud to post links here or something =/ but I didn't see any upload ability so here is a link to the files.

http://www.uphorium.com/test/rc.conf
http://www.uphorium.com/test/test1/XF86Config

Hope you find the problem.
(btw you might think the monitor specs in there are odd but I do have a Flat screen monitor)
 
Old 12-07-2003, 12:26 AM   #12
RJW
Member
 
Registered: Nov 2003
Location: Australia[WA]
Distribution: FreeBSD 5.x/6.x
Posts: 146

Rep: Reputation: 15
You have multiple entries in the `rc.conf' file that contradict one-another:

hostname="sd.cox.net"
ifconfig_fxp0="DHCP"
ifconfig_fxp1="DHCP"
inetd_enable="NO"
kern_securelevel_enable="NO"
linux_enable="YES"
moused_enable="YES"
nfs_client_enable="YES"
nfs_reserved_port_only="YES"
nfs_server_enable="YES"
saver="snake"
sendmail_enable="NONE"
sshd_enable="YES"
usbd_enable="YES"
kern_securelevel="2"
kern_securelevel_enable="YES"
sendmail_enable="NO"
nfs_server_enable="NO"
sshd_enable="NO"
# -- sysinstall generated deltas -- # Sat Dec 6 14:01:49 2003
keyrate="fast"

Other than that, it's fine.

With your `XF86Config', try using the following blocks:
Code:
Section "Monitor"
	#DisplaySize	  300   230	# mm
	Identifier   "Monitor0"
	VendorName   "SNY"
	ModelName    "SDM-HS53"
#	HorizSync    31.5 - 48.5
#	VertRefresh  48.0 - 75.0
	Option	    "DPMS"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Depth     24
                 Modes "1024x768"
	EndSubSection
EndSection

Last edited by RJW; 12-07-2003 at 12:27 AM.
 
Old 12-07-2003, 01:11 AM   #13
Vyeperman
Member
 
Registered: Jul 2003
Location: California
Distribution: Gentoo 1.4
Posts: 108

Original Poster
Rep: Reputation: 15
ok I replaced the old subsections with the ones above.
I took out all the contradicting code in /etc/rc.conf the reason why I think it did that was just recently I changed the security level to shutdown sendmail ssh all that stuff cuz I didn't know it could be shutdown by editing this file and i used /stand/sysinstall Which I think messes up on some things here and there.

btw I did startx and it says exact same thing. Here is what the error log says

http://www.uphorium.com/test/XFree86.0%20log
 
Old 12-07-2003, 01:32 AM   #14
RJW
Member
 
Registered: Nov 2003
Location: Australia[WA]
Distribution: FreeBSD 5.x/6.x
Posts: 146

Rep: Reputation: 15
I think the problem is with your graphics card:
Code:
(EE) No devices detected.
Search google to see if it's compatible with FreeBSD 4.8.
 
Old 12-07-2003, 02:19 AM   #15
Vyeperman
Member
 
Registered: Jul 2003
Location: California
Distribution: Gentoo 1.4
Posts: 108

Original Poster
Rep: Reputation: 15
I wasn't able to locate it on the FreeBSD site but I found a system for sale that came with freebsd and had that graphic card :-/

Intel® 845E chipset is the one I have

I believe all intel chipsets are supported but only by the i810 driver not sure tho.

I have gotten X to work on this machine before I did a reformat I just havn't ever had this much trouble before.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Core 4 - X11-devel complains about X11-libs which are installed Ephracis Fedora 3 09-05-2005 09:32 AM
As a FreeBSD user, what is the best things you like about FreeBSD? t3gah *BSD 6 06-10-2005 02:38 PM
xorg-x11-libs required by xorg-x11-devel darknails Fedora 1 01-13-2005 02:34 PM
Roaming X11/Xfree86, X11 proxy zapp Linux - Software 1 09-12-2003 08:06 AM
X11 harsham Linux - Newbie 1 12-09-2001 12:05 PM

LinuxQuestions.org > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 04:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration