LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   *BSD (https://www.linuxquestions.org/questions/%2Absd-17/)
-   -   FreeBSD X11 (https://www.linuxquestions.org/questions/%2Absd-17/freebsd-x11-122858/)

Vyeperman 12-04-2003 10:54 PM

FreeBSD X11
 
I wen't to the FreeBSD handbook and did exactly what they said to do through the setting up of X and it fails when I do the command startx and all it says is

Code:

Fatal Server error: no screens found
X connection to :0.0 broken (explicit kill or server shutdown). xauth: (argv):1: bad display name ".sd.cox.net:0" in "remove" command

I am confused since I did exactly what it said and played around and tried new things and nothing works please help.

RJW 12-04-2003 11:47 PM

Have you created the file `/etc/XF86Config'?

If not, the following command will create a _basic_ one for you:
Code:

XFree86 -configure
Otherwise, can you post your `/etc/XF86Config', please?

The error ``xauth: (argv):1: bad display name ".sd.cox.net:0" in "remove" command'' means it can't resolve your computers hostname. What you need to do is place that entry in your `/etc/hosts' file:
Code:

127.0.0.1 <hostname> <hostname>.<hostdomain>

Vyeperman 12-04-2003 11:57 PM

Ok yes I did run XFree86 -configure, but when I ran the command xf86cfg -textmode I figured it would edit the correct file that I needed to use. When I typed "startx" it would go blank then it would say in all the text that it was using the config file /etc/X11/XF86Config so I wen't and looked at that and it looked correct then I looked at the one you said and it's configured wrong. So how can I do the "xf86cfg -textmode" configuration tool but edit the correct file?

for the hostname is this fine?

127.0.0.1 localhost sd.cox.net?

If not please clarify I don't understand what you mean. ( maybe an example?)
Thanks in advance.

RJW 12-05-2003 12:33 AM

The manual page `xf86cfg' tells me the argument `-xf86config' is the XF86Config file to edit. Thus `xf86cfg -xf86config /etc/XF86Config -textmode' should do the trick.

For the host entry, you should use:
Code:

127.0.0.1 sd sd.cox.net

Vyeperman 12-05-2003 12:55 AM

Ok I typed
xf86cfg /etc/XF86Config -textmode
Code:

Usage: xf86cfg [-option...] 
options:
-xf86config <XF86Config>  Alternate configuration file.
-modulepath <module-path> XFree86 modules location.
-serverpath <server-path> X server to start (if $DISPLAY is not defined).
-fontpath <font-path> Font path for fonts.
-rgbpath <rgb-path> Where the rgb.txt file is located.
-textmode Use this option for the text only interface.
-nomodules Use this option if xf86cfg is slow to start.
-verbose <number> Verbosity used in the loader (default 1)
-verify Verify modules/options integrity.

So then I tried "xf86cfg XF86Config -textmode" (first option) and I got the exact same code. Then I just did "cp /etc/X11/XF86Config /etc/XF86Config" and then did "startx" and got the exact same thing even with the changes made to the /etc/hosts file I got the same message about the hostname.
=/

RJW 12-05-2003 01:50 AM

No. The command is:
Code:

xf86cfg -xf86config /etc/XF86Config -textmode
What is the output of the following command:
Code:

hostname

Vyeperman 12-05-2003 05:15 PM

ok I did the command and configured everything via that command.

The output is ".sd.cox.net"

RJW 12-06-2003 04:59 AM

Does X work now?

And you hostname shouldn't have the period prefixed to it. In your `/etc/rc.conf' file, edit/add the entry `hostname="sd.cox.net"'.

Vyeperman 12-06-2003 03:04 PM

No X does not work.
Still does the same thing.
It still says .sd.cox.net is there something I need to kill/restart?

RJW 12-06-2003 08:05 PM

Okay, you'll need to post your entire `/etc/XF86Config' and `/etc/rc.conf' files.

Vyeperman 12-06-2003 11:57 PM

I thought I heard something like your not aloud to post links here or something =/ but I didn't see any upload ability so here is a link to the files.

http://www.uphorium.com/test/rc.conf
http://www.uphorium.com/test/test1/XF86Config

Hope you find the problem.
(btw you might think the monitor specs in there are odd but I do have a Flat screen monitor)

RJW 12-07-2003 12:26 AM

You have multiple entries in the `rc.conf' file that contradict one-another:

hostname="sd.cox.net"
ifconfig_fxp0="DHCP"
ifconfig_fxp1="DHCP"
inetd_enable="NO"
kern_securelevel_enable="NO"
linux_enable="YES"
moused_enable="YES"
nfs_client_enable="YES"
nfs_reserved_port_only="YES"
nfs_server_enable="YES"
saver="snake"
sendmail_enable="NONE"
sshd_enable="YES"
usbd_enable="YES"
kern_securelevel="2"
kern_securelevel_enable="YES"
sendmail_enable="NO"
nfs_server_enable="NO"
sshd_enable="NO"
# -- sysinstall generated deltas -- # Sat Dec 6 14:01:49 2003
keyrate="fast"

Other than that, it's fine.

With your `XF86Config', try using the following blocks:
Code:

Section "Monitor"
        #DisplaySize          300  230        # mm
        Identifier  "Monitor0"
        VendorName  "SNY"
        ModelName    "SDM-HS53"
#        HorizSync    31.5 - 48.5
#        VertRefresh  48.0 - 75.0
        Option            "DPMS"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device    "Card0"
        Monitor    "Monitor0"
        DefaultDepth    24
        SubSection "Display"
                Depth    24
                Modes "1024x768"
        EndSubSection
EndSection


Vyeperman 12-07-2003 01:11 AM

ok I replaced the old subsections with the ones above.
I took out all the contradicting code in /etc/rc.conf the reason why I think it did that was just recently I changed the security level to shutdown sendmail ssh all that stuff cuz I didn't know it could be shutdown by editing this file and i used /stand/sysinstall Which I think messes up on some things here and there.

btw I did startx and it says exact same thing. Here is what the error log says

http://www.uphorium.com/test/XFree86.0%20log

RJW 12-07-2003 01:32 AM

I think the problem is with your graphics card:
Code:

(EE) No devices detected.
Search google to see if it's compatible with FreeBSD 4.8.

Vyeperman 12-07-2003 02:19 AM

I wasn't able to locate it on the FreeBSD site but I found a system for sale that came with freebsd and had that graphic card :-/

Intel® 845E chipset is the one I have

I believe all intel chipsets are supported but only by the i810 driver not sure tho.

I have gotten X to work on this machine before I did a reformat I just havn't ever had this much trouble before. :(


All times are GMT -5. The time now is 08:26 AM.