LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   *BSD (https://www.linuxquestions.org/questions/%2Absd-17/)
-   -   FreeBSD 6.2 buildworld fail, "getpublickey.c:70: warning:" (https://www.linuxquestions.org/questions/%2Absd-17/freebsd-6-2-buildworld-fail-getpublickey-c-70-warning-553383/)

Mr_Shameless 05-12-2007 11:09 AM

FreeBSD 6.2 buildworld fail, "getpublickey.c:70: warning:"
 
My FreeBSD version is 6.2.

I downloaded the source from FreeBSD FTP host and make buildworld under /usr/src. These are the last lines:
Code:

In file included from /usr/src/lib/libc/rpc/getpublickey.c:178:
/usr/src/lib/libc/rpc/getpublickey.c: In function `getpublickey':
/usr/src/lib/libc/rpc/getpublickey.c:70: warning: passing arg 1 of `__getpublickey_real' discards qualifiers from pointer target type
*** Error code 1

Stop in /usr/src/lib/libc.
*** Error code 1

Stop in /usr/src/lib.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.

I don't know what they mean. So, what do I have to do?

Thank you very much :)

anomie 05-12-2007 09:17 PM

Use # cd /usr/src && make cleanworld and try again.

If that doesn't work, post your:
  • source supfile
  • /etc/make.conf

Mr_Shameless 05-13-2007 12:13 AM

Thank you :)

I tried it and failed again, with the same result. I think i need to show you my files.

My CPU is a 667MHz Celeron (Coppermine).

Here is my /etc/make.conf
Code:

# added by use.perl 2007-04-18 21:19:59
PERL_VER=5.8.8
PERL_VERSION=5.8.8

CPUTYPE?=pentium3
CFLAGS= -O2 -pipe -finline-functions
CXXFLAGS+= -fconserve-space
MAKE_SHELL?=sh
COPTFLAGS= -O -pipe
INSTALL=install -C

The two "PERL" lines were there from the start. The other lines, i copied and edited them from the example.

What is "source supfile"? Sorry i dont know. This is the result when i search my computer. Oh, i updated my database right before doing this :)
Code:

phnguyen# locate supfile
/usr/ports/net/cvsup-mirror/files/supfile
/usr/share/examples/cvsup/cvs-supfile
/usr/share/examples/cvsup/doc-supfile
/usr/share/examples/cvsup/gnats-supfile
/usr/share/examples/cvsup/ports-supfile
/usr/share/examples/cvsup/stable-supfile
/usr/share/examples/cvsup/standard-supfile
/usr/share/examples/cvsup/www-supfile
/usr/src/share/examples/cvsup/cvs-supfile
/usr/src/share/examples/cvsup/doc-supfile
/usr/src/share/examples/cvsup/gnats-supfile
/usr/src/share/examples/cvsup/ports-supfile
/usr/src/share/examples/cvsup/stable-supfile
/usr/src/share/examples/cvsup/standard-supfile
/usr/src/share/examples/cvsup/www-supfile

All of them are examples right? Does the one you want exist? That file relates with cvsup, doesnt it? I've never used cvsup, i think. I've always updated my ports tree using portsnap.

Please tell me what i have to do next.

Thank you very much :)

Mr_Shameless 05-13-2007 08:10 AM

K, these are the contents of the supfiles above. They're examples, so they're also the default settings right? I dont know if what im doing is sensible but i will do anything i can. Our timezones are different so i dont wanna waste time :D

I omitted all the comments.

/usr/src/share/examples/cvsup/cvs-supfile
Code:

*default host=CHANGE_THIS.FreeBSD.org
*default base=/var/db
*default prefix=/home/ncvs
*default release=cvs
*default delete use-rel-suffix

*default compress

src-all

ports-all

doc-all

www

cvsroot-all

/usr/src/share/examples/cvsup/doc-supfile
Code:

*default host=CHANGE_THIS.FreeBSD.org
*default base=/var/db
*default prefix=/usr

*default release=cvs tag=.
*default delete use-rel-suffix

*default compress

doc-all

/usr/src/share/examples/cvsup/gnats-supfile
Code:

*default host=CHANGE_THIS.FreeBSD.org
*default base=/var/db
*default prefix=/usr
*default release=current
*default delete use-rel-suffix

*default compress

gnats

/usr/src/share/examples/cvsup/ports-supfile
Code:

*default host=CHANGE_THIS.FreeBSD.org
*default base=/var/db
*default prefix=/usr
*default release=cvs tag=.
*default delete use-rel-suffix

*default compress

ports-all

/usr/src/share/examples/cvsup/stable-supfile
Code:

*default host=CHANGE_THIS.FreeBSD.org
*default base=/var/db
*default prefix=/usr

*default release=cvs tag=RELENG_6
*default delete use-rel-suffix


*default compress

src-all

/usr/src/share/examples/cvsup/standard-supfile
Code:

kensmith Exp $
*default host=CHANGE_THIS.FreeBSD.org
*default base=/var/db
*default prefix=/usr
*default release=cvs tag=RELENG_6_2
*default delete use-rel-suffix

*default compress

src-all

/usr/src/share/examples/cvsup/www-supfile
Code:

*default host=CHANGE_THIS.FreeBSD.org
*default base=/var/db
*default prefix=/usr
*default release=cvs tag=.
*default delete use-rel-suffix

*default compress

www

But let me say again that I have never updated my ports tree using cvsup. When installing FreeBSD, i chose a minimal system, then used portsnap to update my tree. Then when i wanted to recompile the kernel, i got the kernel source from the CD. Yesterday before making buildworld, i realized that i missed the sources, so i sysinstall --> Configure --> Distributions --> src --> All. I chose to install via FTP, not my CD anymore.

Umm..., so, do i need to update my port tree again using cvsup to make it easier for you? If it's neccesarry, i will do it. OMG, i dont know anything, lol.

Thanks thanks :D

anomie 05-13-2007 10:59 AM

Copy /usr/src/share/examples/cvsup/standard-supfile into /root and edit it there. Change
Code:

*default host=CHANGE_THIS.FreeBSD.org
so that it is using one of the mirrors. If possible pick one in your country.

Then install cvsup-without-gui, and run # cvsup /root/standard-supfile

Next, comment all that other business out of your /etc/make.conf so that it looks like this:
Code:

# added by use.perl 2007-04-18 21:19:59
PERL_VER=5.8.8
PERL_VERSION=5.8.8

#CPUTYPE?=pentium3
#CFLAGS= -O2 -pipe -finline-functions
#CXXFLAGS+= -fconserve-space
#MAKE_SHELL?=sh
#COPTFLAGS= -O -pipe
#INSTALL=install -C

Finally, run # cd /usr/src && make cleanworld and try your buildworld again.

Mr_Shameless 05-14-2007 05:25 AM

Thank you, i made it :)

I installed cvsup-without-gui, then used it to download the sources.

About the /etc/make.conf file, actually i just deleted the -finline-functions option, and the building was successful. I just wanted to keep the other options for the last time to see if they worked, and to try what people called "optimizing". OMG, before "optimizing", i had 154MBs of free RAM when starting up, and now its 152MBs, lol. But its ok. I dont mind getting my hands dirty to try new things :D


All times are GMT -5. The time now is 11:36 PM.