LinuxQuestions.org
Review your favorite Linux distribution.
Home Forums Tutorials Articles Register
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices


Reply
  Search this Thread
Old 01-20-2005, 07:02 AM   #1
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,623

Rep: Reputation: 51
freeBSD 5.3 will not load the sound driver during the startup


hi

every time after restart my freeBSD 5.3 doesn't load the SOUND driver:
Code:
bsd# cat /dev/sndstat
cat: /dev/sndstat: No such file or directory
bsd# kldstat
Id Refs Address    Size     Name
 1    7 0xc0400000 5cdad0   kernel
 2   14 0xc09ce000 537f0    acpi.ko
 3    1 0xc268a000 17000    linux.ko
my /boot/load.conf looks:
Code:
bsd# cat /boot/loader.conf
sound_load="YES"
snd_via8233_load="YES"
linux_load="YES"
but the sound driver will not be loaded after restart !


only if I do manually from the Konsole:
Code:
bsd# kldload snd_via8233
bsd# cat /dev/sndstat
FreeBSD Audio Driver (newpcm)
Installed devices:
pcm0: <VIA VT8235> at io 0xd800 irq 5 kld snd_via8233 (5p/1r/0v channels duplex default)
bsd# kldstat
Id Refs Address    Size     Name
 1    9 0xc0400000 5cdad0   kernel
 2   14 0xc09ce000 537f0    acpi.ko
 3    1 0xc268a000 17000    linux.ko
 4    1 0xc2e4e000 4000     snd_via8233.ko
 5    1 0xc2e52000 18000    sound.ko
then the sound works well.

Knows someone, how can I solve this problem ?
 
Old 01-22-2005, 02:58 PM   #2
Clark Bent
Member
 
Registered: Jul 2004
Distribution: Debian, FreeBSD, Slamd64
Posts: 201

Rep: Reputation: 30
Most interesting. Here is a thought. Try removing the sound_load="YES" from /boot/loader.conf. I suspect what is happening, is that when you load up your driver for your sound and try to load sound too, it is causing a conflict because sound is loaded automatically when the driver is loaded. It errors out I suspect. I myself have a creative labs card. My /boot/loader.conf looks like this:
code:

snd_emul101_load="YES"

That is all it has in it. My sound comes up evertime I reboot just fine. If memory serves, I too also had the sound_load="YES" in mine and it wouldn't work until I removed it. Give it a try.
 
Old 01-22-2005, 07:13 PM   #3
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,623

Original Poster
Rep: Reputation: 51
I have now:
Code:
bsd# cat /boot/loader.conf
snd_via8233_load="YES"
linux_load="YES"
but still doesn't work !
 
Old 01-22-2005, 07:41 PM   #4
Clark Bent
Member
 
Registered: Jul 2004
Distribution: Debian, FreeBSD, Slamd64
Posts: 201

Rep: Reputation: 30
Strange. Check it out:

$ kldstat
Id Refs Address Size Name
1 9 0xc0400000 33f260 kernel
2 1 0xc0740000 7494 snd_emu10k1.ko
3 2 0xc0748000 1d4fc sound.ko
4 14 0xc0766000 537f0 acpi.ko
5 1 0xc23e4000 17000 linux.ko
$


I was hoping I could help you with a quick and easy fix but looks like we will need some extra help.
 
Old 01-22-2005, 07:53 PM   #5
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 65
See if you can also load the module by the automatic process:

kldload snd_driver

if that works, simply try adding the following line at your /boot/loader.conf:

snd_driver_load="YES"

I also found your problem to be pretty interesting, if you'd ask me

Good luck!
 
Old 01-22-2005, 09:01 PM   #6
Clark Bent
Member
 
Registered: Jul 2004
Distribution: Debian, FreeBSD, Slamd64
Posts: 201

Rep: Reputation: 30
Heheh...yeah I almost said the same thing as you Megaman, but if you scan up, you'll see he has already tried those things.
 
Old 01-22-2005, 09:11 PM   #7
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 65
 
Old 01-23-2005, 05:43 AM   #8
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,623

Original Poster
Rep: Reputation: 51
Quote:
Originally posted by Megaman X
See if you can also load the module by the automatic process:
kldload snd_driver
if that works, simply try adding the following line at your /boot/loader.conf:
snd_driver_load="YES"
I've tried already, but still doesn't help !
Code:
bsd# kldstat
Id Refs Address    Size     Name
 1    7 0xc0400000 5cdad0   kernel
 2   14 0xc09ce000 537f0    acpi.ko
 3    1 0xc268a000 17000    linux.ko
 
Old 01-23-2005, 07:25 AM   #9
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,623

Original Poster
Rep: Reputation: 51
dmesg says:
Code:
pci0: <multimedia, audio> at device 17.5 (no driver attached)
or if I try to load manually:
Code:
bsd# kldload snd_driver
Jan 23 13:18:06 bsd kernel: sio1: configured irq 3 not in bitmap of probed irqs 0
Jan 23 13:18:06 bsd kernel: sio1: port may not be enabled
Jan 23 13:18:07 bsd kernel: sio1: configured irq 3 not in bitmap of probed irqs 0
Jan 23 13:18:07 bsd kernel: sio1: port may not be enabled
Jan 23 13:18:07 bsd kernel: sio1: configured irq 3 not in bitmap of probed irqs 0
Jan 23 13:18:07 bsd kernel: sio1: port may not be enabled
Jan 23 13:18:12 bsd kernel: sio1: configured irq 3 not in bitmap of probed irqs 0
Jan 23 13:18:12 bsd kernel: sio1: port may not be enabled
Jan 23 13:18:12 bsd kernel: sio1: configured irq 3 not in bitmap of probed irqs 0
Jan 23 13:18:12 bsd kernel: sio1: port may not be enabled
Jan 23 13:18:12 bsd kernel: sio1: configured irq 3 not in bitmap of probed irqs 0
Jan 23 13:18:12 bsd kernel: sio1: port may not be enabled
Jan 23 13:18:12 bsd kernel: sio1: configured irq 3 not in bitmap of probed irqs 0
Jan 23 13:18:12 bsd kernel: sio1: port may not be enabled
Jan 23 13:18:13 bsd kernel: pcm0: <VIA VT8235> port 0xd800-0xd8ff irq 5 at device 17.5 on pci0
Jan 23 13:18:13 bsd kernel: pcm0: [GIANT-LOCKED]
Jan 23 13:18:13 bsd kernel: pcm0: <VIA Technologies VIA1612A AC97 Codec>
maybe there is a problem ?

Last edited by cccc; 01-23-2005 at 07:54 AM.
 
Old 01-23-2005, 01:26 PM   #10
-X-
Member
 
Registered: Oct 2003
Location: Tx,USA
Distribution: Slackware, Red Hat, CentOS
Posts: 495

Rep: Reputation: 30
I had the same problem and ended up with a /usr/local/etc/rc.d/startup.sh script with the two kldload statements to get sound. Undo the kernel and loader.conf stuff.
 
Old 01-23-2005, 02:40 PM   #11
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,623

Original Poster
Rep: Reputation: 51
there is a solution:

change in /boot/defaults/loader.conf

from:
sound_load="NO"
snd_via8233_load="NO"

to:
sound_load="YES"
snd_via8233_load="YES"

default is "NO"
Code:
##############################################################
###  Sound modules  ##########################################
##############################################################

sound_load="NO"			# Digital sound subsystem
snd_ad1816_load="NO"		# ad1816
snd_cmi_load="NO"		# cmi
snd_csa_load="NO"		# csa
snd_cs4281_load="NO"		# cs4281
snd_ds1_load="NO"		# ds1
snd_emu10k1_load="NO" 		# Creative Sound Blaster Live
snd_ess_load="NO"		# ess
snd_es137x_load="NO"		# es137x
snd_fm801_load="NO"		# fm801
snd_ich_load="NO"		# Intel ICH
snd_maestro_load="NO"		# Maestro
snd_maestro3_load="NO"		# Maestro3
snd_mss_load="NO"		# Mss
snd_neomagic_load="NO"		# Neomagic
snd_sbc_load="NO"		# Sbc
snd_sb8_load="NO"		# Sound Blaster Pro
snd_sb16_load="NO"		# Sound Blaster 16
snd_solo_load="NO"		# Solo
snd_t4dwave_load="NO"		# t4dwave
snd_via8233_load="NO"		# via8233
snd_via82c686_load="NO"		# via82c686
snd_driver_load="NO"		# All sound drivers
my /boot/loader.conf is empty and it works well !

greetings
cccc

Last edited by cccc; 01-23-2005 at 03:48 PM.
 
  


Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[Newbie] [FreeBSD] Error while initializing the sound driver kloss Linux - Hardware 2 06-01-2005 01:09 PM
Sound Driver intel8x0 hangs on startup, can only boot from cd. mwaddoups SUSE / openSUSE 4 05-20-2005 02:27 AM
sound at startup, ATI driver failure, package installations trey31357 Linux - Newbie 2 04-12-2005 09:15 PM
[SOLVED] sound card driver does not load on boot uncle guido SUSE / openSUSE 2 01-26-2005 01:21 PM
How to make sound works on FreeBSD & mount extended partition & ATI radeon driver Ninja_212 *BSD 3 11-02-2004 06:36 AM

LinuxQuestions.org > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 06:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration