LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices


Reply
  Search this Thread
Old 11-11-2018, 09:36 AM   #1
tramni1980
Member
 
Registered: Jul 2006
Location: Gießen, Germany
Distribution: Slackware64-14.2 & -current
Posts: 806

Rep: Reputation: 49
Desktop problems


Hello, I am running DragonFly BSD 5.2.2 on my 10-year-old laptop TOSHIBA TECRA S11-11H.
Code:
 Intel® Core™ i5-520M Processor, 4 GB DDR3 RAM, NVIDIA® Quadro® NVS 2100M mit CUDA™ Technology,
Monitor resolution:  1600 x 900 , 802.11a/b/g/n Wireless Technology Version : Intel® Centrino® Advanced-N 6200.
My /root and /home disklabel partitions have the HAMMER filesystem,
the /boot partition has UFS.

After installation the VESA driver was started, which could not provide the native 1600 x 900 display resolution I need.
Installing xf86-video-nv-2.1.21_1 solved this problem.

I tried most of the available desktop environments for dragonfly: windowmaker, lumina, mate, lxde, xfce, kde. All desktops
except for windowmaker and lumina are practically unusable, because the logout time is about 4 minutes. This is the time between
clicking on logout and the actual logout. Furhtermore, on kde the opening of the start menu itself takes about 2 minutes.
The biggest problems occurred with the mate desktop, where the logout time is more than 15 minutes, I never waited to see
if it is even finite. The mate-terminal fails to start. Trying to start most applications from the command line in mate
fails (e.g. vim, gvim, kate, kwrite, thunderbird). The only text editor that opens there is mousepad.
Kate and kwrite print the following message:

Code:
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
and never start. Vim and gvim never start, the console window hangs and I can do nothing but close it.
I am typing this from lumina, which works pretty OK, all the applications so far start and seem to behave well.

When I start lxde, I get a window the following message:
Code:
GDBus.Error:org.freedesktop.ConsoleKit.Manager.Error.General:
Unable to lookup session information for process '2838'
After that lxde works pretty OK, but the logout time is about 4 minutes.

cinnamon starts OK only in software rendering mode and complains of many features and extensions missing.
In the normal mode I only get a black screen and have to kill Xorg. The logout time is extremely long, never waited.

I refrained from starting the hal daemon, because it results in flooding my terminals
with messages about my cdrom (being printed every second) that contain something like:
Code:
ahci0.1: TFS ccb slot rfis flg st err dev off
I have installed OpenBSD on another slice of the same hard drive and I have none of the above problems there.
It is therefore definitely a software issue, probably I am missing some settings?

Thank you very much for your attention. Any suggestions will be appreciated.
 
Old 11-12-2018, 05:44 AM   #2
cynwulf
Senior Member
 
Registered: Apr 2005
Posts: 2,187
Blog Entries: 5

Rep: Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248
Quote:
Originally Posted by tramni1980 View Post
Code:
Intel® Core™ i5-520M Processor, 4 GB DDR3 RAM, NVIDIA® Quadro® NVS 2100M mit CUDA™ Technology
The problem is the Nvidia GPU. Last time I checked, there was no support for switching in DragonFly.

However it's worth checking the BIOS for an option to completely disable the Nvidia discrete graphics and use the CPUs integrated Intel graphics.
Quote:
Originally Posted by tramni1980 View Post
After installation the VESA driver was started, which could not provide the native 1600 x 900 display resolution I need.
Installing xf86-video-nv-2.1.21_1 solved this problem.
Can you revert back to vesa - ignoring the resolution problems for now and check if you have the same problems?

Quote:
Originally Posted by tramni1980 View Post
I have installed OpenBSD on another slice of the same hard drive and I have none of the above problems there.
Odd because OpenBSD has no Nvidia hardware support. What driver are you using?
 
Old 11-13-2018, 04:44 AM   #3
tramni1980
Member
 
Registered: Jul 2006
Location: Gießen, Germany
Distribution: Slackware64-14.2 & -current
Posts: 806

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by cynwulf View Post
The problem is the Nvidia GPU. Last time I checked, there was no support for switching in DragonFly.

However it's worth checking the BIOS for an option to completely disable the Nvidia discrete graphics and use the CPUs integrated Intel graphics.
No, unfortunately my BIOS does not have such an option.
Quote:
Originally Posted by cynwulf View Post
Can you revert back to vesa - ignoring the resolution problems for now and check if you have the same problems?
Yes, in VESA the problems were similar, plus the bad resolution.

Quote:
Originally Posted by cynwulf View Post
Odd because OpenBSD has no Nvidia hardware support. What driver are you using?
In OpenBSD I am using also the nv driver. Honestly, that is how I found the solution to the resolution problem,
I had the correct resolution in OpenBSD and checked what driver it uses. I saw it was nv and then downloaded nv also
for Dragonfly.


Meanwhile, the problem seems to be largely solved by fixing a DBus library problem, as suggested to me in
the DragonFly users mailing list:

Code:
ln -s /usr/local/lib/libmozjs-52.so.1 /usr/local/lib/libmozjs-52.so.0
Now the logout time is normal in all desktop environments. All problems with MATE were solved, I am
now typing from MATE in DragonFly. Thus, this turned out to be a DBus problem.
The only thing that still annoys me is the following message I get at staring the LXDE desktop:
Code:
"GDBus.Error:org.freedesktop.ConsoleKit.Manager.Error.General:
Unable to lookup session information for process '2838'"
This has something to do with DBus and ConsoleKit, but I don't know any further.
Any suggestions will be appreciated!

Best regards,
Martin
 
Old 11-13-2018, 06:35 AM   #4
cynwulf
Senior Member
 
Registered: Apr 2005
Posts: 2,187
Blog Entries: 5

Rep: Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248
Ok yes, it appears I was far too hasty in pointing the blame at the Nvidia hardware and ignored the obvious dbus errors scattered throughout your post...

Are you using a display manager or startx?

Is the messagebus enabled in rc.conf?
 
1 members found this post helpful.
Old 11-13-2018, 12:29 PM   #5
jggimi
Member
 
Registered: Jan 2016
Distribution: None. Just OpenBSD.
Posts: 171

Rep: Reputation: 61
Quote:
Originally Posted by tramni1980 View Post
In OpenBSD I am using also the nv driver.
You are one of the lucky ones with NVIDIA hardware supported by the nv(4) driver. This was an open source driver written by NVIDIA at a time when they were still writing open drivers for their closed interfaces. They have since switched to closed-source drivers.
 
1 members found this post helpful.
Old 11-14-2018, 01:24 PM   #6
tramni1980
Member
 
Registered: Jul 2006
Location: Gießen, Germany
Distribution: Slackware64-14.2 & -current
Posts: 806

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by cynwulf View Post
Are you using a display manager or startx?
I am using startx for loading the desktop environment. Here is my .xinitrc:
Code:
#exec start-lumina-desktop
#exec wmaker
#exec startlxde
#exec startxfce4
#exec startkde
#exec cinnamon-session-cinnamon2d
#exec cinnamon-session
exec mate-session
Quote:
Originally Posted by cynwulf View Post
Is the messagebus enabled in rc.conf?
Yes, here is my rc.conf:

Code:
 $DragonFly: src/nrelease/root/etc/rc.conf,v 1.3 2008/02/17 19:51:53 swildner Exp $
# rc.conf for CDRom boot.
#
# NOTE!  This rc.conf is designed for a CD boot.  When starting fresh on
# your HD you can simply remove most or all of the lines below and then
# add features as appropriate.
#
nfs_reserved_port_only="YES"
syslogd_enable="NO"
nfs_client_enable="YES"
rpc_umntall_enable="NO"
cron_enable="NO"
wlans_iwn0="wlan0"
ifconfig_wlan0="WPA DHCP"
dbus_enable="YES"
#hald_enable="YES"
enable_ntpd="YES"
sshd_enable="YES"
 
Old 11-15-2018, 04:56 AM   #7
cynwulf
Senior Member
 
Registered: Apr 2005
Posts: 2,187
Blog Entries: 5

Rep: Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248
Ok as you're using startx, in your .xinitrc change the exec stanzas for the session managers/startup scripts to something like:

Code:
exec ck-launch-session dbus-launch mate-session
 
Old 11-15-2018, 02:00 PM   #8
tramni1980
Member
 
Registered: Jul 2006
Location: Gießen, Germany
Distribution: Slackware64-14.2 & -current
Posts: 806

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by cynwulf View Post
Ok as you're using startx, in your .xinitrc change the exec stanzas for the session managers/startup scripts to something like:

Code:
exec ck-launch-session dbus-launch mate-session
Thank you very much. After correcting the library problem the mate desktop worked well and without any error messages. It was only LXDE that complained about DBus. Adding "ck-launch-session dbus-launch" at the exec command for LXDE solved the problem, the error message does not appear any more. The most responsive desktop is XFCE, that is why am switching now to it. Thank you very much again!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with my Desktop Sape73 Linux - Desktop 10 06-18-2018 01:43 AM
ubuntu-desktop vs. kubuntu-desktop vs. xubuntu-desktop vs. lubuntu-desktop vs. unity Kenny_Strawn Ubuntu 18 05-13-2011 10:20 AM
Desktop Problems?! Prada Linux - Software 1 04-24-2007 12:33 AM
some problems with desktop TurtleFace Debian 1 03-12-2007 01:39 PM

LinuxQuestions.org > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 06:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration