LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices


Reply
  Search this Thread
Old 01-17-2019, 04:31 PM   #1
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware14.2 64-Bit Desktop, Devuan 2.0 ASCII Toshiba Satellite Notebook
Posts: 2,658

Rep: Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724
A hyper mouse or normal mouse but you cannot click


This is some kind of GhostBSD thing. I am playing with GhostBSD 18.12, and the only issue I have is the mouse. Seriously, I have it set on the lowest setting for both acceleration and sensitivity - but it is just as fast and sensitive:

Click image for larger version

Name:	VirtualBox_FreeBSD_15_01_2019_02_08_40.jpg
Views:	12
Size:	172.6 KB
ID:	29487

I then went into the settings in VirtualBox, changed the pointing device from PS/2 to USB Tablet, much better the speed and sensitivity is now sane; but now I cannot actually click on anything, great!

Click image for larger version

Name:	Screenshot_2019-01-17_15-32-47.png
Views:	7
Size:	52.1 KB
ID:	29488

So my choices are:

1. Extremely hyper mouse cursor movement
2. Sane speeds, but can't actually do anything

Thoughts?

Last edited by Jeebizz; 01-17-2019 at 04:34 PM.
 
Old 01-17-2019, 05:38 PM   #2
cynwulf
Senior Member
 
Registered: Apr 2005
Posts: 2,215
Blog Entries: 5

Rep: Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284
Is it a PS/2 mouse or a USB one?

Is moused(8) enabled in rc.conf?
 
Old 01-17-2019, 05:45 PM   #3
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware14.2 64-Bit Desktop, Devuan 2.0 ASCII Toshiba Satellite Notebook
Posts: 2,658

Original Poster
Rep: Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724
USB mouse. Also since I am using VirtualBox I first left it on default PS/2. As for rc.conf, this is left over from the live iso even though I installed GhostBSD:


Code:
kload_nvidia=nvidia0modeset nvidia"
root_rw_mount=NO"
sendmail_enable="NONE"
sendmail_submit_enable="NO"
sendmail_outbound_enable="NO"
sendmail_msp_queue_enable="NO"
devfs_system_ruleset="devfsrules_common"
rc_interactive="YES"
ntpd_enable="YES"
ntpd_sync_on_start="YES"
keymap="us.iso"
hostname="breadmoth.ghostbsd-pc.home"
zfs_enable="YES"
ifconfig_em0="DHCP"

Last edited by Jeebizz; 01-17-2019 at 05:52 PM.
 
Old 01-17-2019, 06:01 PM   #4
cynwulf
Senior Member
 
Registered: Apr 2005
Posts: 2,215
Blog Entries: 5

Rep: Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284
Does the VM provide an option to change it from a PS/2 to USBHID or whatever? (same for keyboard)
 
Old 01-17-2019, 06:09 PM   #5
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware14.2 64-Bit Desktop, Devuan 2.0 ASCII Toshiba Satellite Notebook
Posts: 2,658

Original Poster
Rep: Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724
Yes, I actually have 3 choices - PS/2 , USB-Tablet and USB-Tablet-Multitouch. If I want to actually be able to click anything, I have to select PS/2 as shown in my screenshots.
 
Old 01-17-2019, 06:18 PM   #6
cynwulf
Senior Member
 
Registered: Apr 2005
Posts: 2,215
Blog Entries: 5

Rep: Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284
Yes sorry, you did state as much in your original post...

Try enabling moused in rc.conf for a start and see if that changes anything.
 
Old 01-17-2019, 06:19 PM   #7
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware14.2 64-Bit Desktop, Devuan 2.0 ASCII Toshiba Satellite Notebook
Posts: 2,658

Original Poster
Rep: Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724
So would that just be mousepad="YES" ?
 
Old 01-17-2019, 06:29 PM   #8
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware14.2 64-Bit Desktop, Devuan 2.0 ASCII Toshiba Satellite Notebook
Posts: 2,658

Original Poster
Rep: Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724
mousepad="YES" has no effect, it is still really fast, or I cannot click anything when I switch between PS/2 and USB Tablet on the VM settings.
 
Old 01-17-2019, 06:57 PM   #9
cynwulf
Senior Member
 
Registered: Apr 2005
Posts: 2,215
Blog Entries: 5

Rep: Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284
moused_enable="YES"

As detailed in rc.conf(5)
 
Old 01-17-2019, 07:03 PM   #10
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware14.2 64-Bit Desktop, Devuan 2.0 ASCII Toshiba Satellite Notebook
Posts: 2,658

Original Poster
Rep: Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724
Still no effect, mouse is still really fast and sensitive on PS/2.
 
Old 01-17-2019, 07:21 PM   #11
Trihexagonal
Member
 
Registered: Jul 2017
Location: Land of 1000 Nights
Distribution: FreeBSD, OpenBSD and Solaris
Posts: 183

Rep: Reputation: 158Reputation: 158
I no longer have any mouse variables in /etc/rc.conf but try:

mouse_type="auto"
 
Old 01-17-2019, 07:26 PM   #12
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware14.2 64-Bit Desktop, Devuan 2.0 ASCII Toshiba Satellite Notebook
Posts: 2,658

Original Poster
Rep: Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724
Nope, still no change. A valiant try I appreciate all your attempts. I have to conclude something is just wrong with how GhostBSD is setup by default. *shrug*
 
Old 01-17-2019, 07:35 PM   #13
Trihexagonal
Member
 
Registered: Jul 2017
Location: Land of 1000 Nights
Distribution: FreeBSD, OpenBSD and Solaris
Posts: 183

Rep: Reputation: 158Reputation: 158
Well, GhostBSD did recently start following TrueOS...
 
Old 01-18-2019, 04:59 AM   #14
cynwulf
Senior Member
 
Registered: Apr 2005
Posts: 2,215
Blog Entries: 5

Rep: Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284
I suggest just installing FreeBSD and seeing if you get the same mouse behaviour...

Better still would be to get rid of the flakey x86 virtualisation and install on bare metal.

You could try vmware of course, if memory serves I had better luck with that with any of the 'BSDs.
 
Old 01-19-2019, 01:06 PM   #15
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware14.2 64-Bit Desktop, Devuan 2.0 ASCII Toshiba Satellite Notebook
Posts: 2,658

Original Poster
Rep: Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724
I'll try FreeBSD again. Only problem with FreeBSD after trying to follow documentation and configuring I couldn't even get a proper XWindows session to work. Installing on actual hardware is not an option. Right now I am just experimenting to see where it goes, which is why I am running a VM instead.

Last edited by Jeebizz; 01-19-2019 at 01:35 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Computer detecting right-click as left-click, left-click as left-click and middle with 2 fingers pressed as right-click Festerdam Linux - Newbie 5 06-19-2017 06:41 PM
Single mouse click acts as a double click TheIndependentAquarius Linux - Hardware 9 08-31-2010 02:50 AM
middle mouse click is replaced by the dual click wanas Linux - Desktop 2 05-15-2009 05:53 PM
mouse: single-click becomes double-click kinzlaw Linux - Hardware 2 08-24-2005 08:55 PM

LinuxQuestions.org > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 05:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration