LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices


Reply
  Search this Thread
Old 05-30-2004, 11:32 PM   #1
yfn
LQ Newbie
 
Registered: Aug 2003
Posts: 6

Rep: Reputation: 0
30 second application start delay with KPPP


I just installed FreeBSD 5 and got my Lucent LT winmodem to work. However whenever I am connected to the internet there is a 30 second delay for any application in gnome or kde to start. I will click on gterm and it will say "starting gterm.." in the taskbar then go away then 30 or more seconds later gterm will pop up. It is doing this with all applications even terminal applications like emacs. I found a post about a similar problem in newsgroups but no one replied with an answer. If I could get this ironed out FreeBSD would be awesome...

Last edited by yfn; 05-30-2004 at 11:33 PM.
 
Old 05-31-2004, 10:30 AM   #2
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
It's something in the hosts file. What do you have in there?
 
Old 05-31-2004, 02:54 PM   #3
yfn
LQ Newbie
 
Registered: Aug 2003
Posts: 6

Original Poster
Rep: Reputation: 0
This is my /etc/hosts file, which I havn't altered so far:

# $FreeBSD: src/etc/hosts,v 1.16 2003/01/28 21:29:23 dbaker Exp $
#
# Host Database
#
# This file should contain the addresses and aliases for local hosts that
# share this file. Replace 'my.domain' below with the domainname of your
# machine.
#
# In the presence of the domain name service or NIS, this file may
# not be consulted at all; see /etc/nsswitch.conf for the resolution order.
#
#

::1 localhost localhost.my.domain myname.my.domain
127.0.0.1 localhost localhost.my.domain myname.my.domain



# Imaginary network.
#10.0.0.2 myname.my.domain myname
#10.0.0.3 myfriend.my.domain myfriend
#
# According to RFC 1918, you can use the following IP networks for
# private nets which will never be connected to the Internet:
#
# 10.0.0.0 - 10.255.255.255
# 172.16.0.0 - 172.31.255.255
# 192.168.0.0 - 192.168.255.255
#
# In case you want to be able to connect to the Internet, you need
# real official assigned numbers. Do not try to invent your own network
# numbers but instead get one from your network provider (if any) or
# from your regional registry (ARIN, APNIC, LACNIC, RIPE NCC, or AfriNIC.)

Gnome gives me an error about the /etc/host whenever it starts that says: "Could not look up internet address for . This will prevent GNOME from operating correctly. It may be possible to correct the problem by adding to the file /etc/hosts"

Last edited by yfn; 05-31-2004 at 03:14 PM.
 
Old 05-31-2004, 03:43 PM   #4
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
Are the hostname and domain names in the file correct?

You need to have the machines actual hostname in there if it's not localhost, and if the domainname is set on the machine put that in there as well.


Here's an example..

[david@slacker david]$ hostname -s
slacker

[david@slacker david]$ hostname -d
dcphillips.net

[david@slacker david]$ hostname -f
slacker.dcphillips.net




[david@slacker david]$ cat /etc/hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost.localdomain localhost
192.168.1.2 slacker.dcphillips.net slacker



Last edited by DavidPhillips; 05-31-2004 at 03:47 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
A strange delay when start-up LinxNew Linux - Laptop and Netbook 1 04-29-2005 10:44 AM
Too much delay in ftp/ssh to start anmsg Linux - Networking 8 10-15-2004 07:20 PM
Application delay when ppp is up nannilongari Linux - Networking 1 10-12-2004 06:58 AM
unexpected application delay maxgsp Linux - Software 1 06-08-2004 08:36 PM
Can I gett KPPP to start when I start a browser on a network machine? duffboygrim Linux - Networking 0 03-25-2004 05:49 PM

LinuxQuestions.org > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 09:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration