Download your favorite Linux distribution at LQ ISO.
Go Back > Linux Answers > Networking
User Name


By devinmcelheran at 2009-01-28 01:28
Okay, so this is a lot easier than some make it out to be, absolutely no command line, I can almost guarantee it. The issue, as probably know, is that Ubuntu does not have the license to distribute the proprietary firmware for you Broadcom wireless chipsets. One way to get the firmware is to get something called b43-fwcutter and extract the firmware out of the driver provided by Broadcom. That means you need to do a few things on the command line-which I'm not even good at. Yes, I'm not a linux pro, I'm a newb. Instead of the command line stuff, which is fine if you want to do that, there are files for the firmware as *.deb files, which will install them automatically for you when you double-click them. Administrative power is necessary. There are no dependencies either. The firmware goes to /lib/firmware. As for the drivers, it should already be installed on your system, you just have to enable it by going to "System" -> "Administration" -> "Hardware Drivers". Enable the one that has Broadcom wireless in the name.

First thing you should do is find out your card model. This can be done by running "sudo lspci" in the terminal. This is my example of output for my wireless card:

02:03.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
                                                 |     |
                                       This is what your looking for
If you can't find it, just keep looking, lspci lists all your hardware, so if there's no wireless card in there, chances are, you don't have a wireless card.

Once you've determined your card model, you should know whether you need the bcm43xx firmware, or the b43 firmware. bcm43xx firmware is for the older models, and b43 for the newer. If you are not sure just install both packages, it won't do any harm to your pc, and it won't interfere.

For bcm43xx, get this

For B43, get this

Now, double check, and make sure you have enabled your proprietary driver, and restart your pc. Now, you should have working wireless. I had been trying to get wireless working for the longest time, countless trials, and I got it to work with this, after playing with confusing commands that I had no clue what they were doing, I just did them because that's what the tutorials said to do. But this was easier and faster than any other tutorial I've seen, I hope it helps, and I hope you don't go through what I had to.

by Red_one on Sat, 2012-02-18 00:37
I used this fix on Mint 12 and it worked great, I have spent hours with command line as I am a newb, not so successful in Terminal yet. I guess I am GUI all the way as I come from using mostly Windows. I have used ubuntu mostly, but wanted to give mint a try as well.

Thanks again

by muslyt on Wed, 2012-08-08 10:06
This is a great article. I just used it on a Comice install PearLinux Os4
Worked GREAT! Thanks very much. Like others I have tryed looking all over the NET and nothing worked, till I found this.

by Microman on Thu, 2012-12-27 13:29
Thank you for posting this information. I am new to Linux, but the method you give is so simple, even I coud do it :-). I downloaded the "deb" file on to a flash drive, then inserted the flash drive into my laptop running Ubuntu, double clicked on the file and installed it. After restarting my laptop my wireless network is now working :-)


All times are GMT -5. The time now is 01:47 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration