Download your favorite Linux distribution at LQ ISO.
Go Back > Linux Answers > Applications / GUI / Multimedia
User Name


By mcnalu at 2009-10-01 10:37
When I switched from Slackware 12.1 to 13.0 for everyday use, the only real pain was that my dualhead monitor setup no longer worked. I really need this for work and back when I installed slack 12.1 I got a good solution with xrandr for spanning across internal+external 19" monitors as described clearly here.

intel pre-i965 (mine is 945gme) won't do dri if the Virtual in xorg.conf is set greater than 2048, but my width is 1440+900>2048. In slack 12.1 I just turned dri off with an option in xorg.conf and the problem was solved - don't play games at work :)

But, in slack 13.0 the new xorg seems to ignore all requests to turn off dri and so I couldn't get past the >2048 issue with xrandr. When I finally did manage to clobber dri (Disable "glx" did it I think), I had terrible graphics performance and still got the >2048 error from xrandr! Seems a partial explanation can be found here.

Trying to use Xinerama in the xorg.conf (which was my solution back in slack 11 days) resulted in a complete crash on starting X - not an EE in the log, a full on crash.

Early on I'd come across this page and the second solution it described didn't make sense to me, so I had ignored it. But, since nothing else worked, I copied and pasted it into my xorg.conf and bingo! I now have dualhead with a width of 1440+900 and I also have dri, which I thought wasn't possible on this intel chipset with width>2048!


All times are GMT -5. The time now is 04:21 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration