Help answer threads with 0 replies.
Go Back > Linux Answers > Networking
User Name


By apinta10 at 2006-06-26 11:33
Hello I wanted to submit a simple how to for installing 2 wirless cards.

1. PCMCIA RT2500 card - used a source for it and compiled it as a module.

First I used all with my default kernel on Ubuntu 6.06 LTS. Works great. No dubts!

Unpack source RT61_Linux_STA_Drv1.0.4.0.tar.gz

As root! Any folder.

However there are 2 Files for Rt61 - source code and firmware. I dint copy firmware. So it worked without. You can try both.

there is a *Configure file. Tryed to execute it it didnt work as it should.

$: make

So we made a module! (Kernel HEADERS, sources are NEEDED)!

Modpost was made.

modprobe rt61

insert the card.


check for ra0:

or type: dmesg | grep ra0

it will come.

$: iwconfig

it should list the card without connecting to any SSID.

so type:

$: iwconfig ra0 essid -network name-

$: iwconfig

to check it.

$: ifconfig - it won't be listed > ra0

$: ifconfig ra0 up - activate ra0 (leds will blink - youll be connected to AP, OPEN AP, NO KEY and Encription, I used MAC address filtering for my Wireless, So I dont use encryption)

$: ifconfig - check for ra0 again (there wont be ip address i think... i didnt get it at first)...

$: dhclient ra0 - to activate DHCP client to get an IP from the router... (router needs to have DHCP server activated)....

$: ifconfig - to check again...

$: ping - you should get reply...

2. Siemens USB Adapter 108

I lost two weeks settings this up. First i had slackware 10.1 coudn't make it work. So I installed ubuntu.

Ubuntu has intergrated Ndiswrapper 1.8 inside its kernel. And it is enough to push this card to make its job.


copy WindowsXP drivers to one folder in linux.

/home/s108 - example

since ndiswrapper does work in Ubuntu we need to install 2 files.

athfmwdl.inf i think its called and


ndiswrapper -i athfmwdl.inf
ndiswrapper -i net5523.inf

ndiswrapper -l (you should get, driver installed, present) - plug in after you installed

modprobe ndiswrapper - type this ALWAYS after you installed something (you'll get errors if you do earlier)


look for ndiswrapper and wlan0 - if wlan0 is not listed type again dmesg (loads few seconds later)


iwconfig wlan0 essid -network-


This card should start atomatically and get ip address and all after you plugged it in!

by bolognese on Mon, 2006-11-06 02:29
I have tried a whole weekend getting this card set up in Fedora 5, also having to get me a 16k stack kernel. Are there people using Ubuntu using this card? What I would like to mention: I only have a Win driverdisc containg the net5523.inf. Do I need the other one too?

by markcgriffiths on Tue, 2007-08-07 05:46
I got my USB Gigaset 108 working after just a few hours. I too, only had that one file ( net5523.inf), the other I found from Google. I am using Ubuntu and I can say that the device works as it should.

Only problem I had was that Ubuntu doesn't download ndiswrapper correctly, I had to do that by hand. First though delete the old one from the system. Instructions are on their web site.

by rickh on Tue, 2007-08-07 07:42
Your title says rt2500, but the discussion revolves around an rt61. Those are two separate chipsets both of which have native Linux drivers. No ndiswrapper required, although I suppose Ubuntu users would not be expected to realize that.

The RT2500 is probably the easiest and best card to set up on Linux with native drivers.

by markcgriffiths on Wed, 2007-08-08 13:47

Are you saying that Ubuntu should support my device out of the box? How can I get it to work without using ndiswrapper?

by Uden on Fri, 2007-09-14 05:45
Hi all,
i followed the instructions mentioned in the first link but the Siemens Gigaset 108 USB Adapter does not initialise. See output below.

The only difference is that i used the *.inf files that were provided with my adapter. Is "net5523.inf" a later version? Any other suggestions?

Thanks all for any help!

Result dmesg:
[ 569.529597] ndiswrapper version 1.43 loaded (smp=yes)
[ 569.733976] usb 1-2: reset full speed USB device using uhci_hcd and address 4
[ 569.966309] ndiswrapper: driver netwg11t (NETGEAR,01/07/2005, loaded
[ 580.016067] ndiswrapper (NdisWriteErrorLogEntry:199): log: C0001389, count: 4, return_address: d8cf3c6b
[ 580.016095] ndiswrapper (NdisWriteErrorLogEntry:202): code: 0xd11da7c4
[ 580.016107] ndiswrapper (NdisWriteErrorLogEntry:202): code: 0x28
[ 580.016119] ndiswrapper (NdisWriteErrorLogEntry:202): code: 0xd8c49000
[ 580.016131] ndiswrapper (NdisWriteErrorLogEntry:202): code: 0xd8c49000
[ 580.017090] ndiswrapper (miniport_init:271): couldn't initialize device: C0000001
[ 580.017114] ndiswrapper (pnp_start_device:425): Windows driver couldn't initialize the device (C0000001)
[ 580.019745] unregister_netdevice: device eth%d/d11da000 never was registered
[ 580.019776] ndiswrapper (miniport_halt:335): device d11da400 is not initialized - not halting
[ 580.019802] ndiswrapper: device eth%d removed
[ 580.019850] ndiswrapper: probe of 1-2:1.0 failed with error -22
[ 580.019888] usbcore: registered new interface driver ndiswrapper

by markcgriffiths on Sun, 2007-09-16 01:05
Try using version 1.47 of Ndiswrapper, if I remember right, mine didn't work either with 1.43.


All times are GMT -5. The time now is 12:34 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration