Review your favorite Linux distribution.
Go Back > Linux Answers > Networking
User Name


By munstah at 2005-10-10 05:58
===Tech specs===
* Compaq Evo N400c, PIII850M, 256MB
* Suse 10.0 - 2.6.13-8-default
* KDE 3.4.2 level 'b', standard Workstation installation
* Netgear WG511 v1 PC card (Important: for version description see!!!)
* wireless router completely set up and tested under Windows with WPA, acting as DHCP server (NAT).

===What I wanted===
Wireless networking with WPA-PSK security under Linux

===What I needed===
* ndiswrapper and wpa_supplicant packets
** either select packages during SuSE installation or
** install afterwards via K-menu -> System -> YAST -> Software -> Software Management
*** filter by "Selections"
**** wpa_supplicant can be found under "Laptop"
**** ndiswrapper can be found under "Mobile Computing"
* a hard-wired and working Internet connection
* the WG511 card plugged into the computer
* firmware for WG511
* netwg511.inf from Windows installation

===Configuration sequence===
1) disable KInternet
2) install firmware
3) install driver
4) configure network card
5) restart

Make sure both network cable and wireless card are plugged in before starting!
NOTE 1: I will use "eth1" as device ID for the wireless card as set by SuSE. If in doubt, check your Network Devices in YAST first before starting the setup procedure!
NOTE 2: Linux is CASE-SENSITIVE!!! A capital "G" is a "G" and not a "g"!
NOTE 3: the lights on the WG511 may come on, blink, turn off or become stable during configuration. I recommend resisting the urge to try connecting to the internet until the final restart...

====disable KInternet====
KInternet starts with KDE by default but it does not support WPA and can cause quite a lot of confusion. Right-click the tray-icon and select "Quit". Choose "Do not start at next start-up" to avoid future problems.

====installing firmware====
Open console and switch to super user mode (type "su", press enter and the type the root password)
Tip: if you do not like typing, highlight the commands between quotes, right-click and select "copy". Inside the console right-click the blinking cursor and select "paste" (imagine Linux purists crying in agony :))
In the console:
* type "mkdir -p /usr/lib/hotplug/firmware" and press Enter to create a directory for the firmware
* type "cd /usr/lib/hotplug/firmware" and press Enter to switch into this directory
* type "wget" and press enter
- This downloads the firmware file directly into the newly crated directory. It may take several minutes depending on your network speed. The original file name is and should also be found in a complete Windows installation....
* "ifconfig eth1" will show if the firmware is installed correctly

====installing driver====
Here we will point ndiswrapper to the driver file. Make a note of the exact path_to_the_netwg511.inf_file (Example: /windows/C/Program Files/NETGEAR/WG511/Driver/netwg511.inf)
* type "ndiswrapper -i path_to_the_netwg511.inf_file"
* type "ndiswrapper -l" to get this output:
- Installed ndis drivers:
- netwg511 driver present, hardware present
* type "ndiswrapper -e eth1 netwg511" to bind the driver to the device
* type "ndiswrapper -m"
* type "ndiswrapper -hotplug"
* type "exit", hit Enter, type "exit" and hit Enter again to close the console

====Configure Network Card and WPA====
SuSE detected the WG511 and applied the prism54 driver by default, but this driver does not yet fully support WPA-PSK.

Go to K-Menu -> System -> Control Center (YAST) -> Network devices -> Network cards -> Netgear WG511 wireless card -> Edit
* on main screen:
** provide static IP address (WHY? see summary)
** OK
* click "Host Name and Name Server
** supply host- and domain names
** leave Name server and Search set to be changed by DHCP server
** OK
* click "Routing"
** enter the IP address of router/ gateway
** OK
* click "Advanced - Hardware details"
** in the field 'Module Name' replace the string "prism54" with the word "ndiswrapper"
** OK
* click "Next"
** field 'Operating Mode': managed
** field 'Network Name (ESSID)': your network name
** field 'Authentication Mode': WPA-PSK
** field 'Key Input Type - Passphrase': enter the passphrase
** click "Next"
* click "Next" on the summary screen

====restarting computer====
* close all open windows and SHUT DOWN the system
* disconnect the network cable
* unplug the WG511 and plug it back in
* restart the machine, use the "ESC" key to suppress the SuSe splash screen, watch out for eth devices being loaded...
* the green light should come on and become stable after a few seconds...
* after login open a console and type "ifstatus wlan0" to check the status of the device
NOTE: ndiswrapper uses "wlan0" instead of "eth1"

When using DHCP the wireless connection using seemed to randomly block off access to the Internet while local browsing still was working fine. I switched to a static IP address instead and the issue disappeared completely, Internet access is stable and running perfectly fine since then.

Good luck!

by djortz on Sun, 2005-11-13 16:40
I've had some trouble configuring Suse 10.0 with wpa-psk. When using wpa-psk my laptop hung, except the touchpad. After some debugging I found out that wep and no-security did work. It turned out that any special characters made the system crash. My wpa-psk key was wwwwdddd#ww$wwwww (w=[a-z], d=[0-9]). Without the # and $ wpa-psk works like a charm, with the software provided by Yast.

(I was using my built in wlan device (Inspiron 6000, ipw2200))

by frieweka on Wed, 2005-12-14 03:37
Hi, I am a Linux newbie. I have often tried to install Linux (different distributions) on my Laptop, but I always failed with WLAN (only with a LIVE CD of Knoppix I've got a connection to my Router and to the Internet).
Since two weeks I try to configure my new Suse 10 that WLAN will work, but all I got (after an online update via the build in Ethernetcard) was an active WLAN (green LED on my Netgear WG511 is permanently on). I tried different configurations via YAST2 and KWIFI to get a connection to the DSL-Router and through it to the Internet. The best solution I obtained was the information of the router that a connection with 54Mps is active (the MAC adress of the WLAN card was also addressed)but there was no IP address assigned by the router (works as a DHCP server).
I was very happy about the detailed description I found for the installation of the WG511 with WPA on SuSE 10.0 in this forum and tried to follow it.
All worked well until I checked if ndiswrapper has installed the netwg511.inf file correct. Here a got the message: "netwg511 invalid driver".
I am confused and don't know how to proceed. I want to change from Microsoft to Linux, but I need a wireless connection to the Internet and as long as this doesn't work I can not change. Please help me. Thanks

by r_f_k_c on Tue, 2005-12-20 04:05
Originally Posted by frieweka
All worked well until I checked if ndiswrapper has installed the netwg511.inf file correct. Here a got the message: "netwg511 invalid driver".
I am confused and don't know how to proceed. I want to change from Microsoft to Linux, but I need a wireless connection to the Internet and as long as this doesn't work I can not change. Please help me. Thanks
You should probably check to see what version your card is and where it was made. From what I've read, the "Made in Taiwan" cards are easier to get working, but I got my "Made in China" version 3 card working. Try searching this site or googling for details on your specific card. Also, when installing the .inf file, make sure that the .sys file is in the same directory. That led to a lot of head scratching on my part until I figured that out. Good luck.

by JimN on Fri, 2006-06-09 10:35
The link in the original WG511 post to the firmware at no longer works. I went to the web site and they do have the file on the "FullMAC Driver page". I got the card working following the instructions (my thanks to munstah for those) but had problems with WPA. The Network Card section of Yast wasn't happy with my key selections. I finally found the NetworkManager tab in the system tray and it had a line for a WPA personal encryption key. I put in the key there and the system connected I've been trying different Linux distros to get this card working and never got any further than making the lights blink before now. Thanks for sharing the wisdom.

by shikarishambu on Sun, 2006-06-11 09:46
Originally Posted by munstah
This thread is to discuss the article titled: Netgear WG511 with WPA on SuSE 10.0[/url]
I followed the steps outlined in this post above. When I do an ifstatus wlan0 I see that the WPA_STATE=SCANNING and it remains there for ever.

I am not sure what the issue is and how to proceed further.

Any help is appreciated.


by shikarishambu on Sun, 2006-06-11 11:18
I had to run iwconfig to set the essid.



All times are GMT -5. The time now is 09:29 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration