Download your favorite Linux distribution at LQ ISO.
Go Back > Linux Answers > Networking
User Name


By secretservgy at 2006-07-11 17:41

This is a how to on how to get the stubborn infamous Broadcom 43xx wireless cards working:

First download the drivers from my website:

1) Blacklist bcm43xx driver
Open a Terminal window
Type "sudo gedit /etc/modprobe.d/blacklist"
At the bottom add the lines
# get rid of the default kernel drivers
blacklist bcm43xx

2) Make sure network interfaces file is correct
Type "sudo gedit /etc/network/interfaces"
Remove all comments ('#') that you see so that all devices arehandled by the default network manager.
I would reboot here and make sure the wireless light goes out

3) Install ndiswrapper
Put in Ubuntu CD. Open Synaptic Package Manager (ClickSystem -> Administration -> Synaptic Package Manager),search for ndiswrapper-utils, and install it.You could also type "sudo apt-get install ndiswrapper-utils (IF you are not using ubuntu then make sure you have ndiswrapper-utils somhow installed)

4) Conigure ndiswrapper
Open terminal and navigate the folder where your drivers are."cd Desktop/bcm43xx"
Type "sudo ndiswrapper -i oem3.inf"Then type "sudo ndiswrapper -m"
Type "sudo gedit /etc/modprobe.d/ndiswrapper"Change the one line in that file to read "alias eth1 ndiswrapper"

Now you should reboot so all the drivers load.

Once you reboot the wireless light on your laptop should be lit. If it worked, you should be able to click the Network Manager icon in the top right. It will probably show a disconnected ennection becuase the computer is not plugged in.
Left click it and select eth1 from the drop down menu.
Click Configure
Click Wireless Connection, then Properties. Here just enter your network information. If you're using an unprotected network you should only have to type yout SSID.

Click OK and you should now be connected! If a green signal meter and connected network icon appear in the upper right you'll know it worked.

by Doggyshark on Tue, 2006-09-05 15:42
Firstly thank you very much for your HowTo, I had spent many frustrating days trying to get the wireless connection on my Compaq presario working. I tried so many other guides and how-to's but it was yours that finally did it. I followed your instructions pretty much to the letter, modifying slightly to suit SUSE 10.1 and it all worked. I had to manually create the ifcfg-wlan0 file in /etc/sysconfig/network/ but apart from that practically everything else was as per your guide.
Thanks again,

by cymbaline on Sat, 2006-10-07 23:27
I use Mepis 6.0 and I couldn't get my Broadcom 4318 wireless card to work. I knew it should work with Mepis because I had used it with 3.4.3 and ndiswrapper had done a fine job. I guess something changed with 6.0, but after reading this how-to, it turned out to be very easy to fix. Thank you so much!

by klrtmto on Tue, 2006-11-07 01:54
First off, a big, FAT THANK YOU to secretservgy. This how-to was 100% accurate and fixed it in a flash. For reference, I am running a 2 day old compaq presario v5305wm ($400 wal mart special) laptop with a broadcom 4318 wireless card in the mini-pci slot. I'm dual-booting winxp media center & MEPIS 6.0. I appreciate the time you took to help us all.


by rupak.bag on Sat, 2007-02-10 22:51

Thanks so much for the wireless setup instructions. I still have one problem here. I am able to connect using my wireless only if I don;t have any key for my router i.e. make my router unsecured. If I make my router secured and put the WEP key in /etc/sysconfig/network-scripts/keys-eth1, I am not able to connect. It says "Determining IP information for eth1... failed; no link present. Check cable?".

My System configuration:
Compaq Presario X6000
Wireless: Broadcom BCM4306
Fedora Core 6
Netgear Router

Kindly advice what could be the problem?


by jmfurtado on Mon, 2009-04-27 18:10
After almost 2 weeks of deceiving attempts I could now, thanks to these precious technical notes from this Forum, finally manage to get my Linux Ubuntu 8.10 to react to and operate with my home wireless network.
I was about to quit using this operating system if I hadn't come across this help and would find myself back to the nuisance of the "infamous" system I was used to...



by w5gcx on Mon, 2010-05-31 11:47
Will this work with Ubuntu 10 ?


All times are GMT -5. The time now is 03:27 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration