Visit Jeremy's Blog.
Go Back > Linux Answers > Networking
User Name


By heffo_j at 2005-12-10 16:09
Does your wireless card have an Atheros chipset? The box that my D-Link DWL-G650 and manual told me it had an Atheros chip running the card. If you have an Atheros chip, the Madwifi driver can get your card working for you.

Here is the simple way I got my Atheros chipped card to work in FC4:

1) check the current kernel details in terminal by running "uname -a". Write down what is shown.

2) Go to ATrpm ( in Firefox 1.07 (or later) and download by clicking on the link (I'm not running a 64bit processor). When this is run in the Firefox download manager you get the option to "open with" and in the drop down box "install packages (default)". Hit OK. This will install this rpm. Do this before you proceed to the next step.

3) Now search the ATrpm Fedora driver list ( and make sure you get the correct rpm to match your kernel details you wrote down in Step 1) above. In my case "uname -a" told me that my kernal is 2.6.14-1.1644_FC4. I do not have a 64bit processor running so I selected this rpm: Make sure you click on the "madwifi-kmdl-" rpm that matches both your your processor and kernel.

4) Click on the correct rpm as described in 3) above and Firefox will offer to install it. Click OK.

5) Reboot your computer.

6) Go to Desktop in your FC4 top panel. Select "System settings" then "Network". Type in your root password when asked and you will be taken to graphic menu that will list your network cards. In my case my laptop has an ethernet card and the wireless card. Until I installed Madwifi as described above the wireless card was not listed.

7) The wireless card is now listed under "Devices", in my case under the ethernet card. Check the box to the left, next to the listed wireless card and press the "Activate" button. I you would like to have the card load up each time you start click on the "Edit" button and then check the box that says "Activate device when computer starts".

8) When you go to leave the network menu you will be asked to save the new settings. Press OK. You're almost there.

9) Your card will still not be working. Restart your computer.

10) Bingo! It works.

by vengeance on Tue, 2006-02-07 13:23
Hi after reading this article I decided to try and get my netgear usb adapter wg111t to work on linux after typing in "uname -a" it came up with 2.6.11-1.1369_FC4

When I went to ( I couldnt find my version on the website could someone please give me some advise on how to sort out this problem.

by sarahslagstedt on Wed, 2006-02-08 06:52

I have tried all steps but get stuck when I try to install I am told that "madwifi-kmdl- is necessery but missing. When i download that one and try to install i'm told I need vmlinuz and then I'm stuck for good.
Isd there an easier way to9 do this.

Alternativly, are there other cards I can buy and use?


by sloik2000 on Wed, 2006-11-29 07:49
Originally Posted by sarahslagstedt
When i download that one and try to install i'm told I need vmlinuz and then I'm stuck for good.
Isd there an easier way to9 do this.
Add ATrpm's repository to yum and download them that way. It automatically gets all of the dependancies. They should give you the info you need at

by SGlassman on Wed, 2007-06-06 09:08
I added the ATrmps key and Repo but it downloaded madwifi for an earlier kernel release. I had tried this once before with the correct infomation and rpms but it still wouldn't 1. Show the wireless NIC nor 2. Activate it. Is there something additional that needs to be done outside of the basics described in the original post? I'm on FC6.



All times are GMT -5. The time now is 04:03 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration