Download your favorite Linux distribution at LQ ISO.
Go Back > Linux Answers > Networking
User Name


By jlawren7 at 2005-01-03 11:26
Know what internal wireless you have you can have the 2100 or the 220bg wireless
First step.. go to the terminal and type the following
rpm -q kernel
hopefully you have a fully updated system and receive
if not, update everything including the kernel
next go to
select your distribution (only Red Hat or fedora so far )
you need to download 3 rpms to get your wireless to work!!!
*********************** NOTICE ************************
MAKE SURE YOU GRAB the CORRECT VERSION # for each of these rpms if you get the 0.19-19 driver then you need the kernel module to have the 0.19-19 version/
ALSO if you have a 64 bit architecture don't worry they have a 64 bit versions well...
in my case i have the 2200bg internal wireless
grab the latest rpms available.

you'll next need to go to here to get the firmware
i grabbed the latest version of the firmware...

next open the terminal again and type this in ....

rpm -ivh

Next Step....
go to your routers admin page
( for testing purposes name SSID: TESTING )
set up your wireless to enable wireless AND
A-- broadcast your SSID
B-- don't broadcast your SSID but remember the name
either way your just testing here so it don't really matter
if you use DHCP then all is good then Save your Changes


if your going to assign Static IP's then write down you settings for your router
You'll need ...
IP address (the one you'll assign your wireless device)
Subnet mask (the
Default Gateway (your routers internal IP address )

Save your Changes

Next Step.....
go into your Applications ---> System Settings ---> Network
click your eth0 device(wired connection) and choose the Edit button
Under the General tab uncheck the
" Activate Device when computer starts"
Click OK and click the File then Save
you'll be prompted to reboot the system because you made changes to the configuration .

Next Step......
after all router adjustments and software installed
log out and reboot you machine.

Next Step....
when you restart, you should be stopped during boot up by kudzu about your card.

if you chose DHCP in your router just put a mark in the
"Assign IP Address Automatically" box then Click OK

if you chose to assign Static IP then Enter the settings you wrote down earlier into the fields and click OK

Next Step......
Depending on what you installed during your installation of fedora
E.g Gnome, KDE etc..
if you installed both then go to Applications ----> Internet ---> Kwifimanager upon the applications launch it should find your network and show the signal strength and all is good and the wireless works. if you installed KDE only then you can also follow the same steps as for Gnome and KDE.

I personally followed the steps above using DHCP and not trying the static IP addressing as of this writing. after all your just trying to get your wireless to work for now. Any questions or comments please join the fedora-users mailing list you can sign up at

If i made any goofs in my above writing please let me know and I'll revise as needed.
Hopefully you get everything to work and your going to need my next post which will be on how to secure your wireless and get it to function properly... check back soon

by terrence on Sat, 2005-08-13 18:27
this is what i recieved from my terminal:
warning: Header V3 DSA signature: NOKEY, key ID 66534c2b
Preparing... ########################################### [100%]
package is intended for a x86_64 architecture

from inputing this:
[root@localhost Desktop]# rpm -ivh

i am so confused now, where does this leads me, am I almost there?
i have the same 2200BG Intel Pro Wireless, i did not find the specifics ipw you had,
what is the routher admin page that you refer to? (i am just trying to connect wireless at my school's library)
and what is kudzu? ( i am a new user to linux using gnome)

please let me know, thanks for your time.

by thomasfingram on Sat, 2005-08-27 11:50
Ok I have a fresh install of Fedora Core 4, and I am a complete and total newbie (both myself and my friend whom I am helping). We are trying to get his Intel 2200bg wireless adapter to work. The only way to get files to this computer is to copy them to a cd from another computer. How can we adapt the instructions to get this to work?

We tried:
# modprobe ipw2200
# dmesg | grep ipw
which returns the following:
ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Drive, 1.0.0
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: ipw-2.2-boot.fw load failed: Reason -2
ipw2200: Unable to load firmware:0xFFFFFFFE
ipw2200: failed to register network device
ipw2200: probe of 0000:02:09.0 failed with error -5
What are we doing wrong, and how can we fix this? Please help us! We are sinking fast!

by qwameske on Mon, 2005-10-17 23:37
The laptop contains a Intel PRO/Wireless 2200BG 802.11b/g mini-pci adaptor card. It's supported by the ipw2200 driver, which Fedora includes. The driver needs to download some firmware to the card during initialization. Unfortunately, Fedora does not include that firmware. You need to download them from, and unpack the tar file into /lib/firmware.

Watch out! There are multiple versions of the firmware, and you need the right version for the driver in your kernel. Fedora core 4 ships with version 1.0.0 of the driver, which needs the 2.2 version of the firmware. The 2.3 or newer firmware will NOT work.

Once you have the firmware installed in /lib/firmware, unload and reload the ipw2200 module. using the commands;

/sbin/rmmod ipw2200
/sbin/modprobe ipw2200

The iwconfig command should list the adapter as eth1, and it's status.

You may need to create a file /etc/sysconfig/network-scripts/ifcfg-eth1, containing:


Once that file exists, /sbin/ifup eth1, should bring up wireless networking.

Now this worked perfectly for me. I believe it will work for you if you follow the instructions. I got this information from and it was created by Doke Scott, 2005.8.12

by Malachai.77 on Fri, 2006-03-17 19:44

I just found the thread finally on how to install... I need some major help on setting up my wireless drivers or something...

I'm a newbie so I'm sorry if I don't explain myself that well.

My Spec's below for my laptop...

Dell XPS M140 (Laptop)
Intel® Pentium® M Processor 750 (1.86GHz/2MB Cache/533MHz FSB)
Genuine Windows® XP Media Center Edition 2005
1GB Shared DDR2 SDRAM 2 Dimms
100GB 5400rpm Hard Drive
Integrated Intel® Graphics Media Accelerator 900
Intel Corporation Pro/Wireless 2200BG (rev 05)

I read that I need to download a couple of things. So far here's what I have... noarch.rpm

My kernel is 2.6.15-1.1833_FC4

Every time I run all the rpms using the command

rpm -ivh *.rpm I get this error message.

error: Failed dependencies:
ieee80211-kdl-2.6.15-1.1833_FC4 >=1.1.6 is needed by i686

Can someone please tell me what I'm doing wrong... All I need from what I'm looking at is one more rpm ... I can't find a rpm for ieee802111 ...

Help please... Been fixing with this problem for 1 week now.




All times are GMT -5. The time now is 03:33 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration