Download your favorite Linux distribution at LQ ISO.
Go Back > Linux Answers >
User Name


By XavierP at 2004-09-14 12:36
To post a question, first click on the appropriate forum and then click the "New Thread" button.

Your Thread Title
This seems silly but it is actually pretty important. Many people will just skip over a thread if the title isn't informative.

Bad Title: Help Me, Please!!!!!! - putting 5 exclamation marks after your title doesn't make it any more compelling. It tells us nothing about the topic and decreases the likelihood of a member reading your thread.

Good Title: Installed GAIM, Won't Connect to MSN

Your Question
Before posting, it is always a good idea to know exactly what your questions is. That sounds strange, I know, but too often we see short, one line questions which need lots of further questioning until we can see the problem. In fact, the best thing to do is to run a Search first - chances are, your question has been asked and answered over and over again already. Another great resource is the LQ Wiki - there are a large number of articles, many dealing with diagnostics.

As an example:
Bad Question: Help me, <program> just stopped working, what do I do????

That does not give us any of the information needed to help you. We need to know: your distribution (really this should be set in your User Profile so you only need to type it in once), the version of the program (if it's, for example, GAIM, the answer may simply be to upgrade to the latest version), how you were trying to run it, what happens if you run it from the console, what error messages you get, what searches you have run already (this is important, there's nothing worse than spending ages on a search for someone only to be told "I tried that")

Even worse, is to say that you are too busy to search. Why should your time be more valuable than anybody else's? We are not your personal technical support team, nor are we your personal research assistant, the spirit of Linux (one of the many spirits :)) is of helping yourself.

So a good question would be:
I have been trying to get GAIM running and it will not connect to MSN. I am running version x.xx in Fedora Core 2. When I open it, there is no problem, but when I try to connect to MSN, it returns "error message". All other applications seem to connect with no problems.
I have tried a search on Google, but I really don't know what I need to search for. Can anyone help me to solve this? Please bear in mind that I am new to this and so would appreciate being told in plain English what I need to do or where I need to start

What was written above applies to all questions - we need information. Tell us your hardware, what happened before you tried it, what changes have you made. Tell us everything - you save a lot of frustration down the line.

Be Polite
It may be that after 10 posts, you still haven't found an answer. Instead of posting this, it would be a good idea to read back over the posts and see if you can work out why it is that no one can answer you. Does your question need restating? Is there a piece of information which, at the start, seemed not to need stating but now does? Have you tried any additional troubleshooting since posting?

What If No One Answers You?
Firstly, if after sitting for an hour hitting refresh on your browser no one answers, do not despair. LQ's membership is drawn up from a wide variety of people - from all around the world. 2pm your time is the middle of the night for someone else - and that person may have the answer.

My (and everyone's) advice is to wait for 24 hours - give us all a chance to see your post. If no one answers after at least 24 hours, reply to your own post giving us some more information: of course, you didn't sit there waiting, did you? No, you searched and tried some things - tell us what you tried, it may mean that a member seeing your post will know what you need to do.

What To Do When Your Question is Answered
Tell us. Tell us what worked for you. Someone coming along after you with an identical problem needs to know if the fixes work. And, just as importantly, the people who have spent their free time helping you would like to know that you have now solved the problem. Please don't just vanish or walk away without saying Thanks.

Even better, find a place in the LQ Wiki to describe what was done to get it working properly first time. Not only will you help others, but your solution will be saved for posterity.

And Remember - every member of LQ (and that includes Jeremy and the Moderators) is doing this on their own time and for no remuneration. No one is guaranteed an answer and no one can always expect one.

For a more detailed essay on asking questions, please read How to Ask Questions the Smart Way by Eric S Raymond and Rick Moen. And don't forget, two very invaluable resources are Google and the LQ Wiki - much of the help you need can be found there.

by ToniT on Sat, 2004-09-18 09:02
ups. wrong window..

by vectordrake on Sat, 2004-09-18 11:26
My answer'll be short. Good article. Valid. A great thing to do would be to redirect there from the registration page (and have a checkbox to click confirming you've read it - and then a popup asking again...). That'd give first-timers an idea of how to get an answer...

by XavierP on Sat, 2004-09-18 12:53
It's a good idea, but..... When you go to create a thread, there is a link to "Has this been asked before?". The idea is that you can see if the answer is already out there. How many click it? How many read the Rules before clicking "I agree"?

Basically, we can put all the info in front of people and they will still ignore it.

But thanks for the review

by vectordrake on Sat, 2004-09-18 13:35
I know its difficult to get people to actually think on their own sometimes. Perhaps there's another way, as I think this is a good, succinct article. Perhaps a permanently visible sticky in most forums...

and, arrr! Me be talkin' like pirate on the morrow, laddies!

by XavierP on Sat, 2004-09-18 14:03
Well, we have been discussing wiring people's keyboards to the mains. Obviously, we'd only use this power for good - or when we felt like it

Seriously though, probably the only good way to get questions asked correctly is by education. LAs like this one and reinforcement through the boards - if we all aim to ask only "good questions", eventually that will become the norm and then new people will follow suit.

And, arrrr, Oi'll be talking like a pirate meself, me laddie-boy

by JZL240I-U on Tue, 2004-09-21 08:46
It may be that after 10 posts, you still haven't found an answer. Instead of posting this, it would be a good idea to read back over the posts and see if you can work out why it is that no one can answer you. ...

I found it repeatedly frustrating, that perfectly sound advice (not mine ) wasn't acted upon (or the results / failures not reported back). That is particularly annoying if the earlier suggestions are steps in a whole procedure to be tried out for finding a solution and only 15 posts later the original poster grudgingly deigns to test a suggestion already three days old and a lot of effort of other people wasted.

So in my opinion it can't be stressed enough that all suggestions for a remedy deserve a prompt reaction by the owner of the thread, like "I tested xyz and now the error is..." or "It worked okay, thanks".

by XavierP on Tue, 2004-09-21 12:09
Absolutely agree with you (even I'm doing it ) It's all about being polite, really. If someone has taken the time to offer help, the very least you can do is post back with the result. It's all about us being a community and we are only strong if we act that way.

by Konch on Thu, 2004-10-28 02:09
I sent the following question. I can' t see the question and the answer. Where has it gone?


Now I can't open the Linux. It opens the root. It asked me to write
the login name and password and accepts what I write.

So I can log in to the root and do everything. I can't open the real
Linux. It worked before. After a crash, I got this problem.

All the root commands work fine. For example, ls , cd.. , du , df etc.

I wrote just linux at the root. No, it didn't work. Could you help me to
solve the problem?

I have Mandrake Linux 10.0 version. It worked very well for more
than six months. Today, after a crash, things have gone to hell.

by Konch on Thu, 2004-10-28 08:02
First of all I am new to Linux. I have a smattering of knowledge about things in Linux.

When I start my computer I have a choice to go either to Windows 2000 Professional version or Mandrake Linux.

When I select Mandrake Linux, I get Mandrake Linux. Then I go to Interenet, collect my email, write letters using the Open Office Program, etc.

Recently I had a small crash, after this crash I cannot get into the Linux. I just come to the root. The following is the current problem in stepwise.

1) It asked the login name -> I write the login name and press enter.
2) It asked the password -> I write the password and press enter.

3)Then I come to the the following root:

4)[alfento@digicam rchtr] $

5) The above is the root, to the best of my knowledge of Linux.

6) When I issue basic commands like ls, du ,df etc works fine. So I am in the root.

7) I gave the command 'kde' , it does not work.

8) I gave the command 'Linux' command, it didn't work.

9) When I gave the command 'vi' , it worked and I got the text editing program.

10) When I gave ' Alt + F8 ' command, I want it to give me the KDE. No it didn't work.

11) Ctrl + Alt + Del command works fine and it restarts the computer.

How I can get in to my Linux? I just come to the above mentioned (4).

It has been working for more than 6 months. After the crash yesterday, I am in trouble.

by XavierP on Thu, 2004-10-28 15:07
Konch, this thread is expressly to discuss the LinuxAnswer "How to ask a question". You should add your posts to your own thread since your questions have nothing to do with the how to.


All times are GMT -5. The time now is 02:23 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration