Download your favorite Linux distribution at LQ ISO.
Go Back > Linux Answers > Hardware
User Name


By peace at 2003-08-14 13:38
In response to weekly (almost daily) postings about getting a WinModem to work under Linux, I have decided the LQ community would benefit from a local WinModem resource. There are many other pages on the net with better, more accurate information than I am including here. However, this is more personal experience, and should work as a guide for those that post about WinModems. Also, I will do my best to include useful links throughout the guide so that I don't have to repeat information posted by others elsewhere.

I. Introduction to Winmodems
II. How do I know I have a WinModem?
III. Drivers
VI. Conclusion
VII. Links

I. Introduction to WinModems

A winmodem is a piece of hardware that is commonly found in notebooks and computers designed for a Windows OS. A winmodem is not a modem! It is much more CPU heavy, and relies on Windows to function. But if you are reading this, I assume you want to get your winmodem working under Linux. This can be done, and there are lots of different ways to do it. In this less-than-complete HOW-TO, I'll outline how I got my Lucent WinModem on my Dell Inspiron 7500 working under Red Hat. Lucent is the most common chipset, so I hope this will be useful to many of you. Of course, these steps can be followed by anyone with any winmodem or distribution (but not with guaranteed results).

II. How do I know that I have a WinModem?

I was still running Windows 98SE when I started on my quest to "cleanse" my notebook of Microsoft, and I simply went to the Control Panel and checked my modem name there. However, I understand this may not be possible for everyone. You can use the Linux command 'dmesg' and look for a line that may resemble your modem. If you do not see one there, then it is probable that you are the owner of a WinModem. Now you should become familiar with the term LinModem, because a WinModem under Linux is what we are working towards in this HOW-TO.

III. Drivers

The first step in getting a functional LinModem is getting a driver. If you are using a distribution that supports RPMs or DEBs then you can take a shortcut. However, under RH9 the RPM drivers never did work for me, so that may be a good start, but there is always a more sound backup: source drivers. Just some notes before I move onto them, when choosing a driver take note of the kernel version and chipset associated with the driver, and make sure they match your system.

Determining chipset: (look for scanModem tool)

Here is a great list of LinModem drivers:

So I headed to the above referenced link, and chose the latest Source driver ( ltmodem-8.26a9.tar.gz at the time of writing this). After downloading it on my Windows machine and transferring it via Memory Key to my Linux notebook (Red Hat 9) I pointed my IE browser to . This is a wonderful page and helped me a great deal. I would recommend following the given instructions, but here I will rundown them in "Reader's Digest" form:

(please read the README, and also make sure you have your kernel source on the harddrive)

cd /home/peace
tar -zxvf ltmodem-8.26a9.tar.gz
insmod lt_modem
insmod lt_serial

Now hopefully that went OK without trouble. If anything did go wrong, check the site and make sure you read everything carefully and followed the directions exactly. If you got an error about kernel headers, than you need to make sure you have the kernel source. This is done in Red Hat by making sure the "Kernel Development" box is checked off under Preferred Applications.


PPP is point-to-point protocol, and it is how you connect to the internet using a dial-up connection. In Red Hat, it is easy to setup; you go to System Settings then Internet Configuration Wizard.

PLEASE NOTE: Your LinModem is /dev/ttyLT0 (that is a zero)!

If you do not have Red Hat, I would recommend testing your new LinModem with minicom. Type 'minicom -s' at the terminal and set your Serial device to /dev/ttyLT0. Then, connect to your ISP and you should hear a nice little success tune when it gets through. After, use this PPP-HOWTO to
get fully connected and setup:

If you cannot for some reason get your LinModem to connect using minicom, please make sure you have the device set to /dev/ttyLT0. This is the most common mistake made by far.

VI. Conclusion

This guide is a exact recreation of how I managed to get my WinModem working under Linux. Hopefully it will help you in some way or another. If it hasn't, than please post a concern/question to the LQ forum associated with this guide, and the community will do it's best to assist you. Also, there is a much more in depth LinModem HOW-TO in the links section. This is too long to read in one sitting, but it is very useful.

VII. Links


PPP: (note chapter 7)

Related LQ Threads:


by msn_murty on Sat, 2003-09-13 15:28
Yes very intresting ...
but I need some larification reg.
Conexant SoftK56 Data,Fax,Voice,Speakerphone PCI Modem
For the above mentioned modem in my WinXP
I had downloaded drivers from site for my AMD Athlon Processor based PC with Redhat Linux 9.0
But not a singel RPM from that site is working for..
Shall I down load i686 version or athlon version from the site.
As my RedHat Version on the machine is telling me my kernal is i686 with 2.4.20-8
but physically mine is a AMD athlon 1700+XP processor
If You can guide me on this I'll be very thankful to you...
my modem scan results are
Vendor ID 127A, Device ID 1025, Vendor Name Rockwel..
Thanks in Advance

by peace on Sat, 2003-09-13 20:49

Yes for your modem would definitely be the place to get your drivers.

I am not quite sure whether you should download the i686 or Athlon driver for your machine. Personally, I would get both:

Unzip them, and then rpm -ivh foo.rpm to install 'em.

If you are absolutely stuck after trying both of those drivers, I also found this page:

I haven't tried those drivers, or read the info on them, so I am guessing they won't work.

Try the 2 Linux Ant ones specified above, and come back if you need more help (preferably with the error message).

by ferrari on Mon, 2003-09-22 00:25
Hoping someone out there is running Linux on one of these excellent new machines. I have Windows XP and RH9 (kernel 2.4.20-8) installed. No real major problems with the Linux config, exept for... you guessed it... the modem.

I've checked out, intel, compaq sites, various discussion sites etc, all to no avail.

Tried to install the pctel (0.9.6) driver, but not able to get it to work. Having problems with 'make install'. Unresolved symbols reported. Spent a large amount of time reading 'install' and 'faq' notes, but they are too vague to be of assistance.

Anyway, anyone know what modem driver might be available? Or if pctel driver can be configured correctly?

Windows XP reports as AC'97 (Agere) modem. Used 'scanmodem' to determine:

8086:24c6 PCI bus
0e11:0860 PCI-ID subsystem (Compaq)

Thanks in advance for support.

by bgoins on Sat, 2003-09-27 08:37
I have been using the Linuxant driver for my Winmodem. However, I am having a problem with KPPP "finding" my modem. I find that if I issue a "depmod --all" command as root, KPPP can find my modem. Since Linuxant has now gone "commercial" for any drivers faster than 14.4 kb, support is pushing purchasing the newest release, rather than helping fix my problem.

Is there a way to put the "depmod -all" command in a script that runs during startup? This would save me a lot of grief. Thanks.

by mustafasattar on Mon, 2004-03-08 14:40
hello to every one.
i just want to say that i tryied my best to install the winmodem on redhat linux 9, and i succeeded in installing the driver. the driver of my modem is installed but when i dial a no. of ISP then i have an error message i-e

"No Dial Tone"

i tried my level best to remove this but i cant remove this error.

PLZ give me the solution of this problem

by Nick1104 on Thu, 2004-03-11 10:58
This looks like a pretty good site

by deepsa on Fri, 2004-03-12 00:55
Hi Everybody
I am using Red Hat Linux 9.0 with kernel 2.4.20-8.
I have Pctel HSP56 Modem but could not detect it through the pctel-0.9.7-6.
"make" gives many error.
Exactly the compiled kernel is based on GCC 3.2 and the drivers which comes with pctel-0.9.7-6 are compiled for GCC 2.xx.
That I thing can be the problem.
So I want drivers of the modem with kernel 2.4.20-8 support and compiled for GCC 3.2.
Anybody Help!!

by Amuro-Ray2020 on Wed, 2005-06-01 18:01
While I am still for the most part a Linux n00b, I know this from experience and from reading articles about WinModems.

Not every WinModem will work with Linux, even if you've got packages and patches that'll act as the needed software. Winmodem support is still an a fairly experimental stage in Linux, and that should be kept in mind whilst working with yet another one of Micro$oft's methods to screw over the average customer.

Good luck getting those modems to work; hopefully this guide helps you dialup users.


All times are GMT -5. The time now is 03:35 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration