Help answer threads with 0 replies.
Go Back > Linux Answers > Hardware
User Name


By TheRepublican at 2004-07-01 16:57
Getting the ATI fglrx drivers can be a real pain to someone new to linux, that said it is not too hard, and most people should be able to do it, with a little help. So, here's a step-by-step tutorial on getting X up and running with ATI's drivers. All commands should be executed at the command line (without X running, to be safe) and text in brackets ( [ ] ) should be replaced with text appropriate to your system. I assume that by reading this tutorial, you are running Linux on your computer, with some sort of X system installed, have a ATI video card, and have a monitor (duh).

1) Get the drivers.

This is the easiest part of the install, as it should be. Go to , click Linux, Graphics Driver, and your card model (doesn't really matter, all link to the same page). Grab the driver for the version of X you are using. If unsure, download the script and run sh to find out.

NOTE: at this time there are no official XFree86 4.4 drivers available, however the drivers for XFree86 4.3 have been reported to work with 4.4

2) Install the drivers.

- If using RH, SuSE, or Mandrake, install with the command rpm -Uh --force [package name]

- If using Debian, convert to .deb format with a tool like alien and install with your package manager

- If using Slack, convert to .tgz format with a tool like alien or rpm2tgz, and install with installpkg

3) Install Kernel Module.

This step may or may not be necessary on RH or other systems, but definitely was on my Slack 10 box. cd to /lib/modules/fglrx/build_mod/. Now you may need to patch your drivers, depending on your system configuration.

- If running kernel 2.6.7 or greater (I assume, 2.6.7 is the latest version at time of writing) go to , copy the text of the patch on said page and save to a text file.

- If using an AMD processor, go to and run the command in the second code box. Alternatively, copy all the text in the second code segment except the first line into a text file.

Next, for each patch you downloaded, run patch -p1 < [path to downloaded patch] in the /lib/modules/fglrx/build_mod/ directory. See man patch for more help. Now run sh Next, cd .. and run sh

4) Configure X

Almost done now. Run fglrxconfig to configure X. You will need to know information about your video card and monitor, such as V-sync range and H-sync range, all which should be covered in the video card and monitor's documentation. If unsure about something (besides V-sync and H-sync, those are important!), the safest bet is to accept the defaults. When asked to save the file, accept the default if running XFree86, or save to /etc/X11/xorg.conf if running

5) Start X

Now run startx at the command line, and with any luck you should be looking at a fresh, hardware-accelerated desktop! If not, go over the steps laid out in this tutorial again, check for potential solutions to your problems, ask around here at LQ, or finally PM me with your issue.

by BlackZeppelin on Wed, 2004-10-06 19:33
I am using the newest Mandrake distro, and I'm new to Linux
When I type the rpm -uh --force thing into the Konsole I get this message

rpm -Uh --force /home/michael/Documents/fglrx-4.2.0-3.14.1.i386.rpm
error: cannot open lock file ///var/lib/rpm/RPMLOCK in exclusive mode
error: cannot open Packages database in /var/lib/rpm

What is the problem and how do I fix it?

by heema on Thu, 2004-10-07 02:57
have u got mandrake control center opened when u tried to install it or have u been using urpmi ?

by BlackZeppelin on Fri, 2004-10-08 05:29
I've been using the Konsole, Mandrake Control Center wasn't open, and I don't know what urpmi is....

by soylentgreen on Fri, 2004-12-03 20:50
hey republican...
i've been going thru this for a while now... and i just don't know what i'm doing wrong...

i have a dell latitude c610.. ATI card...
finally found the fglrx{blahblah}.rpm
i'm using slack 10.. so i used rpm2tgz and installed it w/pkgtool
went fine... i did the patch, as described in the how-to .. saved it as patch.diff and performed the 'patch -p1 < patch.diff' in the 'build_mod' directory..
and got:

root@slacktop:/lib/modules/fglrx/build_mod# patch -p1 <patch.diff
patching file agpgart_be.c
patching file firegl_public.c
Hunk #1 succeeded at 2110 (offset 100 lines).
Hunk #2 succeeded at 2057 (offset 5 lines).

did the '' and got:

ATI module generator V 2.0
patching 'highmem.h'...
skipping patch for 'drmP.h', not needed
skipping patch for 'drm_os_linux.h', not needed
probing for VMA API version...
doing script based build for kernel 2.4.x and similar
compiling './agpgart_be.c'...
compiling './agp3.c'...
compiling './i7505-agp.c'...
compiling './nvidia-agp.c'...
compiling './firegl_public.c'...
firegl_public.c:207:1: warning: "pte_unmap" redefined
firegl_public.c:140:1: warning: this is the location of the previous definition
linking of fglrx kernel module...
duplicating results into driver repository...
You must change your working directory to /lib/modules/fglrx
and then call ./ in order to install the built module.

the did the ../ but it failed... with

root@slacktop:/lib/modules/fglrx# ./
- creating symlink
- recreating module dependency list
- trying a sample load of the kernel module
Warning: loading /lib/modules/2.4.26/kernel/drivers/char/drm/fglrx.o will taint the kernel: non-GPL license - Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY
See for information about tainted modules
/lib/modules/2.4.26/kernel/drivers/char/drm/fglrx.o: init_module: No such device
/lib/modules/2.4.26/kernel/drivers/char/drm/fglrx.o: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.26/kernel/drivers/char/drm/fglrx.o: insmod /lib/modules/2.4.26/kernel/drivers/char/drm/fglrx.o failed
/lib/modules/2.4.26/kernel/drivers/char/drm/fglrx.o: insmod fglrx failed

have any ideas? this is buggin me hard.

by SlackerLX on Mon, 2004-12-13 12:26
That did not work!
only screwed!
I had to Modify newly created Xorg by hand because it did not start the X.
And even after starting the X check this out

$ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_SGI_make_current_read, GLX_SGIS_multisample
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
GLX extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
OpenGL vendor string: Mesa project:
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.4 Mesa 5.0.2)
OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
    GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
0x23 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  1 0 None
0x24 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  1 0 None
0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  1 0 None
0x26 24 tc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  1 0 None
0x27 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  1 0 None
0x28 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  1 0 None
0x29 24 dc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  1 0 None
0x2a 24 dc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  1 0 None
Direct rendering still absent

by TheHushedCaskeT on Fri, 2005-01-28 02:54
Does this work with the 9800xt ??

by Gamezace on Sun, 2005-02-06 14:46
For people having trouble with the patches or installing the original patch in Debian, look in the following thread:

by theheffe on Sun, 2005-03-06 05:53
hey blackz i was getting the same problem, then i realized i wasn't logged in as root. maybe that's your problem too.

by Hubmasterflex on Wed, 2005-06-01 04:52
Will this also allow TV Out and other associated connections to work? Or do u need to configure TV Out differently?

by Be.Gurmeet.Be on Fri, 2005-08-05 08:26

i did the following to install my ATI Radeon XPress 200G Graphics Card Drivers.

1. i downloaded the ati driver.rpm from
2. installed it with rpm -Uvh --force [filename.rpm] . it installed successfully.
3. Then, i copied the 2 patches from on thread and saved them in /lib/modules/fglrx/build_mod directory.
and ran it . it executed successfully.
4.Then i run the command sh & sh

Here i got problem. when i run first command ,

it gives the out put
ATI module generator V 2.0
kernel includes at /usr/src/linux/include not found or incomplete
file: /usr/src/linux/include/linux/version.h

and the output of ' sh ' command is as following...

Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

Any idea.


All times are GMT -5. The time now is 10:32 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration