Share your knowledge at the LQ Wiki.
Go Back > Linux Answers > Applications / GUI / Multimedia
User Name


By dalek at 2003-08-10 22:44
Mandrake 9.1 NVIDIA driver install

This is written for newbies like myself that need details. Read the entire thing before starting this. I tried to make it as simple as possible. If you have a good downloaded file and follow this your problems should be minimal.

I'm going to assume that you can navigate using Konqueror and use a editer such as Kwrite. You should also get the basics of a command line editer called "vi" just in case the driver does not work and you need to change the driver back to the old basic one. If you have a linux book check for editers that work in commandline. That will get you back into 'x' at least. It is not really that bad to install but you have to do it in command line not through the GUI or 'x'. If you are a newbie like myself it can be scary. Especially if it doesn't work the first time. BTW, booting to 'failsafe' will not work. 'x' will crash and you will be disappointed.
Steps to take:

1: Download the driver
2: Edit the inittab and XF86Config-4 file
3: Reboot to command line and Login as 'root'
4: Install driver (Look for any errors during install)
5: Test
6: Change inittab file back to original configuration

The first thing is to download the driver and put it in the /root directory. You can get the latest driver here: You will most likely want the IA32 version, that's Intel/AMD 32 bit. Once you get that downloaded and in the proper directory, you are ready to get it installed. It's important to put it in the right directory or know exactly where it is.

You will need to edit the inittab file and the XF86Config-4 file. You will need to edit the inittab so that you will boot into the command line not into the GUI or 'x'. The inittab file is in the following location for Konqueror, file:/etc/inittab . You should have root access. The line you are looking for is "id:5:initdefault:". You will need to change the '5' to a '3'. It should look like this "id:3:initdefault:. "This will get you to a text login. It will be sort of like old DOS, no pretty screens or anything. Remember this file, you will need to change it back when you are done. Of course some leave it like this but that's up to you.

Make a note of what you change here or print a copy if you can of the original file. Now to edit the XF86Config-4 file. It should be located here, file:/etc/X11/XF86Config-4. You will need to look for and change this part 'Section "Device"'. It's about half way down the file. You will need to change 'Driver "nv"' to 'Driver "nvidia"'. This will load the drivers when 'x' starts. Now look for the part 'Section "Module"'. It's pretty close to the top. Look for a line that says 'Load "dri"' and 'Load "GLcore"'. If you have these lines put a '#' in front of them. The system will then ignore those commands. I don't like deleting, if you have to switch back this will make it easier. Now, in the same section look for a command 'Load "glx"'. It should already be there but make sure it is. It needs to be there. Don't delete it. You have now got your XF86Config-4 file ready. Click 'save'.

Now comes the part that is a bit new for newbies that have not used other distro's and are not used to the command line and login. It's time to reboot. When you reboot you will not get Xwindow or a GUI. You will get a login prompt. When you get the prompt type in 'root' and hit enter. Type in your password. You are ready to install your driver. If you put the file in the right directory this should be very easy. Type in 'ls'. The NVIDIA driver should be right there in the list.
If it's not there try typing in 'cd ..' and hit enter. Then type in 'cd /home/<user name>/Desktop'. Replace <user name> with your user name, mine would look like this for example '/home/dale/Desktop'. Do a 'ls' and see if it is there. If it is not try this 'cd ..' and then type in 'cd Documents', do a 'ls' and see if it is there. If by now you have found the file, you are ready to go.
This part is easy. Type in 'sh ' and the name of the file exactly like it is on the screen. It is case sensitive and put a space between sh and the file name. You should get a screen that says loading, then accept the agreement etc. Use the arrow keys to change your selection. No mouse here, sorry. Just let it walk you through. When it gets done with the install, you will be back at the prompt. If you get a error write it down and skip to the shutdown part or edit the XF86Config-4 file back to the way it was and type 'startx'. If you get no errors, type in 'exit'. You will be back at the login and will take you out of root. Login in as a regular user, mine for example would be 'dale' then type in your password. When you get the prompt, type in 'startx' and hit enter. 'x' should start. If it works you will see a white screen with a graphic and 'NVIDIA' in the middle. If you have this, the install was sucessful.
If you don't get this something went wrong. You will get a error message when 'x' shuts down. The important part will start with (EE). Write this info down and see if you can find a post that will help you diagnose the problem. If you can't find the error and need help, post with the subject "Mandrake 9.1 NVIDIA" and some of the error message. Put the entire error in the post. Someone will have run into and fixed or will know what the error means and how to fix.

If you have a error, you will need to change the XF86Config-4 file back like it was. You can do a 'cd ..' until you get to root, '/', then type in 'cd etc', then 'vi XF86Config-4'. This will let you edit the file back to the way it was. The really important part is to change 'nvidia' to 'nv' like it was. Hope you have the 'vi' info handy. It's a bit tricky for a newbie but I survived with out much damage. Just change the file back and save and exit the editor. When you get back to the prompt, type in 'startx' and it should get you back into the GUI with the old set of drivers. If you had rather just reboot into windows to get help you can type in 'shutdown -r now'. This will reboot your system and you will have the option to get windows as usual when it restarts.

If all worked well and you want to change so that 'x' starts automatically, you will need to change the file 'inittab' back to '5' like it was before this install. You can leave it this way if you want. Some people do this anyway. To get into 'x' if you want to do it this way, just type in your login and password then 'startx'. When you exit, logout, of 'x' it will take you back to the prompt, just type in exit and you will get a login. Login as root, and type in 'shutdown -r now' to reboot or 'shutdown -h now' to turn off your system. If you change the 'inittab' file back to '5' it will boot like it used to.

Hopefully you will have had success. If so, I hope this 'how to' helped. I tried to make it for a newbie. There are other ways to do it but this way if there are no problems most is done in a GUI. This is much easier for a newbie.

by metros on Tue, 2003-08-12 16:51
those are the steps i followed while trying to set up mandrake with my nvidia geforce4 128meg integrated card... although im using mandrake 9.0 instead of 9.1... anyway I've seen that those steps work perfect for many people but it didn't for me.

so if it doesnt work for you, you can check the thread that I started about my problem...

i'll post the resolution as soon as i can figure out how to get the damn things to work...

by metros on Fri, 2003-08-15 15:38
well, i figured out that my problem was with X, not with the nvidia drivers. i reinstalled all of mandrake from scratch and followed those instructions again and now it works perfect.

by matador on Mon, 2003-08-18 17:37
I don't know about the rest of you but my installation went as smooth as a baby's butt thanks to this excellent manual

Thanks mate!

by Proud on Tue, 2003-08-19 13:33
There's no need to edit /etc/inittab and reboot twice, see my link in my sig.

by kr381 on Mon, 2003-09-01 22:42
Being a windows user I don't mind clicking around under the "hood" but windows is windows and Linux is whole different animal.

I downloaded RH9 to see how Linux looked. Install went great except X screen was only 6x6. I tried for couple of days reading docs and book that finally went and bought. I guess at 50, it is hard to teach old dog new tricks, but your tutorial got me headed in the right direction. Now if can get icons and resolution set , I be set. At least I am looking at whole screen.

Thanks again,


by dalek on Tue, 2003-09-02 09:32
Trying to make it as easy on the newbies as I could. Yes it can be done without a single reboot. I have done it. You basically just skip the inittab part and goto a term as root and type in "init 3". When you get through you just type in as root "init 5". Done.

Newbies may not like a whole lot of command line stuff. They may even freak out when x goes away. I did.

For all that liked it, your welcome. I have actually redone the how to. It just looks better. Same info.

by bigfoot1966 on Mon, 2003-10-27 21:11
WOW...finally a really really easy how to for newbs like me
These steps worked flawlessly. I wish I would have read this post before I tried to follow the nvidia site how to. Still wiping up the tears from my 2 fresh installs when x didn't boot up. Thanks alot "cheers"

by Lando on Fri, 2003-11-14 01:13
Awesome, finally a set of instructions I could follow and actually get to work.
Maybe you should think about writing a book for all the Linux NooB's like me.

by dalek on Fri, 2003-11-14 08:43
Na, the next is going to be doing it without a reboot. I do wish this how to was easier to find though. It is way down the list.

I have gotten messages that it works in a lot of distros. It does not work in Gentoo. I have that installed too.

This thing is on a lot of forums and even a website or two. They 'borrowed' it I guess.

Glad it helps you guys though. If you can, download 'nano' from here

I have used this version: nano-1.2.2-2mdk.i586.rpm

This thing is much easier than vi. I would recommend it just in case you have some problem and need to change a file in command line or rescue something. It is very easy compared to vi.

The command to edit a file is

nano -w <filename>
You do a control x to finish then y(es) to save then hit enter to save to the same file without changing the name. Try it on a couple of test files. It is really nice.


Noobie book? That would be huge. By the time I finished, it would be out of date. I may work on some things though. I'll try to keep it simple.

by Infinite Monkey on Mon, 2003-11-17 09:14
The installer tells me it needs to compile a kernel interface for my kernel. I've installed the kernel-sources for my distribution (actually Mandrake 9.2) but I'm still having problems.

I get the following error message, but being a complete newbie it's rather unhelpful to me:

ERROR: Unable to load the kernel module 'nvidia.o'. This is most likely
because the kernel module was built using the wrong kernel header files.
Please make sure you have installed the kernel header files for your
kernel; on Red Hat Linux systems, for example, be sure you have the
'kernel-source' rpm installed. If you know the correct kernel header
files are installed, you may specify the kernel include path with the

Can anyone out there tell me what I need to do next?

Thanks in advance,


All times are GMT -5. The time now is 07:27 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration