Help answer threads with 0 replies.
Go Back > Linux Answers > Applications / GUI / Multimedia
User Name


By woolfrey at 2004-11-28 17:17
Wireless and touchpad now work on my Toshiba A70 using Fedora Core 3. Sound is very faint and I believe needs a sound patch, and I have not tried to make power management work yet.

I found all of the material related to making wireless and the touchpad work somewhere on the 'net, and I thank all of the people who posted information. The following is not really new, but I hope it provides an integrated set of steps that will save time for others with this machine.

Toshiba A70
If you are not familiar with the machine, it is a relatively inexpensive laptop with a wide-aspect (15.4") screen. It has integrated wireless and a touchpad. (Note to Toshiba: I wish you hadn't discontinued the trackpoint mouse for lower-end machines; I find the prevalence of touchpads to be quite unfortunate. I almost bought a low-end ThinkPad for this reason alone.)

The machine is around 8 lbs, so is best for use at home with the convenience of being able to move it around easily; it is not designed for road warriors who need lightweight machines. Microsoft XP Home Edition is included.

I have always liked Toshiba laptops, and a PC repair guy I know says they are well made and straightforward to repair, unlike some other popular machines.

BTW, the A70 does not come with any Windows software that can burn ISO images, as far as I can tell. The version of RecordNow that is shipped does not appear to have that capability, though the documentation says it does. Sonic Software indicated to me that the capabilities of RecordNow that are shipped with Toshiba and other machines is configured by the manufacturer. If I am wrong on this I would appreciate being advised. Fortunately, I have another machine that has ISO burning software that I used to burn the Core 3 CDs.

Disk Partitioning
I used PartitionMagic (commercial) to re-partition my hard drive. I placed a primary partition of about 75MB at the beginning of hard drive for the boot loader, and a 6GB primary partition at the end of the drive for Linux Fedora Core 3. I also created a 6GB Fat32 partition so I could share files between WinXP and Linux. (From the tone of the Linux NTFS material, it sounds to me that some smart people are working on NTFS support for Linux, but it does not seem to be ready for prime time; I could be wrong on this.)

Fedora Core 3 Installation
Core 3 installed quite easily. I formatted the 75MB partition for "/boot", and placed the boot loader (GRUB) in that partition. The other 6GB primary is "/". I did not create a SWAP partition this time.

The wide aspect screen was recognized. The touchpad was not recognized, so I used an external USB mouse until I could get the touchpad working (see below). Wireless also did not work initially (see below).

Activating the Touchpad
I used the dumb-simple approach of changing the BIOS setting to disable legacy USB support. This gives basic touchpad support in Linux without scrolling and other capabilities available with WinXP; changing this BIOS setting does not affect WinXP touchpad behavior, though it may have other effects I don't know about yet. I saw references to an ALPS kernel patch that apparently provides full support, and I may try that later.

Activating Wireless
As an experiment, I tried a Linksys PCMCIA card. It was recognized immediately, and I was able to configure it with WEP encryption with the "Managed" option. It worked fine.

To enable the built-in Atheros wireless device, I tried some RPMs that were for Core 2, but they did not work with Core 3. In the end, I obtained the current cvs source from MadWifi (madwifi-cvs-current.tar.gz) and followed these steps based on the accompanying README:

1. From the Core 3 CD #4, I installed the Linux kernel source under /usr/src. It is compressed in bz2 format, and can be uncompressed using 'bunzip2'. "sharutils" also must be installed from CD #4, in order to get "uudecode", which is used by the MadWifi 'make' file.

2. I un-tarred madwifi-cvs-current.tar.gz under /usr/src. Following the README, I did a 'cd' into the madwifi directory, and ran 'make', 'make install', and 'make clean'. Many warning were generated, but they didn't seem to matter.

3. When I re-booted the machine, the built-in wireless device was recognized. I configured it as "Managed" with the name of my wireless router and set up WEP encryption; note that the WEP key must start with '0x' if entering the key in hex. After another re-boot, wireless worked.

At some point, I found that a Linux re-boot seems to shut of screen; I need to do a complete shut down then a power-on. I would appreciate any advice about this.

Next tasks include getting sound to work properly (I saw a reference to a patch AC97 that I will follow up), and to try to get power management working.

by faust_in_linux on Sat, 2005-04-02 20:23
The solution to the sound work properly was given us by Tutle. Look at this post:


All times are GMT -5. The time now is 08:17 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration