LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Zenwalk
User Name
Password
Zenwalk This forum is for the discussion of Zenwalk Linux.

Notices



Reply
 
Search this Thread
Old 01-06-2007, 10:35 PM   #1
spoofyou4life2007
LQ Newbie
 
Registered: Jan 2007
Posts: 3

Rep: Reputation: 0
ZenWalk Will not Boot Lilo Boot Problem


Ok I just got the zen live cd today. I have tried to install it three times with no luck. I did get through the set up, have master, swap, and all the partitions correctly. I think the problem is when it trys to install the lilo boot system. I tried doing it in auto and tried to do it maunal. No mater what when my system goes to boot up on the hard drive there is a boot error and it says mbr1 and mbr3. Will not go any further.. Any help on why the lilo boot system is not loading.. is there any way to get this to boot with out the lilo boot system??? This is my first time using linux any help would be great.. Thank you

Last edited by spoofyou4life2007; 01-06-2007 at 10:36 PM.
 
Old 01-06-2007, 11:56 PM   #2
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
Quote:
Originally Posted by spoofyou4life2007
No mater what when my system goes to boot up on the hard drive there is a boot error and it says mbr1 and mbr3.
Is that the complete message? If so, it makes no sense to me.

Usually when you install, you are given a choice to install LILO on the MBR (the first 512 bytes of the disk) or on a particular partition's boot record. You should tell it to insall on the MBR if that is how you want your computer to boot.

If that fails you can try GRUB instead of LILO. I believe most current distros use GRUB. If this is not offered on Zenwalk, you should be able to use a live CD like KNOPPIX to install it. Google for how to do this. You could also use a live CD to try to force the LILO provided with Zenwalk to do what you want. But this would take some more explaining.

Quote:
is there any way to get this to boot with out the lilo boot system???
Does Zenwalk give you the option to create a floppy rescue disk when you install it? If so, you can boot from that.
 
Old 01-07-2007, 12:13 AM   #3
spoofyou4life2007
LQ Newbie
 
Registered: Jan 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks

ok thanks, I did look into the grub, I will look at that more. I can load morphix live cd and it works fine but that is only a kiosk version of it. I am new to linux and am going to download a few of the others out there to see what I like and dont.. Thanks for your help, im try to install grub from the knopix cd.. I may just install knopix instead. I dont have to have zenwalk and prob is not a good package to learn linux with.. Thanks again for your help.
 
Old 01-07-2007, 05:30 AM   #4
guth
Member
 
Registered: Aug 2006
Location: France
Distribution: Zenwalk
Posts: 132

Rep: Reputation: 15
Quote:
Originally Posted by spoofyou4life2007
Ok I just got the zen live cd today.
humm what iso did you get ?
- ZenLive (ZENwalk LIVE cd) is not an install CD.
- Zenwalk (4.2 released yesterday) is an install cd.

(i guess it's ZW 4.2)

Quote:
I have tried to install it three times with no luck. I did get through the set up, have master, swap, and all the partitions correctly. I think the problem is when it trys to install the lilo boot system. I tried doing it in auto and tried to do it maunal. No mater what when my system goes to boot up on the hard drive there is a boot error and it says mbr1 and mbr3. Will not go any further.. Any help on why the lilo boot system is not loading.. is there any way to get this to boot with out the lilo boot system??? This is my first time using linux any help would be great.. Thank you
which type of disks have you?
which filesystem did you choose ?
Did you read zenwalk manual (might be helpful for an install "step by step"):
http://manual.zenwalk.org/
 
Old 03-22-2007, 06:40 AM   #5
mirceaar
LQ Newbie
 
Registered: Mar 2007
Posts: 1

Rep: Reputation: 0
I have a similar problem.
I tried to install ZL 4.4.1 and it all went smooth until the end, when it asks for LILO install.
In automatic mode I try to install on MBR on /dev/sda, and it hanged at first. For a few minutes, until I lost my patience.
I reinstalled it and went for expert LILO install. Same thing.
Again, expert install, and wanted to install LILO on floppy. I got a long error message, that it could not be installed.
Again, tried to install on MBR, this time I get same error as above.
I slipped in Mdk 9 install CD, as I use it to recover the Windows boot when it's the case. I get an error that it cannot repair a damn thing.
Now, on this system I had PCLinuxOS and DreamLinux, and they all ran like a charm.
The system is a P3@1.3GHz w/ a Intel 815 chipset, with a 250GB IDE HDD and an IDE 40GB where I keep among others the Linux installs too. the 250GB made some problems, as it flollows:
- the BIOS is set to Auto/Auto for this IDE device, and it sees it as a 136 GB HDD.
- when I got the HDD I wanted to install Win XP on it. No luck, the setup just hanged. I installed Win 2k, which installed without a glitch (sic). Then I upgraded to Win XP without a problem, and installed the latest Intel drivers for the chipset.
- after thet I did installs of PCLinuxOS and later of DreamLinux, which ran w/ no problem.
Any help...?
I'll try to install either PCLinuxOS or Vector tonight, but just was curious about Zenwalk
 
Old 03-22-2007, 11:59 AM   #6
alienDog
Member
 
Registered: Apr 2004
Location: Europe
Distribution: Debian, Slackware
Posts: 505

Rep: Reputation: 46
Hmm... maybe you have write-protection for MBR enabled in BIOS? Some BIOSes call it (misleadingly) virus protection or something like that. Just a thought...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Zenwalk install disc will not boot. Current system Windows 98. ImperfectionCaught Zenwalk 9 11-04-2006 08:41 PM
Tri-Boot xp/zenwalk/slack sicness Slackware - Installation 3 11-11-2005 07:32 PM
Need help fixing boot problem on Ubuntu/WinXp dual-boot Ay-Karamba! Linux - General 5 09-06-2005 10:20 PM
solaris boot problem boot error loading interpreter(misc/krtld) Johncy_j Solaris / OpenSolaris 5 08-18-2005 02:47 AM
problem with Installing red hat linux dual boot(/boot < for 1024 cylinders ) praveenb Linux - Newbie 2 02-13-2004 09:49 PM


All times are GMT -5. The time now is 06:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration